[ACK] Smart Tags broken in 6.3 SR1

Page 3 of 10 (191 items) < Previous 1 2 3 4 5 Next > ... Last »
This post has 190 Replies | 16 Followers

Posts 20
Jeff Weaver | Forum Activity | Replied: Wed, Jun 10 2015 9:19 AM

I got the same message... so far no solutions.

Patiently we wait!!!

Jeff

Posts 20
Jeff Weaver | Forum Activity | Replied: Wed, Jun 10 2015 9:21 AM

Thanks Bryan!

I tried it again with same results. I even had someone else read me the commands and then we both verified. I see now another person is having the same problem below. 
Jeff

Posts 12
Paul Carpenter | Forum Activity | Replied: Wed, Jun 10 2015 9:34 AM

All I can say to that is Amen! and Amen!

Paul

Posts 3659
BillS | Forum Activity | Replied: Wed, Jun 10 2015 2:13 PM

Bryan Albert:

...

  1. Open a Command Prompt (hit the Windows key, then type command prompt and choose Command Prompt from the list.
  2. In the Command Prompt, type cd C:\Users\YOU\AppData\Local\Logos Enter, where You is your Windows user name. You can hit the Tab key while you're typing and it will cycle through matching folder names (such as your user name when you get to the C:\Users\ part). Note also that if you upgraded from Logos 4 or Logos 5, the name of the Logos folder could be Logos4 or Logos5.
  3. Type Logos.exe /register Enter, you should see a dialog that says, "Logos Bible Software was registered successfully." 
  4. If you are running a 64 version of Windows, you'll need to register the Smart Tags dll manually: Type C:\Windows\System32\regsvr32.exe 6.3.0.0074\L4SmrtTg.dll Enter. You should see a dialog that says, "DllRegisterServer in 6.3.0.0074\L4SmrtTg.dll succeeded." 

... 

Bryan

This restored SmartTags for me, too, upon installing Logos Bible Software 6.3 SR-26.3.0.0074.

My config is in my signoff.

Grace & Peace,
Bill


Asus GF63 8RD, I-7 8850H, 32GB RAM, 1TB SSD, 2TB HDD, NVIDIA GTX 1050Max
Samsung S9+, 64GB
Fire 10HD 64GB 7th Gen

Posts 24851
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Jun 10 2015 4:02 PM

all4als:
I received this message. Is there anything further that I could do?

Please show the complete command in a screenshot. Are you sure you have the correct Logos/Verbum folder name?

Dave
===

Windows & Android

Posts 1646
SteveF | Forum Activity | Replied: Wed, Jun 10 2015 6:45 PM

Bryan Albert:
we do have an experimental 64 bit Smart Tags dll, see https://wiki.logos.com/Smart_Tags#Smart_Tags_for_64-bit_Office. Some users have had success with that.

This worked for me tonight.

Regards, SteveF

Posts 92
Christopher Powell | Forum Activity | Replied: Thu, Jun 11 2015 11:00 AM

Thanks for the attempts, but, none of the wiki options or regedits worked for me.  I've done everything here and followed the instructions on the wiki - even tried the custom dll.  Nothing.  Wish I could go back in time.  Any ideas?

Posts 42
LogosEmployee
Bryan Albert | Forum Activity | Replied: Thu, Jun 11 2015 2:24 PM

We've created a Windows PowerShell script (the modern equivalent of a Command Prompt batch file) to register Logos COM and Logos Smart Tags for 32 bit Office. On most Windows versions, PowerShell comes with script execution disabled by default, so if you haven't already, you'll need to set the PowerShell execution policy to allow script execution, as described in step 1. 

  1. Run PowerShell as Administrator (Windows key, type PowerShell, right-click on Winodws PowerShell in the list and choose Run as administrator, click Yes on the User Account Control dialog). In the PowerShell window, type Set-ExecutionPolicy RemoteSigned <Enter>. Hit <Enter> to make the change. Close PowerShell.
  2. Download the RegisterSmartTags.ps1 script from http://downloads.logoscdn.com/LBS6/Support/RegisterSmartTags.ps1.
  3. In Windows Explorer, find the script, right-click and choose Run with PowerShell. Since the script is signed by Logos Bible Software, choose Open from the Open File - Security Warning dialog, if displayed.
  4. The script calls RegSvr32.exe to register the Logos Smart Tags dll, L4SmrtTg.dll, which should display a RegSvr32 dialog message similar to, "DllRegisterServer in C:\Users\Bryan\AppData\Local\Logos\6.3.0.0074\L4SmrtTg.dll succeeded.", click OK.
  5. The PowerShell window should list details about registering, ending with the message "Finished successfully. Hit a key to exit..." Logos COM and Logos Smart Tags for 32 bit Office should now be registered.
  6. If you see an error message, such as "Failed to...", please post back here and I'll check it out, otherwise hit any key to exit PowerShell.

You can also register COM and Logos Smart Tags for Verbum and Noet:

  1. Open PowerShell (Windows key, type PowerShell and click)
  2. type cd <path-to-RegisterSmartTags.ps1> <Enter>, e.g. cd C:\Users\Bryan\Downloads <Enter>
  3. type RegisterSmartTags.ps1 -Noet <Enter> or RegisterSmartTags.ps1 -Verbum <Enter>

Hopefully this script will help resolve any lingering COM registration issues. Please let me know if you have problems or questions.

Thanks,

Bryan

Posts 50
all4als | Forum Activity | Replied: Wed, Jun 17 2015 8:54 AM

Dave,

Thanks for the response. I have a Logos folder with only an Install folder inside of it (i.e. Local\Logos\Install) and a Logos5 folder with 2 different smart tag files. One file located in Local\Logos5\6.3.0.0056\L4SmrtTg.dll and another in Local\Logos5\6.3.0.0074\L4SmrtTg.dll. 

Does that help at all? I really like smart tags convenience and believe it to be a selling point, but can live with copy paste.

John 14:15

Posts 1
David Matti | Forum Activity | Replied: Wed, Jun 17 2015 3:14 PM

Bryan Albert,

Thanks for the instructions for using the Windows PowerShell script. It fixed my problem with Logos and Paratext not scrolling together. I think the scrolling problem started after the latest update from Logos since it was working fine before that.

David Matti

Translation Consultant

SIL Islands Asia

Posts 50
all4als | Forum Activity | Replied: Thu, Jun 18 2015 8:56 AM

Bryan,

Thank you. This also worked for me. However, the first time I attempted your fix I had a space between Remote and Signed and it did not work. Then going back and removing the space, everything worked exactly how you have it detailed step by step. After all of this do I need to run PowerShell as administrator again and Set the Execution Policy back to No?

Thank you for all of your help, and for everyone's suggestions!

John 14:15

Posts 42
LogosEmployee
Bryan Albert | Forum Activity | Replied: Thu, Jun 18 2015 9:42 AM

all4als:

However, the first time I attempted your fix I had a space between Remote and Signed and it did not work. 

That is unfortunate that the rendering of RemoteSigned in the forum post appears to have a space in it, in fact it does not! I suppose remotesigned would not have that issue and would work just as well. 

I'm glad it worked for you!

Bryan

Posts 23
Nelson E Aguillon | Forum Activity | Replied: Sat, Jun 27 2015 12:08 PM

I am also having issues applying the fix... my system does not like the command please see the attached screen shot.  I need help!!

Posts 4595
Forum MVP
Fred Chapman | Forum Activity | Replied: Sat, Jun 27 2015 12:48 PM

The error message you are getting point to a path problem.

Are you running 32 bit or 63 bit office? If 32 bit then try running the Powershell available in Bryan's post 

Posts 23
Nelson E Aguillon | Forum Activity | Replied: Sat, Jun 27 2015 12:58 PM

I´m running the 32 bit office, so I will try the Powershell.  

Thank you very much!!

Blessings,

Nelson A.

Posts 23
Nelson E Aguillon | Forum Activity | Replied: Sat, Jun 27 2015 1:26 PM

Bryan,

My name is Nelson Aguillon, and I just tried running the Powershell. It failed.  Please the attached screen shot.  

Thank you,

Nelson A.

Posts 24851
Forum MVP
Dave Hooton | Forum Activity | Replied: Sat, Jun 27 2015 3:12 PM

Nelson E Aguillon:
My name is Nelson Aguillon, and I just tried running the Powershell. It failed.

Does the path to ...\Logos5 exist? Does the folder 6.3.0.0074 exist?

Dave
===

Windows & Android

Posts 23
Nelson E Aguillon | Forum Activity | Replied: Sun, Jun 28 2015 12:08 AM

I will check and post my reply.  

Thank you,

Nelson

Posts 23
Nelson E Aguillon | Forum Activity | Replied: Sun, Jun 28 2015 10:39 PM

Dave,

I did a search for the two items (I hope I did it correctly, I am not an expert at this) and I took screen shots of the results.

Thank you,

Nelson

Posts 24851
Forum MVP
Dave Hooton | Forum Activity | Replied: Mon, Jun 29 2015 5:08 PM

I'm not sure why PowerShell failed as the Logos folders do exist. Does LogosCom.exe exist in the 6.3.0.0074 folder?

Dave
===

Windows & Android

Page 3 of 10 (191 items) < Previous 1 2 3 4 5 Next > ... Last » | RSS