[ACK] Smart Tags broken in 6.3 SR1

Page 4 of 10 (191 items) « First ... < Previous 2 3 4 5 6 Next > ... Last »
This post has 190 Replies | 16 Followers

Posts 23
Nelson E Aguillon | Forum Activity | Replied: Tue, Jun 30 2015 4:06 PM

Brother Dave,

There is only one file inside the folder.  Please take a look at the attached screen shot.

Thank you,

Nelson

Posts 24842
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Jun 30 2015 4:25 PM

The smart tag doesn't appear to be the correct version, never mind it being the only file!

Update to the latest version 6.4 as that will provide a new 'system' folder and try PowerShell again if the update itself does not fix Smart Tags

Dave
===

Windows & Android

Posts 23
Nelson E Aguillon | Forum Activity | Replied: Tue, Jun 30 2015 4:43 PM

Dave,

Just making sure... update the whole Logos application?

Nelson

Posts 23
Nelson E Aguillon | Forum Activity | Replied: Tue, Jun 30 2015 4:47 PM

Correction,

I´m actually running this version... 

Logos Bible Software 6.4
6.4.0.0037

Nelson

Posts 24842
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Jun 30 2015 4:59 PM

Smart Tags should now work from files in the folder 6.4.0.0037

Dave
===

Windows & Android

Posts 23
Nelson E Aguillon | Forum Activity | Replied: Tue, Jun 30 2015 6:10 PM

No, Dave.  I started having the problem when I upgraded to version 6.4.

I am right where I started

Nelson

Posts 149
Timothy Brown | Forum Activity | Replied: Tue, Jun 30 2015 7:23 PM

Bryan Albert:

We've created a Windows PowerShell script (the modern equivalent of a Command Prompt batch file) to register Logos COM and Logos Smart Tags for 32 bit Office. On most Windows versions, PowerShell comes with script execution disabled by default, so if you haven't already, you'll need to set the PowerShell execution policy to allow script execution, as described in step 1. 

  1. Run PowerShell as Administrator (Windows key, type PowerShell, right-click on Winodws PowerShell in the list and choose Run as administrator, click Yes on the User Account Control dialog). In the PowerShell window, type Set-ExecutionPolicy RemoteSigned <Enter>. Hit <Enter> to make the change. Close PowerShell.
  2. Download the RegisterSmartTags.ps1 script from http://downloads.logoscdn.com/LBS6/Support/RegisterSmartTags.ps1.
  3. In Windows Explorer, find the script, right-click and choose Run with PowerShell. Since the script is signed by Logos Bible Software, choose Open from the Open File - Security Warning dialog, if displayed.
  4. The script calls RegSvr32.exe to register the Logos Smart Tags dll, L4SmrtTg.dll, which should display a RegSvr32 dialog message similar to, "DllRegisterServer in C:\Users\Bryan\AppData\Local\Logos\6.3.0.0074\L4SmrtTg.dll succeeded.", click OK.
  5. The PowerShell window should list details about registering, ending with the message "Finished successfully. Hit a key to exit..." Logos COM and Logos Smart Tags for 32 bit Office should now be registered.
  6. If you see an error message, such as "Failed to...", please post back here and I'll check it out, otherwise hit any key to exit PowerShell.

You can also register COM and Logos Smart Tags for Verbum and Noet:

  1. Open PowerShell (Windows key, type PowerShell and click)
  2. type cd <path-to-RegisterSmartTags.ps1> <Enter>, e.g. cd C:\Users\Bryan\Downloads <Enter>
  3. type RegisterSmartTags.ps1 -Noet <Enter> or RegisterSmartTags.ps1 -Verbum <Enter>

Hopefully this script will help resolve any lingering COM registration issues. Please let me know if you have problems or questions.

Thanks,

Bryan

Nelson, smart tags were not working for me in Logos 6.4. I followed the instructions above and they are now working. I recommend following Bryan's instructions.

Windows 8.1 64-bit, Core i5-3330, 8GB RAM

Posts 23
Nelson E Aguillon | Forum Activity | Replied: Tue, Jun 30 2015 8:45 PM

IT WORKED!!!

I am happy again Smile

Thank you Timothy and EVERYBODY else for your patience and priceless help.

Blessings,

Nelson A.

Posts 4595
Forum MVP
Fred Chapman | Forum Activity | Replied: Wed, Jul 1 2015 5:06 AM

Good to hear. Good work

Posts 23
Nelson E Aguillon | Forum Activity | Replied: Tue, Jul 7 2015 1:24 PM

Hello everyone,

The original problem came back!!!

The solution to my problem worked TEMPORARILY.  The smart tags option is not available.  I did not make any changes to my system.  The solution worked for a couple of days, and then, it put back to where I started.  

Any ideas from anyone?

Thank you,

Nelson A.

Posts 24842
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Jul 7 2015 5:07 PM

Nelson E Aguillon:
Any ideas from anyone?

What have you done to restore it (from previous suggestions)? What version of Logos and how did you update?

A previous screenshot shows you have a C:\Windows.old folder. Whilst it won't help here, you can permanently delete that folder as it is a previous version of your Windows operating system.

Dave
===

Windows & Android

Posts 23
Nelson E Aguillon | Forum Activity | Replied: Wed, Jul 8 2015 4:55 PM

Never mind, Dave.  

I was able to reapply Ryan's fix and the issue was resolved, again Smile

Hopefully, it will stay that way.  

Thank you for the suggestion about the Windows.old file.  I got rid of it also.  

Blessings,

Nelson 

Posts 24842
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Jul 8 2015 6:47 PM

Nelson E Aguillon:
I was able to reapply Ryan's fix and the issue was resolved, again 

I don't understand why it was necessary, but create a new thread should it reoccur.

Dave
===

Windows & Android

Posts 12
Paul Carpenter | Forum Activity | Replied: Wed, Jul 8 2015 8:51 PM

Friends,

My smart tags failed again after a recent update, and this plan worked beautifully to restore that critical function. 

Thanks!!!

Paul

Posts 3658
BillS | Forum Activity | Replied: Thu, Jul 9 2015 12:48 PM

6.4 SR2 broke my Smart Tags, too. Since I executed the script right AFTER updating to SR3 (I couldn't tell from L6's notification message whether it was a resource update or a software update, & I was expecting resources), I don't know which fixed the problem Either way, it's fixed now.

 

Grace & Peace,
Bill


Asus GF63 8RD, I-7 8850H, 32GB RAM, 1TB SSD, 2TB HDD, NVIDIA GTX 1050Max
Samsung S9+, 64GB
Fire 10HD 64GB 7th Gen

Posts 7
Robert J. Landon | Forum Activity | Replied: Wed, Jul 22 2015 8:45 AM

OK, I have joined the broken Smarttags club at Logos. For me, it is now broken with 6.4 SR-3. I am running a Windows 7 64 bit system with 64 bit Office 2013.

I think I've tried everything. I tried registering L4SmrtTg.dll again. It seemed to register OK. But when I right click a reference Word "stops responding" for several minutes before finally coming out of the "waiting" and nothing has happened.

I tried using the powershell script. Still broken.

I tried registering LSmtTg64.dll, and I get the message that it successfully registers, but Word 2013 never sees anything except the L4SmrtTg.dll

I know that the right click of references worked fine up until a few weeks ago. I can only surmise that 6.4 SR-3 breaks the feature again, but it seems no one else is commenting about it in the forum.

I would appreciate any help I can get. I don't use the feature every day, but I do have a project right now where it would save me a lot of work and hassle.

Thanks.

Bob Landon

Posts 24842
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Jul 22 2015 5:11 PM

Robert J. Landon:
OK, I have joined the broken Smarttags club at Logos. For me, it is now broken with 6.4 SR-3. I am running a Windows 7 64 bit system with 64 bit Office 2013.

It's also broken for me on a similar system with 32 bit Office 2013 and it was working in previous versions.

I have tried ALL the fixes!

Dave
===

Windows & Android

Posts 149
Timothy Brown | Forum Activity | Replied: Wed, Jul 22 2015 5:38 PM

This is no help, but smart tags are working for me with 6.4 SR-3, 32 bit MS Office and Windows 8.1. They were broken previously and I used Bryan's fix (above) at the end of June.

Windows 8.1 64-bit, Core i5-3330, 8GB RAM

Posts 7
Robert J. Landon | Forum Activity | Replied: Thu, Jul 23 2015 7:24 AM

The first time I commented on my problems with smart tags I think I may have misdirected the post. Here is what I wrote:

OK, I have joined the broken Smarttags club at Logos. For me, it is now broken with 6.4 SR-3. I am running a Windows 7 64 bit system with 64 bit Office 2013.

I think I've tried everything. I tried registering L4SmrtTg.dll again. It seemed to register OK. But when I right click a reference Word "stops responding" for several minutes before finally coming out of the "waiting" and nothing has happened.

I tried using the powershell script. Still broken.

I tried registering LSmtTg64.dll, and I get the message that it successfully registers, but Word 2013 never sees anything except the L4SmrtTg.dll

I know that the right click of references worked fine up until a few weeks ago. I can only surmise that 6.4 SR-3 breaks the feature again, but it seems no one else is commenting about it in the forum.

I would appreciate any help I can get. I don't use the feature every day, but I do have a project right now where it would save me a lot of work and hassle.

Thanks.

I've tried everything suggested in the thread, but without success. I am hoping there will eventually be a solution.

Thanks.

Bob Landon

Posts 24842
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Jul 23 2015 4:30 PM

Robert J. Landon:
I've tried everything suggested in the thread, but without success. I am hoping there will eventually be a solution.

After commenting it was also not working for me, it starting working when I tried it later that day!

Dave
===

Windows & Android

Page 4 of 10 (191 items) « First ... < Previous 2 3 4 5 6 Next > ... Last » | RSS