Logos 6 Hyperlinks

Page 1 of 1 (5 items)
This post has 4 Replies | 1 Follower

Posts 127
John Marino | Forum Activity | Posted: Sat, Dec 12 2015 7:15 AM

One of the most valuable features of Logos for me when it comes to taking notes is the ability to add hyperlinks. My various notes documents are filled with hyperlinks to primarily commentaries. I have noticed an inconsistency for some time, and wondering if anyone else was experiencing this, or if it was just me...

My usual process is that I highlight a sentence which I desire to hyperlink to, then press Ctrl+Alt+C (for PC), or I click on "Copy Location As: URL." Most of the time it copies the location correctly. Occasionally it will incorrectly default to copying the location of the top of the page, rather than the location at which I highlighted the sentence (perhaps half-way down the page).

Once it starts hyperlinking in this "mode," it usually takes some time for it to revert back to the "normal mode" for hyperlinks. I have not tracked it every time, but I believe that it will revert back if I restart the software.

Has anyone else experienced this? Is this a bug unique to my device? Is there some kind of setting to change the "default hyperlink location" or something?

Posts 27775
Forum MVP
JT (alabama24) | Forum Activity | Replied: Sat, Dec 12 2015 9:39 AM

Likely you will need to give explicit examples. Are the ones which aren't working VYRSO resources rather than Logos editions? 

OSX & iOS | Logs |  Install

Posts 127
John Marino | Forum Activity | Replied: Sat, Dec 12 2015 11:37 AM

It does not seem to be resource specific. In fact it sometimes even changes within the same resource. Here is one from NICOT that I took a couple days ago...

logosres:nicot34na;ref=BibleBHS.Hab3.16;off=2983

That same hyperlink taken today is in the following format...

logosres:nicot34na;ref=BibleBHS.Hab3.16;off=2983;ctx=n_of_the_righteous$3F$0A~The_last_portion_of_

Both are the same exact location. The second hyperlink is the "correct" version that I am looking for. In the first hyperlink, I had to manually scroll down the page so that the sentence I wanted was lined up at the top of the page. Even though the sentence I was looking for was highlighted, it still pulled the hyperlink from the top of the page rather than from the highlight. Interestingly enough, when I take a hyperlink from that same resource today, it correctly pulls it from wherever I have highlighted on the page.

Posts 26831
Forum MVP
MJ. Smith | Forum Activity | Replied: Sat, Dec 12 2015 1:48 PM

It sounds as if the focus has sometimes changed and sometime hasn't. Are you selecting the same text or are you sometimes only placing the cursor at the point you want?

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 127
John Marino | Forum Activity | Replied: Sat, Dec 12 2015 1:54 PM

MJ,

In both cases I have highlighted the text completely. The process I follow is the same in both scenarios. But what your are suggesting seems to be correct (at least from the computer's "perspective") - Logos "thinks" that in one scenario I have not highlighted the text, and thus defaults to pulling the hyperlink from the top of the "page." In the other scenario, it recognizes my highlight further down the "page."

To my knowledge, there is absolutely no difference in my process. I am willing to be corrected though. I am fairly positive it is a software issue, though whether it is unique to my setup or a bug across all Windows platforms still is unknown to me.

Page 1 of 1 (5 items) | RSS