Logos 6 for Mac Crashes on Open

Page 1 of 1 (7 items)
This post has 6 Replies | 1 Follower

Posts 3
Tom | Forum Activity | Posted: Mon, Dec 21 2015 6:30 AM

I was using Logos 6 for Mac on OS X Yosemite 10.10.5 using a MacBook Air 13" (and I have used Logos on this machine for many months without a problem) but something happened yesterday and now Logos won't startup without crashing. I tried deleting and reinstalling Logos 6 and no joy. Also, ran FontTester and no problems were reported. About the only thing that I can see that is different is that I had a separate window open with a resource at the time of the crash. Typically, I leave Logos with only the main window open and close any floating windows before exiting. But this time I did not and now when Logos 6 opens it looks at first like it will succeed--and it shows it is trying to open the floating window I left open--but then it crashes. So I am guessing--a layman's guess--that this floating window and its resource have something to do with the problem. I didn't have any personal books or the like open at the time of the crash--just standard Logos resources. I am wondering if there is a way to force Logos 6 to open with a default layout? I ask this because I am thinking the problem lies in the layout somehow. 

Thanks for your help,

Tom Preston 

4188.LogosLogs.Elaine.20151221-092046.zip

Posts 30696
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Dec 21 2015 6:45 AM

Tom:
I am wondering if there is a way to force Logos 6 to open with a default layout? I ask this because I am thinking the problem lies in the layout somehow.

I am not able to look at your logs at present, but there seems to be some sort of bug related to layouts... so lets run with that scenario.

Press and hold the command key immediately upon startup. This should allow you to open to a "blank" layout. At that point, you can try opening the layout... and if you are right, you would get a crash. You can also try to rebuild the layout (simply start again). That <should> fix the problem if the issue is the layout... If the issue is a corrupted resource file, then you will get a crash when you open that resource. 

Let us know how it goes.

macOS, iOS & iPadOS | Logs |  Install

Posts 3
Tom | Forum Activity | Replied: Mon, Dec 21 2015 6:49 AM

Yes, I attempted just what you suggested after reading about layouts a bit. And it worked! I opened with a blank layout (using the command key) and then switched to one of my earlier saved layouts and viola! So thanks, I am back in business!

Posts 30696
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Dec 21 2015 10:58 AM
Glad to hear it. I hope FL figures out what happened here. Tongue Tied

macOS, iOS & iPadOS | Logs |  Install

Posts 7
Robert Olen | Forum Activity | Replied: Tue, Dec 22 2015 1:46 PM

This worked for me as well. 

I would hope that FL would post something on their support page or even remove the download since it is a issue that prevents use of the product.

Posts 1258
LogosEmployee
Dylan Rondeau | Forum Activity | Replied: Tue, Dec 22 2015 4:24 PM

Robert Olen:

This worked for me as well. 

I would hope that FL would post something on their support page or even remove the download since it is a issue that prevents use of the product.

6.8 SR-1 has now shipped and includes a fix for this issue. 

Dylan Rondeau, Software Tester

Enable Logging: Mac | Windows (Right-click "Save As...")

Posts 6
Matthew Hoskinson | Forum Activity | Replied: Sat, Jan 2 2016 1:11 PM

Thank you! Worked for me!

Page 1 of 1 (7 items) | RSS