Linux version of Logos Bible Software

Page 70 of 72 (1428 items) « First ... < Previous 68 69 70 71 72 Next >
This post has 1,427 Replies | 66 Followers

Posts 14
Old Bonsai | Forum Activity | Replied: Fri, May 6 2022 3:43 PM

Bill Anderson:

Gabriel, welcome to the Faithlife forums.

Here is the link to the developer’s GitHub site that uses an app image to install Logos using wine: https://github.com/ferion11/LogosLinuxInstaller 

We don’t know your proficiency in working with Linux, so you’ll need to reach out here if you need help..

Thanks very much for this link! I am also about to start the process of getting as far from windows as possible, I refuse to use windows 11. I work in IT and long ago, maybe 10 years now, I imaged a bunch of Linux machines but at this point I am a complete Linux newb. I use Logos 9 a great deal and love it, that's the only reason I would consider keeping a win10 machine around.

I'm considering the Arch distro but still researching Linux and hardware as I need to build a new machine. Depending on the hardware needed for Linux, I may build a 2nd machine or rebuild my laptop for logos. So glad to see Logos on Linux is possible, I don't want to leave logos, but if my only option was to run it on windows 11, I think I would.

Posts 1272
John Goodman | Forum Activity | Replied: Sat, May 7 2022 1:11 AM

It is also worth looking at https://appdb.winehq.org/objectManager.php?sClass=version&iId=39484

We keep the appdb fairly up to date with info, tests and bugs. We've rated Logos Silver for a long time. What works, is very stable but some things don't work. E.g. video and audio playback in the app. These are things you can easily pick up with the web app. For that reason, I feel you can have a very complete Logos experience on Linux but we still have work to do.

Much of the remaining work has to do with speech, media codecs and quite complicated dependencies. Developers from codeweavers and steam are working on these areas so we expect to get there eventually.

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 185
Paul Unger | Forum Activity | Replied: Tue, May 10 2022 1:58 PM

I've been using the 'ferion scrip' version for a while, without serious trouble. Today Logos downloaded 85 MB of 'updates' and now it will start, but if I try to open a resource, Logos just disappears -- no crash report window, nothing... I'm running Logos 9.5.0.0019. Advice appreciated! ;-)

Posts 738
Frank Sauer | Forum Activity | Replied: Wed, May 11 2022 3:06 PM

If the updates you downloaded were the datasets that Rick posted about an update being released - you'll have to update to Logos 9.13 and be inconvenienced by the Menu bug until we are able to figure out what is causing the crashing. Log files point to the Pericope Dataset that was updated. But your layouts will open with 9.13

https://downloads.logoscdn.com/LBS9/Installer/9.13.0.0018/Logos-x64.msi

Paul Unger:

I've been using the 'ferion scrip' version for a while, without serious trouble. Today Logos downloaded 85 MB of 'updates' and now it will start, but if I try to open a resource, Logos just disappears -- no crash report window, nothing... I'm running Logos 9.5.0.0019. Advice appreciated! ;-)

Posts 185
Paul Unger | Forum Activity | Replied: Wed, May 11 2022 3:41 PM

Thanks, Frank. How would I find out if I downloaded the troublesome datasets? I do *not* have to double-click to open menus, and I can open things like Tools > Atlas and Notes. But as soon as I try to open a resource -- crashola...

I ran ./Logos.sh indexing; I see a bunch of things like:

0024:fixme:path:parse_url failed to parse L"System.Windows.Forms"
0024:fixme:path:parse_url failed to parse L"System.Security"
0024:fixme:path:parse_url failed to parse L"System.Xml"

but the final two lines say:

00a8:err:rpc:I_RpcReceive we got fault packet with status 0x1c010003
======= indexing of LogosBible run done! =======

After doing this, the problem remains... I have the full terminal output from my attempt at indexing, if that would be of any help.

Posts 738
Frank Sauer | Forum Activity | Replied: Wed, May 11 2022 3:52 PM

Hey Paul,

You wouldn't have the Menu bug if you are running Logos 9.9 or lower. To bypass the crash on opening a layout or resource, it appears we need to update to a Logos version with the Menu Bug. I was only able to open resources like audio books or videos. Any other resource seemed to crash Logos.

I'd backup my Data, Documents and Users directory and give the 9.13 a look. Once that installs copy over your backup folders to avoid redownloading and reindexing everything. 

Paul Unger:

Thanks, Frank. How would I find out if I downloaded the troublesome datasets? I do *not* have to double-click to open menus, and I can open things like Tools > Atlas and Notes. But as soon as I try to open a resource -- crashola...

I ran ./Logos.sh indexing; I see a bunch of things like:

0024:fixme:path:parse_url failed to parse L"System.Windows.Forms"
0024:fixme:path:parse_url failed to parse L"System.Security"
0024:fixme:path:parse_url failed to parse L"System.Xml"

but the final two lines say:

00a8:err:rpc:I_RpcReceive we got fault packet with status 0x1c010003
======= indexing of LogosBible run done! =======

After doing this, the problem remains... I have the full terminal output from my attempt at indexing, if that would be of any help.

Posts 975
Bill Anderson | Forum Activity | Replied: Wed, May 11 2022 8:37 PM

I, too, have this bug. It causes Logos to crash right after the startup sound and before it loads anything. I had 9.09 I think. I guess it's time to upgrade to a newer version with the menu bug.

Posts 10
Dean Chia | Forum Activity | Replied: Thu, May 12 2022 9:19 PM

I tried following the fast-script w/ AppImage. Same: I can open a Greek lexicon, but other bibles crash, whether BHS or ESV or CSB, etc.

I included the txt of terminal dump? I'm on new Pop_OS 22.04 (Pangolin 11 - AMD)

6574.logosTerminalDump.txt

Posts 10
Dean Chia | Forum Activity | Replied: Thu, May 12 2022 9:30 PM

"Following installation please ensure the LogosIndexer.exe is set to 'vista' and Logos.exe is set to 'win7' for best performance."

I tried unsuccessfully to do the fast-install ferion11 script. Through ./controlPanel.sh winetricks, I can set something to win7 or vista, but how do I individually set an .exe to one or the other? Thanks!

Is it through the manual process, something like #7?

"https://downloads.logoscdn.com/LBS9/Installer/9.6.0.0024/Logos-x64.msi

Manual Install Procedure:
1 Install wine 6 or newer
2 winetricks corefonts
3 winetricks settings fontsmooth=rgb
4 winetricks dotnet48
5 winetricks settings renderer=gdi (you might need to set the reg key manually)
6 Install the Logos.msi download but don't run it.
7 wine64 reg add "HKCU\\Software\\Wine\\AppDefaults\\LogosIndexer.exe" /v Version /t REG_SZ /d vista /f
8 Run Logos and sign in with your free account."

Posts 10
Dean Chia | Forum Activity | Replied: Fri, May 13 2022 5:11 AM

I tried this with wine-devel 7.8 (jammy - I'm on Pop_OS! 22.04) and it says I need LogosInstaller.exe for NET 4.7.2, so I am not able to complete step 6. Would installing Mono do the trick or is that something we don't want to install?

Posts 185
Paul Unger | Forum Activity | Replied: Fri, May 13 2022 9:28 AM

Dean Chia:

"Following installation please ensure the LogosIndexer.exe is set to 'vista' and Logos.exe is set to 'win7' for best performance."

I tried unsuccessfully to do the fast-install ferion11 script. Through ./controlPanel.sh winetricks, I can set something to win7 or vista, but how do I individually set an .exe to one or the other? Thanks!

I'm trying to work through the update process myself, Dean Chia (following the instructions here: https://github.com/ferion11/logoslinuxinstaller#25--to-update). Not going so well... In the terminal I had to "cd LogosBible_Linux_P" and then "./Logos.sh winetricks". When Winetricks opened, I selected "Run winecfg" then clicked OK. A Windows-y "Wine configuration" window opens, and on the Applications tab you can set LogosIndexer.exe to Windows 7; mine was on Windows Vista. Despite changing this, I'm still crashing after the "Preparing your library' popup appears. I'm going to try a restart and see if that helps. :-|

Posts 185
Paul Unger | Forum Activity | Replied: Fri, May 13 2022 9:37 AM

Well, I think my install is knackered... :-( Restart and indexing didn't do anything -- it's still crashing; and I don't know what else to try. It sure was nice when it just worked. :-P

I'd be game to start from scratch, but the thought of downloading everything again gives me chills. I know people say you can save your existing downloaded resources (I still have /home/*username*/LogosBible_Linux_P_old/data/wine64_bottle/drive_c/users/*username*/Local Settings/Application Data/Logos/Data/zwgbtstt.hmi/ResourceManager/Resources), but copying them has never worked for me... Fool-proof instructions appreciated! ;-)

Posts 10
Dean Chia | Forum Activity | Replied: Fri, May 13 2022 1:49 PM

I'm really at a loss. I have been trying for two days to install this on my new System76 Pangolin11 (AMD) Pop!_OS 22.04.

I have tried using the newly updated ferion11 script today for Logos 9.11. Interestingly, I can consistently open up BDAG after downloading it. I believe I can also preview other Bibles that I have not previously downloaded and view the preview. Once I download it, then opening any Bible results in an immediate crash. I have attached the crash output as a txt: 8535.logosDump.txt

I have tried Hebrew and English Bibles and NA28. No good. Immediate crash. I bought my new computer specifically to run Linux faster (+ bigger screen and supporting System76).

I decided to try and look at what version I installed Logos on my older ThinkPad X1 Carbon Gen 3 (Intel) Pop!_OS 22.04. But now I don't know why, but now Logos doesn't work on the old laptop either!

Posts 185
Paul Unger | Forum Activity | Replied: Fri, May 13 2022 2:36 PM

Funny, I was able to open BDAG as well -- before I tried to upgrade. I had it as a 'favourite' icon in the top bar, and I clicked it and the Atlas icon I have up there and they both opened (I was also able to open the Atlas from the Tools menu, as I mentioned earlier).

You're doing a new install, right? Not upgrading?

Bummer about Logos no longer running on your X1... If it's just a paperweight (albeit a light one!), you could toss it my way! Joke!!! :-P

Posts 10
Dean Chia | Forum Activity | Replied: Fri, May 13 2022 2:46 PM

Yes complete new install. No copying pasting any old data. Clean install from scratch. No bandwidth saving. :P I am trying Debian Stable and seeing if there's any luck with the ferion11 script...

Posts 738
Frank Sauer | Forum Activity | Replied: Fri, May 13 2022 3:01 PM

For those who are experiencing Logos crashing on open of resources or when Logos attempt to load a layout - we are trying to pinpoint the issue.

This bug appeared after the dataset updates a few days ago - one of the logos crash logs seems to point towards the Pericope Dataset.

Thus far, I have been able to get Logos to open with the updated Datasets by running the latest Logos 9.13 (The latest 9.14 Beta also works).

The trade off is we now have to deal with the bug that popped up with the CEF update - it's a slight annoyance of having to double click Menu Headers to access the Menus.

I personally do not use the ferion script - but the recommendation at this time is this:

Logos 9.13

LogosIndexer.exe set to Vista in winecfg (Indexer will not function correctly if not)

Run install and application updates with the prefix default set to Win 10

Once the install is complete - change the prefix default to Win 7 (This allows printing to function and the app load time seems to improve - Win 7 also allows resources to update while not recognizing Program update - which is a positive to avoid installing new Logos versions that haven't been tested for new bugs or regressions)

In Logos Program Settings - turn off automatic updates

***Side Notes

Double Check what renderer is set in Wine (gdi has been the most consistent)

Double check that dotnet48 is installed

Always keep a clean and up to date back up of your Data, Documents and Users directories due to the bug that wipes data on Program Updates. 

Posts 185
Paul Unger | Forum Activity | Replied: Fri, May 13 2022 3:16 PM

Thanks for that, Frank. I used ./Logos.sh winetricks to set LogosIndexer.exe to Vista (just winecfg opened a config window, but there was no LogosIndexer.exe in Applications, just Default Settings [set to Windows 7]), ran ./Logos.sh indexing ("indexing of LogosBible run done!"), and finally ran ./Logos.sh, but it crashed at the "Preparing..." screen.

Here's a question: what version of Wine should I be running? At the end of the crash log, I see System Information, Wine build: wine-5.0 (Ubuntu 5.0-3ubuntu1). Is that correct? I sure hope so, because every time I work with wine and bottles and vintages, it's like I have to learn it all over again...

Posts 738
Frank Sauer | Forum Activity | Replied: Fri, May 13 2022 3:22 PM

Wine-Stable 7.0 would be a good start.

To find logosindexer.exe - you need to navigate to the logos directory in your Wine install - LogosIndexer.exe is located in the System Directory of the Logos install folder

Paul Unger:

Thanks for that, Frank. I used ./Logos.sh winetricks to set LogosIndexer.exe to Vista (just winecfg opened a config window, but there was no LogosIndexer.exe in Applications, just Default Settings [set to Windows 7]), ran ./Logos.sh indexing ("indexing of LogosBible run done!"), and finally ran ./Logos.sh, but it crashed at the "Preparing..." screen.

Here's a question: what version of Wine should I be running? At the end of the crash log, I see System Information, Wine build: wine-5.0 (Ubuntu 5.0-3ubuntu1). Is that correct? I sure hope so, because every time I work with wine and bottles and vintages, it's like I have to learn it all over again...

Posts 738
Frank Sauer | Forum Activity | Replied: Sun, May 15 2022 11:34 AM

In relation to the bug that Passage Analysis crashes Logos - here is the LogosCrash Log

Error ID: 8546
Error detail: COMException: Exception from HRESULT: 0x88980406

System.Runtime.InteropServices.COMException (0x88980406): Exception from HRESULT: 0x88980406
at System.Windows.Media.Composition.DUCE.Channel.SyncFlush()
at System.Windows.Interop.HwndTarget.UpdateWindowSettings(Boolean enableRenderTarget, Nullable`1 channelSet)
at System.Windows.Interop.HwndTarget.UpdateWindowPos(IntPtr lParam)
at System.Windows.Interop.HwndTarget.HandleMessage(WindowMessage msg, IntPtr wparam, IntPtr lparam)
at System.Windows.Interop.HwndSource.HwndTargetFilterMessage(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
at MS.Win32.HwndWrapper.WndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
at MS.Win32.HwndSubclass.DispatcherCallbackOperation(Object o)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)
at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(DispatcherPriority priority, TimeSpan timeout, Delegate method, Object args, Int32 numArgs)
at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam)
at MS.Win32.UnsafeNativeMethods.CallWindowProc(IntPtr wndProc, IntPtr hWnd, Int32 msg, IntPtr wParam, IntPtr lParam)
at MS.Win32.HwndSubclass.DefWndProcWrapper(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam)
at MS.Win32.UnsafeNativeMethods.CallWindowProc(IntPtr wndProc, IntPtr hWnd, Int32 msg, IntPtr wParam, IntPtr lParam)
at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam)
at MS.Win32.UnsafeNativeMethods.UnsafeSendMessage(IntPtr hWnd, WindowMessage msg, IntPtr wParam, IntPtr lParam)
at System.Windows.Window.InternalClose(Boolean shutdown, Boolean ignoreCancel)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)
at System.Windows.Threading.DispatcherOperation.InvokeImpl()
at MS.Internal.CulturePreservingExecutionContext.CallbackWrapper(Object obj)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at MS.Internal.CulturePreservingExecutionContext.Run(CulturePreservingExecutionContext executionContext, ContextCallback callback, Object state)
at System.Windows.Threading.DispatcherOperation.Invoke()
at System.Windows.Threading.Dispatcher.ProcessQueue()
at System.Windows.Threading.Dispatcher.WndProcHook(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
at MS.Win32.HwndWrapper.WndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
at MS.Win32.HwndSubclass.DispatcherCallbackOperation(Object o)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)
at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(DispatcherPriority priority, TimeSpan timeout, Delegate method, Object args, Int32 numArgs)
at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam)
at MS.Win32.UnsafeNativeMethods.DispatchMessage(MSG& msg)
at System.Windows.Threading.Dispatcher.PushFrameImpl(DispatcherFrame frame)
at System.Windows.Application.RunDispatcher(Object ignore)
at System.Windows.Application.RunInternal(Window window)
at LDLS4.OurApp.InitializeAndRun(ReadOnlyCollection`1 listArgs, SingleInstanceManager sim, Scope telemetryStep)
at LDLS4.OurApp.Main(String[] astrArgs)

Posts 10
Dean Chia | Forum Activity | Replied: Sun, May 15 2022 2:59 PM

If you didn't open Logos yet after install, LogosIndexer.exe might be in a folder named Pending

Page 70 of 72 (1428 items) « First ... < Previous 68 69 70 71 72 Next > | RSS