Search function doesn't seem to be working properly

Page 1 of 1 (18 items)
This post has 17 Replies | 1 Follower

Posts 12
Abram Germano | Forum Activity | Posted: Sun, Jul 31 2016 12:21 PM

I'm a new user to Logos and have been going through the training videos. I'm thinking my search function isn't working properly because I'll type in a very common word like "God," searching all my bibles and I get 0 hits. I search the forums for similar issues and I've gotten the logos performance tool to create error logs. I've tried it out and attached my results. I have nearly 2000 books in my system and I'd like to be able to get going with this awesome tool. Please help.

-Abe

4578.Abram Germano - Search Issue Logs.zip

Posts 27489
Forum MVP
MJ. Smith | Forum Activity | Replied: Sun, Jul 31 2016 1:14 PM

Welcome to the forums. How new is new? I ask because the indexing not having completed or a corrupt index is the most common cause of this sort of error. Do you have a circle beside Layout in the upper right?

Click on it and see if it provides information on the status on indexing. If that is not it, respond and I'll tell you how to correct a corrupt index.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 12
Abram Germano | Forum Activity | Replied: Sun, Jul 31 2016 1:28 PM

Thank you. Very new, but there is no exclamation point in the circle - there is a circle though, see below. When I hover over it it just says "synchronization is enabled and all items are updated." 

Posts 27489
Forum MVP
MJ. Smith | Forum Activity | Replied: Sun, Jul 31 2016 1:38 PM

Abram Germano:
there is no exclamation point in the circle - there is a circle though, see below.

Good - the red exclamation point indicates there is a problem. I beta test and have multiple installations - I was too impatient to wait for another installation.

Type "rebuild index" without the quotes in the command box, hit enter and wait until it is complete. Then try the search again.

From Help:


Rebuild index

Rebuild [index name] index

Sometimes the search index will need to be rebuilt, either because the indexer failed to complete its tasks, or because the index somehow became corrupted. Note that building the index takes a long time and uses a lot of system resources, so don’t do this unless you are prepared to wait. If the indexer is already running, these commands restart the indexer from the beginning.
  •      rebuild index rebuilds the indexes for Bibles and all other resources.
  •      rebuild bible index reindexes just Bibles.
  •      rebuild library index reindexes all resources except Bibles.
  •      rebuild personal book index reindexes just personal books.

Learn more about indexing.


Logos 6 Help (Bellingham, WA: Faithlife, 2015).

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 12
Abram Germano | Forum Activity | Replied: Sun, Jul 31 2016 7:09 PM

I've tried the rebuild index command several times and it doesn't seem to be correcting the error.

Posts 27489
Forum MVP
MJ. Smith | Forum Activity | Replied: Sun, Jul 31 2016 7:34 PM

Could you post a screen shot of the Search?

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 12
Abram Germano | Forum Activity | Replied: Sun, Jul 31 2016 7:39 PM

Sure. Here's a quick example of a search for the word faith in my ESV returning no hits.

Posts 27489
Forum MVP
MJ. Smith | Forum Activity | Replied: Sun, Jul 31 2016 7:55 PM

Okay, you've done a good job of showing that my next suggestions wouldn't help. I'm fairly certain that a file or index is corrupted but don't know a quick way to track it down. There are a few others on the forums who might have an idea but at this point I suggest a call to customer service.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 12
Abram Germano | Forum Activity | Replied: Sun, Jul 31 2016 7:59 PM

I appreciate your help regardless Smile. I'll reach out to the support team tomorrow. 

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sun, Jul 31 2016 10:05 PM

Abram Germano:
I search the forums for similar issues and I've gotten the logos performance tool to create error logs. I've tried it out and attached my results

Welcome Big Smile

Attached file shows an application crash, but does not have diagnostic logging enabled => https://www.logos.com/support/windows/report-problem

The script to always enable diagnostic logging sets Enabled to 1 in the registry: HKCU\SOFTWARE\Logos4\Logging

Please close Logos 6, enable logging, open Logos 6, wait for indexing to complete, then repeat Bible Search.  If results in ESV are still 0, please zip log files and attach to reply.

Keep Smiling Smile

Posts 32
Don D. Thompson | Forum Activity | Replied: Sun, Jul 31 2016 10:37 PM

I am having a similar (the same?) issue with the search feature.  I have rebuilt the index and rebuilt the index for just my preferred Bible (ESV) without resolving the issue.

I can perform a search within the open ESV and obtain the expected hits.  Similarly, if I do a Basic Search for text in the ESV I get a similar result (there are some differences due to headings which are not part of the Bible text).  If I do a Bible Search I get zero results.  I have noticed this problem particularly when searching Top Bibles or All Bibles, I may get some hits but not in all the versions I was expecting.  

An example would be searching for "faith" Basic Search in ESV gives 540 hits, Bible Search gives 0 hits, and searching an open ESV gives 450 hits.  Doing the search on Top Bibles only gives hits in the NIV (preferred Bibles are ESV, NIV, NRSV, FSB, NJB)

Windows 7 Home Premium Version 6.1.7600 Build 7600 (x64)

Acer Aspire 5738G laptop

4G RAM

Intel Core 2 Duo T6600

ATI Mobility Raedeon HD 4570

 

Posts 27489
Forum MVP
MJ. Smith | Forum Activity | Replied: Sun, Jul 31 2016 11:38 PM

That implies that there is a problem that is specific to the Bible index ... are either of you running the beta version? Does this match your ESV support info?

LLS:1.0.710
 2015-02-03T19:45:56Z
 ESV.logos4
RVI:ESVNT 
2015-02-03T19:31:04Z 
ESVNT.lbsrvi
RVI:ESVOT
 2015-02-03T19:31:04Z
 ESVOT.lbsrvi

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 12
Abram Germano | Forum Activity | Replied: Mon, Aug 1 2016 7:01 AM

Keep Smiling 4 Jesus :):

Please close Logos 6, enable logging, open Logos 6, wait for indexing to complete, then repeat Bible Search.  If results in ESV are still 0, please zip log files and attach to reply.

Sorry but could you walk me through how I "enable logging"? I'm currently using Windows 10 and navigating to file folders is a challenge in itself sometimes. FYI, I did follow the instructions on the link, held the Ctrl button and recreated the problem once logos opened...I just have no idea how to locate the log file on this machine...lol

-Abe

Posts 22206
Forum MVP
Graham Criddle | Forum Activity | Replied: Mon, Aug 1 2016 7:21 AM

Abram Germano:
.I just have no idea how to locate the log file on this machine

If you open File Explorer and navigate to This PC -> Documents you should find a folder under this called "Logos Log Files"

Have a look in there

Posts 12
Abram Germano | Forum Activity | Replied: Mon, Aug 1 2016 7:32 AM

Thank you! Please see attachment. 3438.Logos.log

Posts 12
Abram Germano | Forum Activity | Replied: Mon, Aug 1 2016 10:47 AM

Please let me know if the attachment in my previous post is what is needed to diagnose the issue. FYI, I have Logos 6 installed on both a desktop machine and on my laptop...I am only having problems on my laptop. The search function works properly on my office computer.

Posts 25188
Forum MVP
Dave Hooton | Forum Activity | Replied: Mon, Aug 1 2016 4:33 PM

Abram Germano:
Please let me know if the attachment in my previous post is what is needed to diagnose the issue.

It doesn't help. Please seek assistance from Tech Support.

Dave
===

Windows 10 & Android 8

Posts 12
Abram Germano | Forum Activity | Replied: Tue, Aug 2 2016 11:08 AM

Just got off with tech. support and they logged into my machine and found out what's going on. They said it was an indexing issue but had to remove some files from a folder before the indexing worked proper. I'm good to go! Thanks everyone for your input :)

Page 1 of 1 (18 items) | RSS