Search for "God" on Logos 4 comes up with zero results

Page 1 of 2 (24 items) 1 2 Next >
This post has 23 Replies | 1 Follower

Posts 28
Keith Milner | Forum Activity | Posted: Sat, Mar 20 2010 11:38 AM

Hi

I have just reindexed as a result of problems with the Berkhof collection. Now when I search for "God" in my entire library I get 0 results.

Keith Milner

Posts 1034
Mike Pettit | Forum Activity | Replied: Sat, Mar 20 2010 1:37 PM

Obviously a very liberal collection in your library.

Posts 769
Alan Charles Gielczyk | Forum Activity | Replied: Sat, Mar 20 2010 1:44 PM

My library must be more conservative, I got 2.67 million results

Posts 769
Alan Charles Gielczyk | Forum Activity | Replied: Sat, Mar 20 2010 1:45 PM

But sadly none in BerkhofSad

Posts 28
Keith Milner | Forum Activity | Replied: Sat, Mar 20 2010 1:45 PM

i actually have 3640 resources but search can't find any of them.

Posts 769
Alan Charles Gielczyk | Forum Activity | Replied: Sat, Mar 20 2010 1:46 PM

If your library is not done indexing you will encounter problems searching, are you sure you are done indexing?

Posts 28
Keith Milner | Forum Activity | Replied: Sat, Mar 20 2010 2:06 PM

It comes to the end of the process but when I go into search it tells me it is still indexing.

Posts 27031
Forum MVP
Dave Hooton | Forum Activity | Replied: Sat, Mar 20 2010 4:19 PM

KeithMilner:

It comes to the end of the process but when I go into search it tells me it is still indexing.

What is the message? The normal message will advise you to do a merge but indexing is complete

 

Dave
===

Windows 10 & Android 8

Posts 28
Keith Milner | Forum Activity | Replied: Sun, Mar 21 2010 2:17 AM

It just says "Some search results may be missing or incorrect while your library is being indexed". Indexing has finished and I still 0 results,

Posts 28
Keith Milner | Forum Activity | Replied: Sun, Mar 21 2010 2:42 AM

Each time I restart Logos 4 the files in the Lbrary Index folder are deleted.. Files in the Bible Index folder remain intact so I can still search the Bible.

Posts 27031
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Mar 21 2010 7:03 AM

KeithMilner:

Each time I restart Logos 4 the files in the Lbrary Index folder are deleted.. Files in the Bible Index folder remain intact so I can still search the Bible.

I'd like to see some logs. Enable permanent logging as per  http://wiki.logos.com/Diagnostic_Logging and then upload to the forum as at  Uploading Logs

Dave
===

Windows 10 & Android 8

Posts 28
Keith Milner | Forum Activity | Replied: Sun, Mar 21 2010 8:14 AM

0702.Logos4.logHere are my logs for the restart

Posts 28
Keith Milner | Forum Activity | Replied: Sun, Mar 21 2010 8:18 AM

2335.Logos4Crash.txt

 Sorry about that. There was more than one file.

Posts 28
Keith Milner | Forum Activity | Replied: Sun, Mar 21 2010 8:41 AM

52141.Logos4.log1682.Logos4Indexer.log

These logs are from another restart

Posts 28
Keith Milner | Forum Activity | Replied: Sun, Mar 21 2010 8:56 AM

78052.Logos4.log7673.Logos4Indexer.log

Now my Bible Index has been wiped as well???!!!

Posts 28
Keith Milner | Forum Activity | Replied: Sun, Mar 21 2010 9:26 AM

0083.Logos4.log2046.Logos4Indexer.log

This is a new start with firewall turned off and update now and update resoures applied. I don't know if this is any use but I think I am clutching at straws.

Posts 584
Gary O'Neal | Forum Activity | Replied: Sun, Mar 21 2010 2:27 PM

KeithMilner:

0083.Logos4.log2046.Logos4Indexer.log

This is a new start with firewall turned off and update now and update resoures applied. I don't know if this is any use but I think I am clutching at straws.

Keith

Just a suggestion - I had the similar result several days ago and panicked at first. Then I realized that I was searching All Open Resources rather than Entire Library.

πάντα εἰς δόξαν θεοῦ ποιεῖτε

Posts 28
Keith Milner | Forum Activity | Replied: Sun, Mar 21 2010 4:30 PM

I wish it was as simple as that Gary. It is the entire library I am searching.

Posts 27031
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Mar 21 2010 5:25 PM

Keith

L4 is in a loop trying nto download the Berkhof files (17.3 MB), failing and trying again. In that process it also cancels the indexing - knowing the existing index was deleted! Hence no index.

I want you to set Automatically Download Updates to NO in Program Settings and exit L4. Wait for the Indexer to finish (it only takes 30 secs to do nothing!). Start L4 and enter the command Rebuild Index (ignore the notification that downloads are available -  cancel it by hitting the X). It should do  a complete re-index.

 

EDIT: The indexer may continue to do its job after changing the download setting, and it may not even be necessary to enter Rebuild Index when you restart L4!

Dave
===

Windows 10 & Android 8

Posts 28
Keith Milner | Forum Activity | Replied: Mon, Mar 22 2010 10:18 AM

Thanks for that Dave.

Everything is working perfectly now with all searches functioning. I copied the Berkhof L3 files over on Saturday and L4 searches them now as well.

My next question is when can I turn Automatic Downloads back on?

Keith

Page 1 of 2 (24 items) 1 2 Next > | RSS