ANNOUNCE: Faithlife ending Logos 6.14 support on June 12, 2017

Page 1 of 1 (3 items)
This post has 2 Replies | 0 Followers

Posts 226
LogosEmployee
Ryan Gano (Faithlife) | Forum Activity | Posted: Tue, Mar 21 2017 4:10 PM

We are changing Logos 6.14 from the "maintenance" support level to "unsupported" on June 12, 2017. (For a full description of these support levels, please see "About Free Support".)

Logos 6.14 will not be disabled. Your existing install will continue to run with the resources you already have. However, new resources purchased from logos.com may not be readable in Logos 6.14.

If you are running Windows 7 or later, or Mac OS X 10.10 "Yosemite" or later, you can update from Logos 6.14 to Logos 7 for free. (For a discussion of updating vs crossgrading vs upgrading, please see "How to upgrade to Logos 7".) We strongly recommend that all eligible customers move to Logos 7.

If you are already running Logos 6 in Windows, there is no need to change operating systems to run Logos 7. The software is still compatible with Windows 7, Windows 8, and Windows 10.

If you are running OS X 10.9 "Mavericks" (or earlier), you may be able to update to macOS 10.12 "Sierra" for free. (And once you do that, you can install Logos 7.) See Apple's "How to Upgrade" article to determine whether Sierra is compatible with your computer.

Posts 21789
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Mar 22 2017 1:09 AM

I suggest it be posted in the General forum for wider visibility.

Dave
===

Windows & Android

Posts 226
LogosEmployee
Ryan Gano (Faithlife) | Forum Activity | Replied: Wed, Mar 29 2017 7:57 AM

Thanks for the suggestion. I'll post there as well.

Page 1 of 1 (3 items) | RSS
Copyright 1992-2015 Faithlife / Logos Bible Software.