Bug? Problems with scaling and mixed display types, i.e. UHD and FHD

Page 1 of 1 (9 items)
This post has 8 Replies | 2 Followers

Posts 70
Thomas Zimmermann | Forum Activity | Posted: Tue, Jan 15 2019 1:06 AM

Hi all,

I have a problem with my new setup.

New Laptop, Lenovo T580, with an 15" UHD display, set to 200% scaling in the windows display settings.

2 external 24" FHD displays, set to 0% scaling in the windows display settings.

If I use my laptop without the external displays, Logos starts up using the UHD display settings, rendering everything absolutely stunning beautiful. Crisp sharp fonts and all.

If I use only the external displays (i.e. laptop lid closed) Logos is using the standard FHD setting, rendering everything as sharp as a normal 24" FHD can go.

However, if I use all three monitors, Logos is starting up using the settings for the FHD monitor, leading to the text being absolutly horribly unsharp and blurry on the UHD monitor. Applications like Firefox can be seen to re-render and scale the whole window if it gets moved across from FHD 24" to UHD 15" monitor. Logos does not do that, leading to the blurry fonts.

Lenovo T580, Windows 10 1809 with January Patch, all firmware and drivers are up to date, Logos Bible Software 8.1 SR-1

Any hints or ideas?

Blessings from Germany,


user since Logos 4

Posts 70
Thomas Zimmermann | Forum Activity | Replied: Wed, Jan 16 2019 10:22 AM

One additional problem popped up: Now Logos is ALWAYS blurry on the 4K display, even when I disconnect the external displays, only use the internal one and start Logos then.

When I was using my laptop first, Logos was cristal clear. I got my docking station later due to a delivery problem. Now that the laptop is used in the docking station, Logos is blurry, even when undocked and started with just the 4K internal display being used.

This is soooo uncomfortable to use.

Edit: I found that rebooting the laptop without external displays makes Logos beautiful on the internal display again. Up until the point when any non High-DPI display is connected again. Then the blurryness starts all over again. Aditionally I found that other Apps, for example enpass (find in windows store, a Password manager) exhibit the same behaviour. While others behave normal and as expected (for example Firefox, Microsoft Office, ...)

user since Logos 4

Posts 2589
Lee | Forum Activity | Replied: Wed, Jan 16 2019 2:20 PM

Try using the Function+F4 (or whichever combination) to cycle through laptop LCD, external display, etc...   this may reset settings

Posts 1538
Ben Misja (Faithlife) | Forum Activity | Replied: Wed, Jan 16 2019 9:25 PM

I would guess it has to do with your specific setup, maybe your graphics drivers. I ran a very similar setup on a Dell XPS 15 up until November (not sure if my scaling was at 200%, though) with 0 issues. 

Posts 70
Thomas Zimmermann | Forum Activity | Replied: Thu, Jan 17 2019 3:39 AM

Hi Lee,

the built in combo from windows is WIN+P. But does not solve it.

But thanks.

user since Logos 4

Posts 70
Thomas Zimmermann | Forum Activity | Replied: Thu, Jan 17 2019 3:48 AM


I am note sure what is happening here. Driver wise it makes no difference if Logos is running on the Intel GPU or the NVidia one - all with the newest drivers from Intel respectively NVidia.

I have tried something more:

  • if I boot up without external display: Logos behaves perfect on the internal display. Dock in and use all displays: Logos is perfect smooth internal and external.
  • if I boot docked in with external displays: Logos behaves odd and has weird blurryness.

Fun fact: If I want to use VMware Workstation, the thing is reversed:

  • If I boot up with external displays attached, it scales perfectly and has a smooth GUI on all displays - no matter if I move it from internal to external.
  • If I boot up only with the internal display and then dock in to use the external, too, Workstation becomes totally unusable. It is not blurry like Logos, but rather all elements remain the scaled up size, leading to buttons the size of my hand...

So, if I want to use VMware Workstation: Boot docked in. If I want to use Logos, boot docked out.

All these reboots... I guess Windows 10 still has a long way to go until it reaches the same usability as macOS had since 5 years...

So this can't be a pure Logos issue. But somehow other applications like Firefox don't mind any way I booted the system, they just stay sharp no matter what.

All the best,


user since Logos 4

Posts 400
Bernhard | Forum Activity | Replied: Thu, Jan 17 2019 5:53 AM

Over the years I have had problems like that with different programs, not just Logos, recently it has been mostly okay. External graphics cards, as you probably have in your docking station, seem to have more problems compared to connecting directly to the computer's HDMI port. 

I don't have a good answer for you, but a few things to try:

  • does connecting to the computer's HDMI Port instead of through the docking station help?
  • make sure all your drivers are up-to-date, including the driver (and firmware?) for the docking station
  • if a restart doesn't help, try logging off first and then restart the computer
  • try the different options in the Windows Display settings, including unter System/Display "Advanced Scaling settings" and "Graphics Settings" (at the very bottom, then browse for the Logos executable, should be under C:\Users\**yourusername**\AppData\Local\Logos\Logos.exe). Make sure you have logged off and restarted after changing options.
Posts 1538
Ben Misja (Faithlife) | Forum Activity | Replied: Thu, Jan 17 2019 10:39 AM

EDIT: Disregard what I had written. I just learned that this is a known issue that will be addressed when there's a chance. Sorry for the confusing communication. Smile

Posts 70
Thomas Zimmermann | Forum Activity | Replied: Fri, Jan 18 2019 12:04 AM

Ben: This is great news, thank you :-)

I had a hunch that it needed to be adressed in the programming of Logos (and Enpass, the other App I mentioned with the same behaviour).

All others: Thank you for your ideas and hints. Since all drivers and Firmware are up to date and my experiments (see my last post above) at leasts yielded a workaround for the time being, I'll wait till a patch arrives as Ben stated.

Blessings from Germany,


user since Logos 4

Page 1 of 1 (9 items) | RSS