Performance of Logos8 on Mac OS 10.14.4

Page 1 of 2 (21 items) 1 2 Next >
This post has 20 Replies | 1 Follower

Posts 27
Arthur Yeo | Forum Activity | Posted: Sat, Apr 20 2019 1:03 PM

I do not see much difference in the performance and responsiveness for Logos8 on Mac Mac OS 10.14.4 .

Is there a good way to split up any caching on a separate secondary device so things can happen more in parallel?

Posts 21591
Forum MVP
Graham Criddle | Forum Activity | Replied: Sat, Apr 20 2019 1:49 PM

Sorry, but I’m not sure what you are comparing with - where you don’t see the difference. Please expand

And, no, there isn’t any mechanism to move caching elsewhere

What sort of performance levels are you seeing that cause concern?

Posts 27
Arthur Yeo | Forum Activity | Replied: Sat, Apr 20 2019 2:12 PM

Just general slowness.

E.g.

  1. Startup from scratch, took a while to settle into a state where I can start typing it. In general, it took around 1.5 min to 100 secs to be in a usable state.
  2. Type in a biblical ref in the Open Passage area and hit GO and it takes around 2.5 mins to set up the page
  3. Hover my pointer over a word in the original text to bring up Information (like BDAG), and it look 90 seconds or more.

My friend said there was a significant improvement in the Windows platform but I'm not seeing it in Mac OS.

Posts 21591
Forum MVP
Graham Criddle | Forum Activity | Replied: Sat, Apr 20 2019 2:21 PM

Those performance times seem very slow. I use Windows but other Mac users are getting better performance than that.

What Mac do you have and, in particular, do you have an SSD?

Posts 1508
Forum MVP
Levi Durfey | Forum Activity | Replied: Sat, Apr 20 2019 3:48 PM

Arthur Yeo:

  1. Startup from scratch, took a while to settle into a state where I can start typing it. In general, it took around 1.5 min to 100 secs to be in a usable state.
  2. Type in a biblical ref in the Open Passage area and hit GO and it takes around 2.5 mins to set up the page
  3. Hover my pointer over a word in the original text to bring up Information (like BDAG), and it look 90 seconds or more.

I agree with Graham...I use a Mac and these times are nowhere near normal. Something is wrong, but we need more information. IN additional to what Graham asked for, posting your logs might help us see what's going on under the hood. See below in my signature for how to post logs.

Posts 27
Arthur Yeo | Forum Activity | Replied: Sat, Apr 20 2019 4:39 PM

Here are my hardware specs (it's an older Mac Mini):

Model Name: Mac mini

  Model Identifier: Macmini7,1

  Processor Name: Intel Core i5

  Processor Speed: 2.6 GHz

  Number of Processors: 1

  Total Number of Cores: 2

  L2 Cache (per Core): 256 KB

  L3 Cache: 3 MB

  Memory: 16 GB

  Boot ROM Version: 238.0.0.0.0

  SMC Version (system): 2.24f32

Posts 27
Arthur Yeo | Forum Activity | Replied: Sat, Apr 20 2019 4:39 PM

No SSD.

Posts 27
Arthur Yeo | Forum Activity | Replied: Sat, Apr 20 2019 4:43 PM

I'm installing Logging Util.

Thanks for the suggestion.

Posts 3037
Forum MVP
PetahChristian | Forum Activity | Replied: Sat, Apr 20 2019 4:58 PM

Arthur Yeo:
Model Identifier: Macmini7,1

No SSD. This is going to have the most significant effect on performance (although the delays you are reporting seem extreme even for a HD).

Posts 17809
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sat, Apr 20 2019 8:55 PM

Arthur Yeo:

Model Name: Mac mini

  Model Identifier: Macmini7,1

  Processor Name: Intel Core i5

  Processor Speed: 2.6 GHz

Complete specs for Late 2014 Mac mini => https://everymac.com/systems/apple/mac_mini/specs/mac-mini-core-i5-2.6-late-2014-specs.html

OWC offers Aura Pro X2 upgrade kit that includes PCIe cable => https://eshop.macsales.com/shop/ssd/owc/mac-mini/2014

Concur with recommendation for SSD upgrade for noticeable performance improvements in macOS and Logos.

Keep Smiling Smile

Posts 1
Michael Holmes | Forum Activity | Replied: Sun, Apr 21 2019 8:53 PM

I run Logos 8 on two Windows machines.  The first is Windows 7 with hex core processor, 64 Gb RAM, and SSD.  Similarly bad performance.  3+ minutes to become usable and then it is just usable.  Second machine is Windows 10 with quad core processor and 32 Gb RAM, and non-SSD.  Better performance, but not great and not nearly as good as Logos 7.

Is there any way to go back to Logos 7?  I tried to reinstall using my original Logos 7 setup file, but it wouldn't work.  My guess is that the old set file was trying to install software prior to the 7.19 security update. 

Any help speeding up Logos 8 or going back to Logos 7 would be appreciated!

Mike H

Posts 21591
Forum MVP
Graham Criddle | Forum Activity | Replied: Sun, Apr 21 2019 11:55 PM

Hi Michael - and welcome to the forums

Sorry to hear you are having performance issues.

I recommend starting a new thread in this forum and we will try to work out what is going on.

I don’t recommend trying to go back to Logos 7 but we can look  the reasons for the performance you are seeing.

Graham

Posts 76
Scott Groethe | Forum Activity | Replied: Mon, Apr 22 2019 7:00 AM

I found this thread because I wanted to comment on slowness on a Mac, only started recently. I notice it when I click inside a note and add text. It takes up to ten seconds just for the note to be ready for me to enter text.

If I stay in the note, then no delay but if I highlight text in another window or leave the note window (click somewhere else), then go back there - then there is that long delay.

Posts 27120
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Apr 22 2019 7:58 AM

Hi Scott! If you want to troubleshoot, please create a new thread. Explain your issue clearly and provide logs. See my signature line. 

OSX & iOS | Logs |  Install

Posts 27
Arthur Yeo | Forum Activity | Replied: Wed, May 22 2019 6:37 AM

I have finally gotten around to buy a new external SSD (2TB).

How do I move the files that are used by Logos desktop to the SSD? Please point me to any docs or instructions I can follow, please?

Thanks!

Posts 27120
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, May 22 2019 7:12 AM
Arthur Yeo:
I have finally gotten around to buy a new external SSD (2TB).
For enhanced performance, you need an INTERNAL SSD. The drive should be the same as the one your operating system is on.

OSX & iOS | Logs |  Install

Posts 17809
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, May 22 2019 8:44 PM

Arthur Yeo:
How do I move the files that are used by Logos desktop to the SSD? Please point me to any docs or instructions I can follow, please?

Logos wiki has => Install in different folder or drive

Arthur Yeo:
I have finally gotten around to buy a new external SSD (2TB).

Curious about external connection ? Late 2014 Mac Mini has Thunderbolt and USB options for external storage.

Personally have experienced macOS 10.14 sometimes ejecting USB external 512 GB SSD, which causes my Logos 8 to crash (since have my Resources folder on external SSD due to faster internal SSD not having enough storage space).

I Fix It has Late 2014 Mac Mini repair guides => https://www.ifixit.com/Device/Mac_Mini_Late_2014

Keep Smiling Smile

Posts 5235
Dan Francis | Forum Activity | Replied: Wed, May 22 2019 8:54 PM

cloning the entire drive to the external and then starting off it should work ok. Superduper or carboncopycloner should work ok. 

-dan

Posts 17809
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, May 22 2019 8:58 PM

Dan Francis:
cloning the entire drive to the external and then starting off it should work ok.

Creating USB installer for macOS allows startup from USB so Apple's Disk Utility can be used for copying (restoring) storage partitions.

Edit: also have installed macOS to a new storage partition, which included copy of stuff from an existing partition.

Keep Smiling Smile

Posts 27
Arthur Yeo | Forum Activity | Replied: Thu, May 23 2019 11:01 AM

>>  Logos wiki has => Install in different folder or drive

In that link, it talked about Logos using ~/Library/"Application Support"/Logos4

When I went to my ~/Library/"Application Support"/ dir, there is only Logos4.

I thought we are on Logos8 ?

Am I missing something? Or they have not changed the name of the folder?

Page 1 of 2 (21 items) 1 2 Next > | RSS