CRASH: Repeated crashes with 8.8 Beta 1

Page 1 of 1 (4 items)
This post has 3 Replies | 0 Followers

Posts 10582
Forum MVP
Jack Caviness | Forum Activity | Posted: Wed, Aug 28 2019 8:27 AM

Logos 8.8 Beta 1 Mac OS 10.14.6

Forum software will not load a screenshot of the main display. Had UBS5 in Multiple Resources view with 6 English translations. USB5 is in a series with LHB.

Put Dt 29 into the address box. Logos opened LHB and the pizza started to spin. In a few seconds, Logos disappeared from the screen. No Apple Crash dialog.

1st crash

2437.LogosLogs.jackcav.20190828-111049.zip

3rd crash

8080.LogosLogs.jackcav.20190828-111423.zip

Disabled Multiple Resources and entered Exo 12.1 into the address field. LHB appeared at Exodus 12.1, but the Multiple Resource button was missing, and the resource tab still showed UBS5. Logos then disappeared again.

6278.LogosLogs.jackcav.20190828-113426.zip

FOUND THE CULPRIT

On then secondary display I had a small window containing the KJV and Byz text linked to the main display. After closing this window, could switch testaments without incident.

Guess the bug lies in going to an address that does not exist in the resource.

Posts 2679
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Wed, Aug 28 2019 9:19 AM

Hi Jack,

Thanks for reporting this. I was able to narrow things down further in case this helps you avoid the crash until we fix it. The issue seems to be when a child resource with only the NT of a Multi-view set is linked to a panel trying to navigate the OT. I've written up a bug report.

Posts 10582
Forum MVP
Jack Caviness | Forum Activity | Replied: Wed, Aug 28 2019 9:56 AM

Philana R. Crouch:
The issue seems to be when a child resource with only the NT of a Multi-view set is linked to a panel trying to navigate the OT. I've written up a bug report.

Glad you could isolate the source. I took that window out of the layout. Didn't remember why it was there Stick out tongue Perhaps my layouts have too many windows Wink

Posts 2679
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Tue, Sep 3 2019 2:07 PM

Jack Caviness:

Logos 8.8 Beta 1 Mac OS 10.14.6

Forum software will not load a screenshot of the main display. Had UBS5 in Multiple Resources view with 6 English translations. USB5 is in a series with LHB.

Put Dt 29 into the address box. Logos opened LHB and the pizza started to spin. In a few seconds, Logos disappeared from the screen. No Apple Crash dialog.

1st crash

2437.LogosLogs.jackcav.20190828-111049.zip

3rd crash

8080.LogosLogs.jackcav.20190828-111423.zip

Disabled Multiple Resources and entered Exo 12.1 into the address field. LHB appeared at Exodus 12.1, but the Multiple Resource button was missing, and the resource tab still showed UBS5. Logos then disappeared again.

6278.LogosLogs.jackcav.20190828-113426.zip

FOUND THE CULPRIT

On then secondary display I had a small window containing the KJV and Byz text linked to the main display. After closing this window, could switch testaments without incident.

Guess the bug lies in going to an address that does not exist in the resource.

This was fixed in 8.8 Beta 2

Page 1 of 1 (4 items) | RSS