Page 1 of 1 (8 items)
This post has 7 Replies | 1 Follower

Posts 21
Christopher (Greenfield, WI) | Forum Activity | Posted: Tue, Jan 4 2022 5:01 AM

Greetings,

I downloaded and installed Logos 9 (upgraded from Logos 8) on an iMac (macOS 10.13.6)

The error message obviously reads that I need macOS 10.14 or later.

I have an older iMac machine.  I'm unable to update to macOS 10.14.

Most application program updates inform me that I'm unable to upgrade to a newer version if my macOS version won't support it.  Logos failed to do that.  It simply installed over Logos 8.

So now I'm unable to use Logos.

How can I revert back to Logos 8?

Thanks in advance!

Chris

Posts 6777
Forum MVP
Lynden Williams | Forum Activity | Replied: Tue, Jan 4 2022 5:13 AM

Sorry for your troubles Christopher. This is all that I could find that might help you get Logos 8 on your machine. https://wiki.logos.com/Quick_Installation_onto_Multiple_Macs 

If that is not helpful best to contact support via telephone or chat. 

Lynden Williams Communications

Posts 30536
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Jan 4 2022 6:54 AM

Christopher (Greenfield, WI):
Most application program updates inform me that I'm unable to upgrade to a newer version if my macOS version won't support it.  Logos failed to do that.  It simply installed over Logos 8.

I agree this should not happen. I'll see if I can get some help from FL. In the meantime, you should still be able to use the web app. 

Link: https://app.logos.com 

macOS, iOS & iPadOS | Logs |  Install

Posts 3053
LogosEmployee
Andrew Batishko | Forum Activity | Replied: Tue, Jan 4 2022 7:08 AM

The community wiki has links to download various older versions of the application: https://wiki.logos.com/Logos_Downloads_Archive#Last_Stable_version_for_OS_X_10.2e11_.28El_Capitan.29.2c_macOS_10.2e12_.28Sierra.29.2c_macOS_10.2e13_.28High_Sierra.29.3a

These versions are unsupported, and I don't know whether or not a fresh install will work correctly.

Andrew Batishko | Faithlife software developer

Posts 21

Thank you all for replying! Big Smile

I managed to recover Logos 8.17.0.22 (backup from a few days ago) from Time Machine and save it to an empty folder on the desktop.  Drag that into the Applications folder?  That sounds too easy!  Before I try that, I'll wait to see if anyone has a better suggestion.

The Logos Wiki link for older versions of the application has version 8.17 SR-3 (for Mac).  I'm guessing that would be next choice if the other scenario (above) won't work.

Thanks in advance for your suggestions!

Chris

Posts 21

Update...

I ended up restoring Logos 8 from Time Machine (back to the Applications folder)

That worked. Cool

I then deleted Logos 9 and restarted Logos 8 just to make sure things A-OK.

Happy Camper here!

Thanks again for your help!

Chris

Posts 30536
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Jan 4 2022 1:18 PM

Glad you have it up and running. As Andrew noted, that version is no longer supported, so at some point it may die. If that happens, there is always the web app. 

macOS, iOS & iPadOS | Logs |  Install

Posts 19599
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Tue, Jan 4 2022 3:05 PM

Christopher (Greenfield, WI):

Update...

I ended up restoring Logos 8 from Time Machine (back to the Applications folder)

That worked. Cool

An option for Logos 8 (or Verbum 8) is using command:

Set Update Channel to Manual

Since the Manual update channel does not exist, the application cannot find a newer version to download (effectively disables automatic program updating).

Christopher (Greenfield, WI):
I have an older iMac machine.  I'm unable to update to macOS 10.14.

An option for macOS Mojave 10.14 upgrade may be a free patcher tool => http://dosdude1.com/mojave/ (do verify iMac is in the list of patchable models)

Forum reply shows Logos 9 on 2011 mac Mini using patched Mojave => https://community.logos.com/forums/p/197497/1146384.aspx#1146384

Keep Smiling Smile

Page 1 of 1 (8 items) | RSS