Favorites going to the wrong place in Theological Journal resources.

Page 1 of 1 (14 items)
This post has 13 Replies | 1 Follower

Posts 5637
Todd Phillips | Forum Activity | Posted: Thu, Aug 19 2010 10:19 AM | Locked

I have several Favorites going to journals like Westminster Theological Journal, Grace Theological Journal, and Trinity Journal. And I just discovered that they are taking me to the wrong place in the resource (newly created favorites work fine, though).

Not sure if this is a program problem or a resource problem.  Anyone else experience this?  Maybe Logos somehow picked up a different version of the files? or the Favorites internal format changed?

All of my Journal files have the same date of modification: 4/18/2010, and the internal date on all the ones I've checked is 2010-04-17.

Wiki Links: Enabling Logging / Detailed Search Help - MacBook Pro (2014), ThinkPad E570

Posts 4077
Melissa Snyder | Forum Activity | Replied: Thu, Aug 19 2010 10:36 AM | Locked

Could those Favorites have been imported from L3 and pointing to earlier versions?

Posts 5637
Todd Phillips | Forum Activity | Replied: Thu, Aug 19 2010 10:44 AM | Locked

No I didn't use favorites in L3, and I remember creating some of these fairly recently.  Some of them might have been created before the 4/18 date that the files have, though.

I see Galaxie has files dated 5/21 on their ftp site.  I'm downloading those now to scan them into Logos.  Not that it will fix the Favorite links, but I was hoping somebody knew something.

Is Logos ever going to host the Journals on their servers?

Wiki Links: Enabling Logging / Detailed Search Help - MacBook Pro (2014), ThinkPad E570

Posts 2279
Andy | Forum Activity | Replied: Thu, Aug 19 2010 11:20 AM | Locked

Todd Phillips:

I have several Favorites going to journals like Westminster Theological Journal, Grace Theological Journal, and Trinity Journal. And I just discovered that they are taking me to the wrong place in the resource (newly created favorites work fine, though).

Hi Todd,

I am running L4.0d SR2 on W7 (I am not a Beta tester) and yet I seem to have a similar problem.

I have just checked my favourites and the vast majority of the journals referenced in my favourites appear to be opening in the wrong place.

I too did not use favourites in L3.

The screenshot below shows a file a created to hold parts 1-5 of a series on TULIP... This appears to have gone completely haywire. None of the links take me to the correct article or, in some cases, even the correct journal. Entries 1 and 2 and then 3 and 4 are duplicates of each other (in effect, I have lost two of the five links).

I am confident that this first worked when I set it up (I have used this folder on a few occasions). I also thought that I had renamed the links with the actual article name (so that I could easily decipher the order and the breakdown)... I am 85% sure that I did rename the links, but then there is a 15% possibility that this might be a result of my dodgy memory.

Is it possible that this is the same issue afflicting both Beta and general users?

If so, I would be grateful if the Logos tech guys could give us an idea what caused this and whether it is now fixed for the future. I wouldn't want to spend several hours rearranging folders and links only for the problem to emerge again.

Thanks in advance.

Andy

Posts 5637
Todd Phillips | Forum Activity | Replied: Thu, Aug 19 2010 11:28 AM | Locked

Andy Evans:

I am confident that this first worked when I set it up (I have used this folder on a few occasions). I also thought that I had renamed the links with the actual article name (so that I could easily decipher the order and the breakdown)... I am 85% sure that I did rename the links, but then there is a 15% possibility that this might be a result of my dodgy memory.

Is it possible that this is the same issue afflicting both Beta and general users?

I think my link names are the same ones I gave them after creating them (abbreviations of the journal name, plus the article name), which helped me find the actual locations to recreate the links.

But you're right, it looks like this isn't just a beta issue.

Also, downloading the latest version of the files from Galaxie didn't change anything.

Wiki Links: Enabling Logging / Detailed Search Help - MacBook Pro (2014), ThinkPad E570

Posts 5637
Todd Phillips | Forum Activity | Replied: Thu, Aug 19 2010 11:46 AM | Locked

After further testing, it appear the old Journal Favorites are just opening the resource without specifying a location.  They are opening them up at the last location they were at, or, if the resource is already open, they don't affect the location of the resource at all.

I'm guessing either the indexing scheme has changed on these resources or else the Favorites storage format changed.

Wiki Links: Enabling Logging / Detailed Search Help - MacBook Pro (2014), ThinkPad E570

Posts 9553
Forum MVP
Mark Smith | Forum Activity | Replied: Thu, Aug 19 2010 12:30 PM | Locked

Todd Phillips:
After further testing, it appear the old Journal Favorites are just opening the resource without specifying a location.  They are opening them up at the last location they were at, or, if the resource is already open, they don't affect the location of the resource at all.

I noticed something similar with converted 3.0 note files and reported it during the beta testing of Notes. Many of the references to journals at best opened the correct journal and volume but that was it. Title page only. My report was acknowledged and I sent files to the development team on their request. Some improvements were noticed by the time Notes went live, but I still have some links that aren't working. I suspect that it was particularly difficult to transfer these to work correctly. I figured I'd have to live with it. The few incidents remaining could be corrected manually.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 2279
Andy | Forum Activity | Replied: Thu, Aug 19 2010 12:39 PM | Locked

Todd Phillips:

I'm guessing either the indexing scheme has changed on these resources or else the Favorites storage format changed.

I have done a little more playing around and it appears that the bookmarks are messed up also (in respect of bookmarked journals). It seems that the bookmarks are taking me to the first page of the correct journal rather than the actual bookmarked page.

I presume that changing the indexing scheme or favourites storage format is an unusual (maybe a one time?!?) deal? We could do with knowing whether this issue is likely to reoccur before investing significant time in organising our favourites.

 

Posts 4077
Melissa Snyder | Forum Activity | Replied: Fri, Aug 20 2010 7:56 AM | Locked

Andy Evans:

I have done a little more playing around and it appears that the bookmarks are messed up also (in respect of bookmarked journals). It seems that the bookmarks are taking me to the first page of the correct journal rather than the actual bookmarked page.

Andy ~  Are you finding, as Todd did, that newly created bookmarks work correctly?

Posts 2279
Andy | Forum Activity | Replied: Fri, Aug 20 2010 8:06 AM | Locked

Hi Melissa,

It seems that newly created bookmarks (to journals) and journals saved in my favourites folders are working. The links and bookmarks (to journals) dating back further than a couple of months or so do not seem to be functioning correctly.

 

Posts 4077
Melissa Snyder | Forum Activity | Replied: Fri, Aug 20 2010 8:10 AM | Locked

Andy Evans:

Hi Melissa,

It seems that newly created bookmarks (to journals) and journals saved in my favourites folders are working. The links and bookmarks (to journals) dating back further than a couple of months or so do not seem to be functioning correctly.

Those previous Favorites and Bookmarks will probably need to be recreated.

Posts 2279
Andy | Forum Activity | Replied: Fri, Aug 20 2010 8:28 AM | Locked

Hi Melissa,

I expected that to be the case and it is no problem whatsoever, but I was wondering if you knew what had caused this and whether it has now been fixed?

I ask because I suspect people are putting a significant amount of time and trust in the favourites system (I know I am!). If the system is potentially unstable/unreliable it would be good to know at this stage. It is tricky remembering and fixing the links that I have collected over the past eight months or so. A year hence, it would be next to impossible (my memory just isn't that good).

I am guessing this is a one off freak issue, but it would be good to know for sure.

Thank you once again for your kind help... It is appreciated!

Andy

Posts 4077
Melissa Snyder | Forum Activity | Replied: Fri, Aug 20 2010 10:32 AM | Locked

Andy Evans:

Hi Melissa,

I expected that to be the case and it is no problem whatsoever, but I was wondering if you knew what had caused this and whether it has now been fixed?

I ask because I suspect people are putting a significant amount of time and trust in the favourites system (I know I am!). If the system is potentially unstable/unreliable it would be good to know at this stage. It is tricky remembering and fixing the links that I have collected over the past eight months or so. A year hence, it would be next to impossible (my memory just isn't that good).

I am guessing this is a one off freak issue, but it would be good to know for sure.

Thank you once again for your kind help... It is appreciated!

Andy

I don't think it was an issue with the functionality of Favorites, but with the change to the Galaxie resources. When resources are edited or rebuilt, it's not common for resource IDs or location information to change. It can occur, but it will probably be rare. 

Posts 2279
Andy | Forum Activity | Replied: Fri, Aug 20 2010 10:35 AM | Locked

Melissa Snyder:

It can occur, but it will probably be rare. 

Thanks, Melissa, that is helpful to know.

 

Page 1 of 1 (14 items) | RSS