Too Slow & No Search Results. Help!

Page 1 of 2 (24 items) 1 2 Next >
This post has 23 Replies | 0 Followers

Posts 1
Tony Wardan | Forum Activity | Posted: Fri, Oct 15 2010 8:20 PM

1731.Archive.zip

I posted previously that Logos 4 is too slow on my (Mac Pro Quad Core 3 GHZ + 9 GB Ram)

Now I noticed that I do not get any results when searching.

The Command "rebuild index" starts indexing but quits after few seconds.

 

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Fri, Oct 15 2010 8:42 PM

Wonder about moving database file /Users/twardan/Library/Application Support/Logos4/Data/gfkfotkx.rba/ResourceManager/logos/Identified.db to your logging folder:  /Users/twardan/Library/Application Support/Logos4/Logging , then restart Mac - Blue icon should appear in Menu Bar - can open Indexer.log file to monitor progress - if indexing completes, try searching - if not, please post another set of log files.

Keep Smiling Smile

Posts 1
Tony Wardan | Forum Activity | Replied: Fri, Oct 15 2010 9:16 PM

8662.Archive.zip

Still no results when searching

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Fri, Oct 15 2010 9:35 PM

Indexer crashed again - wonder about moving 3 files to different folder (e.g. your desktop):

/Users/twardan/Library/Application Support/Logos4/Data/gfkfotkx.rba/ResourceManager/ClauseVisualizer/Identified.db

/Users/twardan/Library/Application Support/Logos4/Data/gfkfotkx.rba/ResourceManager/logos/Identified.db

/Users/twardan/Library/Application Support/Logos4/Data/gfkfotkx.rba/ResourceManager/logos/Discovered.db

Restart Mac

Blue icon should appear in Menu Bar - can open Indexer.log file to monitor progress

Note: if indexing gets going, can take some time.  If blue icon disappears quickly (crash likely), please post logs again.

Keep Smiling Smile

Posts 1
Tony Wardan | Forum Activity | Replied: Fri, Oct 15 2010 10:17 PM

8255.Archive.zip

Problem still there.

Thank you for your patience.

 

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sat, Oct 16 2010 6:49 AM

Indexer still crashing - appears database files OK (crash still repeating).

Couple options: wait for Logos version update next week OR check if a downloaded resource file(s) causing Indexer crash:

Error message stack includes IdentifyResource file - Logos 4 downloads resource files to folders inside /Users/twardan/Library/Application Support/Logos4/Data/gfkfotkx.rba/ResourceManager/Downloaded - after resources identified, Logos 4 moves files to Resources folder, leaving an empty folder in Downloaded:

To figure out which Resource(s) currently troublesome:

Launch Logos 4

Tools => Program Settings (or Logos Bible Software 4 => Preferences)

Change Automatically download updates and Use Internet from Yes to No

Quit Logos 4

To copy Downloaded folder (and contents), press and hold option key, drag Downloaded folder to different location (e.g. desktop) - release option key - check that Downloaded folder and copy have same contents - get info on both folders should have same size and number of items.

Resources should be discovered in roughly oldest to newest (resources were downloaded in a order: with 4 in parallel - file modification time set when download completed - can be bit different that discovery sequence) - in Downloaded folder, look for oldest resource file - move to trash

Launch Logos 4, try Rebuild Index command - watch Indexer.log file - If quickly crash, move next oldest resource file inside Downloaded to trash, try Rebuild Index again.

If Logos 4 rebuilds index, developers would appreciate knowing which resource file(s) cause Indexer to crash.

Keep Smiling Smile

Posts 1
Tony Wardan | Forum Activity | Replied: Sat, Oct 16 2010 2:11 PM

There is only one Folder in ResourceManager/Downloaded. LLS/LOGOS4HELP and it has 1 file, Logoshelp.logos4. I moved it to desktop. Used rebuild Index. Indexing started than quit again.

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sat, Oct 16 2010 2:51 PM

Tony Wardan:

There is only one Folder in ResourceManager/Downloaded. LLS/LOGOS4HELP and it has 1 file, Logoshelp.logos4. I moved it to desktop. Used rebuild Index. Indexing started than quit again.

From description, sounds like same crash - puzzling - can try "Scan /Users/twardan/Desktop" command then rebuild index again, wait for Blue Icon to disappear, quit Logos, and post logs.

Keep Smiling Smile

Posts 1
Tony Wardan | Forum Activity | Replied: Sun, Oct 17 2010 2:58 AM

I did what you said. Indexing quit again

I am sorry to trouble you with this.

5148.Archive.zip

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sun, Oct 17 2010 3:40 AM

Tony Wardan:

I did what you said. Indexing quit again

I am sorry to trouble you with this.

5148.Archive.zip

My apologies too - Logos 4 really not yet usable for you - Thanks for trying stuff and posting logs - know Logos developers will read them.

From forum discussion http://community.logos.com/forums/p/24328/182174.aspx#182174 hoping for new Beta and Stable releases soon (evidently testing found a problem that needs resolution before shipping)

Wiki page has Beta information (including potential risks) => http://wiki.logos.com/The_Logos_4_Beta_Program - also has RSS feed's - updated when new releases ready for download.

Current Beta version 4.10.4.6210 (Build # 46,210) is 11 builds newer than current Stable version 4.10.4.6199 (Build # 46,199) - not know if Beta would be any better for Indexer crash - forum http://community.logos.com/forums/t/24389.aspx has note: if change to Beta, cannot go back to stable until version 4.0b stable released.  Mac Beta now has its own forum for bug reporting => http://community.logos.com/forums/90.aspx  If decide to become a Beta tester and Indexer crashes again, could post in Mac Beta forum and include link to this thread.

Keep Smiling Smile

Posts 1
Tony Wardan | Forum Activity | Replied: Sun, Oct 17 2010 2:04 PM

I shall reinstall pc version on parallels. Thank you for your help.

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sun, Oct 17 2010 4:52 PM

Tony Wardan:

I shall reinstall pc version on parallels. Thank you for your help.

Understand - until Mac update fixes puzzling Indexer crash, PC only viable option.

Wiki method 3 can be used to copy Resources from Mac OS X to Windows => http://wiki.logos.com/Quick_Installation_onto_multiple_computers

Keep Smiling Smile

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Mon, Oct 18 2010 12:08 PM

Tony Wardan:

I shall reinstall pc version on parallels. Thank you for your help.

Tony,

There is one resource that appears to be crashing your system. 

1) Download the attached EnableDebugLogging.zip file. 6087.EnableDebugLogging.zip

2) Uncompress the file.

3) Rename the file to EnableDebugLogging.sh

4) Open Terminal (Under Applications > Utilities > Terminal)

5) Type the following

cd Downloads

sh EnableDebugLogging.sh

 

6) If step 5 is successful, you should see something like the following printed out on your Terminal

Default logging level changed to Debug in /Applications/Logos Bible Software 4.app/Contents/MacOS/Bootstrap.exe.config

 

7) Restart Logos 4

8) Upload your logs.

Mobile Development Team Lead

Posts 1
Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Mon, Oct 18 2010 2:48 PM

Tony,

I noticed an error in my script that didn't set the debug logging level on the Indexer process as well. Please delete the previous EnableLogging.sh in your Downloads folder and try the above steps with this new script.

7120.EnableDebugLogging.zip

Mobile Development Team Lead

Posts 1
Tony Wardan | Forum Activity | Replied: Mon, Oct 18 2010 6:29 PM

3252.Archive.zip

Thanks for helping.

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Mon, Oct 18 2010 9:59 PM

Tony Wardan:

3252.Archive.zip

Thanks for helping.

Tony,

Hopefully, I'll just need one more set of logs. Start Logos 4, wait for the indexer to stop (the little blue icon goes away). Then type "Rebuild Index" in the command bar and press enter. Wait for the blue icon to appear then disappear, then post the Indexer.log.

Thanks for helping us track this bug down.

 

Mobile Development Team Lead

Posts 1
Tony Wardan | Forum Activity | Replied: Mon, Oct 18 2010 10:14 PM

2287.Indexer.log

Indexer was quitting almost immediately after I start it. It took a few time than it ran for less than a minute.

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Tue, Oct 19 2010 10:44 AM

Perfect! Thanks.

This file is causing problems: /Users/twardan/Downloads/Books/ANSRCALL.LSF

If you move it out of your Downloads/Books folder for now (say to your Desktop), it should allow you to progress while we look at why that book is doing bad things to the Indexer on Mac.

Mobile Development Team Lead

Posts 1
Tony Wardan | Forum Activity | Replied: Tue, Oct 19 2010 1:47 PM

I deleted the file because it was a logos 2 format. I do have the logos 3 version.

I still cannot get indexer to start.

Page 1 of 2 (24 items) 1 2 Next > | RSS