BUG: Searches end with force quitting

Page 1 of 1 (1 items)
This post has 0 Replies | 0 Followers

Posts 8899
fgh | Forum Activity | Posted: Tue, Oct 26 2010 6:51 AM

Longer version:

  1. BWS for h:qadosh with BHS/WIVU prioritized.
  2. Textual Searches gives 0 results (see http://community.logos.com/forums/t/24807.aspx). Click Hebrew Bible nevertheless.
  3. In Search window click Analysis (or make the last search before this in Analysis mode, so that that opens automatically).
  4. The 'wheel' spins forever.
  5. Try to abort the search by closing the tab.
  6. Spinning beach ball of death > force quitting required.

Logs: 4073.Logging101026,14.27.zip

Shorter version:

  1. Bible search for h:qadosh in UBS4. 
  2. (Oops... my last search was in Greek, and I forgot to switch the Bible...)
  3. Try to abort the search by closing the tab, entering another, switching to Morph, quitting the program... 
  4. Spinning beach ball of death > force quitting required.

  • (Possible this only happens in Analysis mode.)
  • (Trying to abort the search by switching to Morph did abort it today, but has given the same result as above earlier. Trying to abort by entering a new search gave no reaction today, but has also given the same result as above earlier.)

Logs: 7026.Logging101026,14.40.zip

Really short version:

  • By now all searches I try result in an endlessly spinning 'wheel', with no results ever coming up. I am also stuck in Analysis. Since the buttons only show up after a search is completed, and I can't complete a search, I can't switch...

Logs: 8473.Logging101026,15.01.zip

  • UPDATE: The last version should have said "all Hebrew and Greek searches". By switching to NAB I finally managed to complete a search, and get out of Analysis. 


Observation 1: The Activity Monitor shows Logos using only 1,3-1,4% of the processor while doing these endless searches. Nothing else going on, except me writing this. Nothing stealing the processor.

Observation 2: The normal universal Mac command to stop something -- cmd-. -- doesn't seem to give any reaction at all. It ought to. There must be a way to abort a mistaken search that will take forever, without having to either wait it out (if at all possible) or force quit the program.

Observation 3: Having to complete a search in one mode (grid, analysis etc), before being able to switch to the one you really want, seems a waste of time (even when it works). The buttons should be visible from the start.

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Page 1 of 1 (1 items) | RSS