Logos 4 Mac Refusing to Download Resources

Page 1 of 1 (5 items)
This post has 4 Replies | 0 Followers

Posts 25
Peter Sanad | Forum Activity | Posted: Sun, May 1 2011 6:25 AM

Running into a problem trying to clean-install Logos 4 Mac on my Macbook Pro.

After downloading the app (today, so assuming the last stable release), and installing onto system, the installer refuses to download resources.

After the welcome screen, and user information submitted, there was a brief "Preparing to Download Resources" immediately  followed by an endless "Preparing Your Library" not accompanied by any computer or internet activity. Clicking on the logos icon in the top-right corner reveals an empty message-box.

This is quite unusual, as it usually downloads resources first before attempting to Index.

I have already tried deleting the Logos Data several times and re-installing to no avail: same problem.

If anybody could point me in the right direction, that would be appreciated. Logs are attached.

Thank you,
Peter.

8055.Logging.zip

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sun, May 1 2011 8:57 AM

Peter Sanad:

Running into a problem trying to clean-install Logos 4 Mac on my Macbook Pro.

After downloading the app (today, so assuming the last stable release), and installing onto system, the installer refuses to download resources.

After the welcome screen, and user information submitted, there was a brief "Preparing to Download Resources" immediately  followed by an endless "Preparing Your Library" not accompanied by any computer or internet activity. Clicking on the logos icon in the top-right corner reveals an empty message-box.

This is quite unusual, as it usually downloads resources first before attempting to Index.

I have already tried deleting the Logos Data several times and re-installing to no avail: same problem.

If anybody could point me in the right direction, that would be appreciated. Logs are attached.

Thank you,
Peter.

8055.Logging.zip

Welcome Big Smile

Wiki has http://wiki.logos.com/Mac_Troubleshooting#Uninstalling_and_Reinstalling_in_Logos_4_Mac with all files and folders to delete for complete uninstall, followed by reinstall (can choose Logos 4 Mac Stable or Beta version).

Logos4.log file shows many sync items downloaded (which have resource link issues since resources not yet available).

Option: do a complete uninstall, then reinstall.  After initial sign-in, change "Use Internet" to No.  Once your Library is ready (resources indexed), then click sync arrows (or use sync now command).  After sync completes (arrows stop spinning without warning sign), change "Use Internet" to Yes.

Indexer.log file has "IndexerProgram | There are 0 updates downloading (out of a maximum of 4); starting a new job (from 828 queued updates)" so 828 resources are queued for download.

Keep Smiling Smile

Posts 25
Peter Sanad | Forum Activity | Replied: Sun, May 1 2011 3:23 PM

Keep Smiling 4 Jesus :):

Logos4.log file shows many sync items downloaded (which have resource link issues since resources not yet available).

Option: do a complete uninstall, then reinstall.  After initial sign-in, change "Use Internet" to No.  Once your Library is ready (resources indexed), then click sync arrows (or use sync now command).  After sync completes (arrows stop spinning without warning sign), change "Use Internet" to Yes.

 

Thank you Keep Smiling,

What you have described I have already tried several times, and still running into the same problem.

I cannot set "use internet" to No since the Logos home-screen does not launch at all: the only thing that is on my screen is the endless "Preparing Your Library" message, when it has not downloaded the resources to prepare yet.

I have gone so far as to clean-install my Mac OS and still have the same problem, so I assume there must be some sort of error with my account details at Logos.

If there are any other suggestions I am happy to try them, but perhaps it might be wiser to just contact Customer Service.

Thanks,
Peter.

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sun, May 1 2011 5:32 PM

Peter Sanad:
If there are any other suggestions I am happy to try them, but perhaps it might be wiser to just contact Customer Service.

Can open Indexer.log file to watch progress of resource downloading and indexing.  By default, Console utility scrolls Indexer.log file contents as new lines are written.

Also can open Activity Monitor utility to watch network usage.  On my internet connection, maximum download speed is 97 KB/sec (takes many hours to download Logos library resources).

When updating an old Logos 4 Mac installation on Mac OS X 10.6.7 from 4.0a to 4.3 Beta 3, took 22 restarts to download 135 resource purchases and updates (consistent with Logos 4.3 Beta 3 release notes).  Indexer.log files had numerous download errors, but eventually downloaded all resources.  If installing Logos 4.3 Beta 3, estimating 125 restarts would be needed to download 828 resources (followed by indexing).

Option: Indexer.log file has URL for each resource download; can manually download to Resources folder on your desktop then use scan command (followed by Logos 4 Mac restart).

Another option: if have backup of Resources folder, could try steps in Copy Logos 4 Resources to Mac OS X to scan them.

After restarting Logos 4 Mac, Indexer.log file shows resource discovery and copying (from previous session or scan command).

Third option is contacting Logos Technical Support => http://www.logos.com/about/contact

Keep Smiling Smile

Posts 25
Peter Sanad | Forum Activity | Replied: Sun, May 1 2011 9:48 PM

Thanks, problem solved!

Your tip to check the log file showed that it was downloading resources while the "Preparing Your Library" message was up.
I was just impatiently waiting for the "Downloading Resources" message I was used to seeing.

Peter.

Page 1 of 1 (5 items) | RSS