Logos only has 1 resource?? Bug??

Page 1 of 1 (11 items)
This post has 10 Replies | 1 Follower

Posts 46
Andy Anglea | Forum Activity | Posted: Sun, Jun 12 2011 7:29 PM | Locked

Apparently since i updated to Beta 7, Logos thinks it only has one resource, Friberg's Analytical Greek Lexicon. I've tried the Rebuild Index command and the Scan /Users/USER_NAME/Library/Application Support/Logos4/Data/PROFILE_ID/ResourceManager/Resources commands without any success.  Not sure what is going on here. The Rebuild Index command pops up the Logos icon in the menubar for a second but then it goes away. The Scan command doesn't seem to do anything. 

I did update directly from Beta 5 to Beta 7, not sure if that has anything to do with it or not...

Thanks for any help with this.

Posts 9488
Forum MVP
Mark Smith | Forum Activity | Replied: Sun, Jun 12 2011 7:43 PM | Locked

Andy, have you by chance logged into Logos under a different user name?

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sun, Jun 12 2011 7:59 PM | Locked

Would like to see diagnostic log files, wiki Mac Troubleshooting => How to Report Bugs in Logos 4 Mac has log posting steps plus link to Logos 4 Mac AppleScript Applications in Files forum, which has application for enabling diagnostic logging.

Keep Smiling Smile

Posts 46
Andy Anglea | Forum Activity | Replied: Mon, Jun 13 2011 1:29 PM | Locked

Here you go. I didn't include them initially, as I wasn't sure if this was actually a bug or just something I was over looking...

Posts 46
Andy Anglea | Forum Activity | Replied: Mon, Jun 13 2011 1:30 PM | Locked

Also here's a second log file after opening it a second time, since I belive the Scan command doesn't run until Logos is restarted.

0143.Logging2.zip

Posts 4077
Melissa Snyder | Forum Activity | Replied: Mon, Jun 20 2011 12:25 PM | Locked

Andy,

Quit Logos 4 and delete the LibraryCatalog folder found in /Users/manthano/Library/Application Support/Logos4/Data/3gutckg3.g0s. When you restart Logos 4 that folder and its files will be recreated. When the program finishes loading, check your Library again and let us know if the problem still exists.

Posts 46
Andy Anglea | Forum Activity | Replied: Mon, Jun 20 2011 12:58 PM | Locked

I tried that yesterday actually (and the LibraryIndex folder) and it still only shows 1 resource. Here's the logs. When I go back to that folder after quitting Logos, there are bunch of files in there besides the catalog.db file that's supposed to be in there. I'm assuming they're the various SQLite lock files which don't get cleaned up because of the error.

And to answer Mark's question, no, i haven't logged in with a different user.

0358.Logging.zip

Posts 4077
Melissa Snyder | Forum Activity | Replied: Mon, Jun 20 2011 1:25 PM | Locked

Andy Anglea:
tried that yesterday actually (and the LibraryIndex folder) and it still only shows 1 resource. Here's the logs. When I go back to that folder after quitting Logos, there are bunch of files in there besides the catalog.db file that's supposed to be in there. I'm assuming they're the various SQLite lock files which don't get cleaned up because of the error.

The log indicates that the ResourceMetadataUpdateServiceClient is only finding and updating metadata for the Analytical Lexicon of the Greek NT, so you might also try deleting the Metadata.db file in /Users/manthano/Library/Application Support/Logos4/Data/3gutckg3.g0s/Updates.

Posts 46
Andy Anglea | Forum Activity | Replied: Mon, Jun 20 2011 1:40 PM | Locked

No luck. Also deleted UpdateManager in case it was related. And I deleted LibraryCatalog again since it had all the what I assume are SLQLite lock files.

Log attached.

7120.Logging.zip

Posts 4077
Melissa Snyder | Forum Activity | Replied: Mon, Jun 20 2011 3:36 PM | Locked

Andy Anglea:

No luck. Also deleted UpdateManager in case it was related. And I deleted LibraryCatalog again since it had all the what I assume are SLQLite lock files.

 

Some users have had success deleting the ResourceManager.db in the /Users/manthano/Library/Application Support/Logos4/Data/3gutckg3.g0s/ResourceManager folder.

Posts 46
Andy Anglea | Forum Activity | Replied: Mon, Jun 20 2011 4:34 PM | Locked

Success! I deleted every .db file that was under 1MB (so i didn't delete any actual data) in the Data/3gutckg3.g0s folder. When i first restarted it, it wanted to re-download 7.24 GB of resources, so I canceled the download through the status bar icon and then it crashed. So i opened it again, and it took longer than usual on the "Preparing your library" window, and then when it opened all 1600+ of my resources were back and accessible. Now it's currently downloading a 50 MB update.

Thanks so much for your help! 

Edit:
Here are the specific files i deleted

Updates.db

history.db

ResourceManager.db

keylinkmanager.db

catalog.db

Metadata.db

LibraryIndex.db

statistics.db

downloadmanager.db

Page 1 of 1 (11 items) | RSS