Logos 4 crashed after install on new Mac

Page 1 of 2 (25 items) 1 2 Next >
This post has 24 Replies | 1 Follower

Posts 16
Pamela S. Downs | Forum Activity | Posted: Tue, Aug 9 2011 10:24 AM

I installed Logos on my new Mac with Lion yesterday.  It installed and periodically indicating it was downloading library.  This morning the home screen was open and blank and when I clicked on the Library icon, Logos shut down and gave me an error message.

 

7433.Archive.zip

Posts 1432
Tonya J Ross | Forum Activity | Replied: Tue, Aug 9 2011 11:04 AM

I will send your logs to Development for investigation.

Posts 16
Pamela S. Downs | Forum Activity | Replied: Wed, Aug 10 2011 1:15 PM

Haven't heard anything.  Should I just call support?

Posts 1432
Tonya J Ross | Forum Activity | Replied: Wed, Aug 10 2011 2:04 PM

Pamela S. Downs:
Haven't heard anything

It can take a bit of time for the case to be triaged and assigned to a specific developer before we get any feedback.

Pamela S. Downs:
Should I just call support?

If you are running the stable version of the program (we just updated to 4.3 yesterday) you absolutely can call Customer Support for assistance.  Since we did just update to a new version, I might suggest you try running the setup again; that's likely the first step CS will have you do anyway.  Sometimes just getting the program updated can fix things.  To do so, make sure Logos 4 is quit completely and then click here.

If that doesn't get the program running for you and you do want to give CS a call you can reach them at 1-800-875-6467 during their office hours, Monday to Friday, 6am to 5pm Pacific Time.  

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Aug 10 2011 7:49 PM

Pamela S. Downs:

I installed Logos on my new Mac with Lion yesterday.  It installed and periodically indicating it was downloading library.  This morning the home screen was open and blank and when I clicked on the Library icon, Logos shut down and gave me an error message.

Welcome Big Smile

Looking in zip file noticed version 4.2b SR-2, which has many known display issues on OS X Lion; concur with suggestion for Logos 4.3 upgrade.

Option: can use wiki Mac Troubleshooting => Update Error steps.  Currently, Logos 4 Mac stable and beta download links have same 4.3 version (4.30.0.1517), which was released to stable channel several hours after posting home page crash zip file yesterday.

After installing Logos 4.3, may want to issue rebuild bible index command (fix a Bible search result count issue).

Note: Logos 4.3 changed diagnostic logging default to disabled.

Keep Smiling Smile

Posts 1432
Tonya J Ross | Forum Activity | Replied: Mon, Aug 15 2011 11:58 AM

The fix for this issue will be included in 4.3 SR-1.  Once you've installed the update, if you could let us know if the issue has been resolved for you via this thread, that would be greatly appreciated! Smile

Posts 16
Pamela S. Downs | Forum Activity | Replied: Mon, Aug 15 2011 6:51 PM

I installed the upgrade and thought it was fixed.  But before I posted, I wanted to check one more time.  It is not fixed.  Now what is happening is that Logos loads like all is well and then shuts down and closes within one minute or less.

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Mon, Aug 15 2011 7:01 PM

Pamela S. Downs:
It is not fixed.

Apologies: If history repeats, hoping for Logos 4.3 SR-1 to ship this week, based on pattern of past Logos 4 Mac service releases => http://wiki.logos.com/Mac_Release_Notes_and_History

Keep Smiling Smile

Posts 1432
Tonya J Ross | Forum Activity | Replied: Tue, Aug 16 2011 9:10 AM

Apologies for the confusion.  As KS4J mentioned, 4.3 SR-1 (the update I was referring to) has not yet been released.  There will be a forum announcement once it has. Smile

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Tue, Aug 16 2011 5:57 PM

Logos 4.3 SR-1 was released this afternoon to stable channel, wonder if crash fixed ?

Noticed http://wiki.logos.com/Logos_4.3_SR-1 release notes include fixed crash loading home page (with reference to this thread).

Keep Smiling Smile

Posts 16
Pamela S. Downs | Forum Activity | Replied: Wed, Aug 17 2011 12:22 PM

The update downloaded and installed.  I opened and quickly checked and it is now Logos 4.3 SR-1 but it shut down almost immediately after I had time to check the version.

 

Posts 1432
Tonya J Ross | Forum Activity | Replied: Wed, Aug 17 2011 2:34 PM

Some other forum users have been reporting that the program crashes once after the update and then opens normally the second time.  I've reported that issue to Development.   Have you been able to open the program after the initial crash?

If it doesn't open, if you could post new logs that would be most helpful and greatly appreciated.

Posts 16
Pamela S. Downs | Forum Activity | Replied: Wed, Aug 17 2011 3:00 PM

I have opened multiple times and it closes down almost immediately.  I also tried quickly opening a Bible to see if getting off of the home screen would help.  It didn't.  66332265.Archive.zip

Posts 1432
Tonya J Ross | Forum Activity | Replied: Thu, Aug 18 2011 12:31 PM

Your new logs are showing a different error.  Sad  

I'm going to send the new logs to Development.

Posts 1432
Tonya J Ross | Forum Activity | Replied: Tue, Aug 23 2011 3:13 PM

Pamela S. Downs:
I have opened multiple times and it closes down almost immediately.  I also tried quickly opening a Bible to see if getting off of the home screen would help.  It didn't.

This issue should be fixed in 4.3 SR-2 which should ship soon.  Please let us know the outcome, if you would be so kind.

Posts 16
Pamela S. Downs | Forum Activity | Replied: Sun, Aug 28 2011 6:12 PM

Downloaded and installed 4.3 SR-2 but Logos still shuts down within a minute of opening.   Even uninstalled and then reinstalled---same problem.  Here's the error log.

 

file://localhost/Users/psdowns/Desktop/Archive.zip

 

Posts 16
Pamela S. Downs | Forum Activity | Replied: Sun, Aug 28 2011 6:17 PM

5010831.Archive.zip

Sorry, here's the error log file.

 

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sun, Aug 28 2011 8:29 PM

Pamela S. Downs:

5010831.Archive.zip

Sorry, here's the error log file.

Looking at archive file contents, noticed Logos4.log has 4.3 SR-1 entries from Aug 17 (11 days ago) plus Indexer.log has more recent "Logos 4 Logging is not enabled."

Wonder about always enabling Mac Diagnostic Logging , could use an AppleScript application => http://community.logos.com/forums/p/34277/272324.aspx#272324

Restart Mac, then launch Logos 4.3 SR-2

If quickly crash again, please compress Logging folder and reply with new archive file.

Keep Smiling Smile

Posts 1432
Tonya J Ross | Forum Activity | Replied: Mon, Aug 29 2011 10:35 AM

To reinforce what KS4J has said, the logs you posted aren't showing the new issue (I'm sorry, I know you must be frustrated.)

It would probably be easiest for you if you permanently enable logging for the time being (there's a link to the wiki page that has the Terminal command in KS4J's post previous to mine, the 'Mac Diagnostic Logging' one.)  That way you'll always have current log files.  You can always disable the logging later.

 

Posts 16
Pamela S. Downs | Forum Activity | Replied: Mon, Aug 29 2011 2:03 PM

Here's the new archive folder with logging permanently enabled.

06878.Archive.zip

Page 1 of 2 (25 items) 1 2 Next > | RSS