Page 2 of 3 (59 items) < Previous 1 2 3 Next >
This post has 58 Replies | 1 Follower

Posts 9146
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Wed, Dec 21 2011 8:23 PM | Locked

According to the crash dump, the "windir" environment variable is missing on your system.

This should usually be set to C:\Windows

To fix this, open the Start menu and type "environment" into the Search box. Choose "Edit the system environment variables" from the list of programs that appears. Click the "Environment Variables" button to open the Environment Variables dialog. Scroll to the very bottom of the "System variables" list. If my diagnosis is correct, there will be no "windir" entry in the list. To create it, click "New...". Enter "windir" for the name and "C:\Windows" for the value. Click OK to close all the dialogs, and restart Logos 4.

If you still get problems paging through the resource, please collect another crash dump; this crash may have masked the real problem (as you suspected, because it crashed so early).

Posts 164
David Lee | Forum Activity | Replied: Fri, Dec 23 2011 7:41 AM | Locked

windir was there.  There must be another reason for the crash.

Posts 9146
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Fri, Dec 23 2011 2:08 PM | Locked

David Lee:

windir was there.  There must be another reason for the crash.

Agreed, but we can't diagnose the problem until we obtain a crash dump of this crash.

Posts 164
David Lee | Forum Activity | Replied: Sat, Dec 24 2011 5:27 AM | Locked

How can I get a crash dump?  I followed as best as I can the instructions that were given.

Posts 4264
LogosEmployee
Kevin Byford (Faithlife) | Forum Activity | Replied: Tue, Dec 27 2011 11:04 AM | Locked

Hello David,

Just following up - did setting the "windir" environment variable on your system fix this issue?

Posts 164
David Lee | Forum Activity | Replied: Tue, Dec 27 2011 11:53 AM | Locked

Windir was there.  It was not the cause of the crash.  I did not need to add the line into the environment.

Posts 4264
LogosEmployee
Kevin Byford (Faithlife) | Forum Activity | Replied: Tue, Dec 27 2011 2:29 PM | Locked

David Lee:

Windir was there.  It was not the cause of the crash.  I did not need to add the line into the environment.

Understood, and thanks for letting us know.  If you experience the crash again we'd like to take a look at any fresh crash dumps you might have.

Posts 164
David Lee | Forum Activity | Replied: Tue, Dec 27 2011 2:53 PM | Locked

I get the crash almost daily.  I need help to get a crash dump.  I followed instructions as best as I could.  I pressed CTRL key while Logos started.  I turned on permanent diagnostic dump. Nothing helps.  I wanted to have someone to capture my screen and check settings to see why I can not get a crash dump. 

Posts 26953
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Dec 27 2011 4:51 PM | Locked

David Lee:

I get the crash almost daily.  I need help to get a crash dump.  I followed instructions as best as I could.  I pressed CTRL key while Logos started.  I turned on permanent diagnostic dump. Nothing helps.  I wanted to have someone to capture my screen and check settings to see why I can not get a crash dump. 

David, you got one crash dump as per the screen capture you posted, so let me guide you a little:

  • close Logos4
  • turn off permanent diagnostic logging
  • start the crash dump as per instructions for ProcDump
  • don't press any keys whilst Logos4 starts
  • repeat the steps that cause a crash
  • wait until the dump is written & the process exits (as per the Command Prompt screen)
  • zip and email the latest dmp file in C:\David\Procdump  (as per the Command Prompt screen)

Dave
===

Windows 10 & Android 8

Posts 164
David Lee | Forum Activity | Replied: Wed, Dec 28 2011 4:19 AM | Locked

David,

Thank you for your suggestions.  But the procdump crashed before I can reproduce the crash as I discussed earlier.

Posts 164
David Lee | Forum Activity | Replied: Wed, Dec 28 2011 4:46 AM | Locked

Here are logs after the crash under 4.5 B11.  Again, there is no error or crash log.

144581.Logos4.log

7446.Logos4Indexer.log

6076.logos4setup.log

4331.DigitalLibraryInstall.log

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Dec 28 2011 7:07 AM | Locked

Curious if procdump is version 4.01 ?

Looking at Logos4.log, noticed lot of sync updates, updloading, and downloading.

Wonder about restarting computer, check that indexer is not running, then in a command prompt: echo %windir%  If Windows path appears, then try using procdump again.  Once Logos 4 launches, suspect sync arrows will be turning, suggest waiting for sync arrows to stop.  If sync completes without crashing, then try reading KJV 1900.

Keep Smiling Smile

Posts 164
David Lee | Forum Activity | Replied: Wed, Dec 28 2011 8:44 AM | Locked

Procdump is 4.01.  echo %windir% retunrns %windir% not windows path.  Procdump keeps crashing before Logos is fully loaded.  It appears that the crash has to do with sync as you suspect.  The last entry in logos4.log is sync of note files.  The sync is periodically done.  It never completes.

Posts 164
David Lee | Forum Activity | Replied: Wed, Dec 28 2011 8:49 AM | Locked

I can read KJV1900 quite a few chapters before it crashes.  But I can recreate the crash almost all the time as long as I read it long enough.

Posts 164
David Lee | Forum Activity | Replied: Wed, Dec 28 2011 8:52 AM | Locked

As far as I can remember, this problem was introduced after the release of 4.5 beta cycle not necessarily at beta 8.

Posts 4264
LogosEmployee
Kevin Byford (Faithlife) | Forum Activity | Replied: Wed, Dec 28 2011 9:10 AM | Locked

David Lee:

Procdump is 4.01.  echo %windir% retunrns %windir% not windows path.  Procdump keeps crashing before Logos is fully loaded.  It appears that the crash has to do with sync as you suspect.  The last entry in logos4.log is sync of note files.  The sync is periodically done.  It never completes.

Typing echo %windir% from a command prompt should return something like "C:\Windows" (assuming your Windows install is on drive C:\).  If you type "set" from a command prompt does "windir=C:\Windows" appear somewhere?  If not, there is indeed something wrong and %windir% is not properly set.

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Dec 28 2011 9:23 AM | Locked

David Lee:
Procdump is 4.01.  echo %windir% retunrns %windir% not windows path. 

In a command prompt, set shows all environment variables:

If an environment variable is set, then echo %variable% shows the value, otherwise echo repeats the character string.

The environment variable, windir, is a default system variable for Windows:

One way to edit system environment variables is: right click on Computer => Properties (to open System control panel)

In System control panel can click => Advanced system settings

Keep Smiling Smile

Posts 164
David Lee | Forum Activity | Replied: Wed, Dec 28 2011 9:55 AM | Locked

It is strange indeed.  echo %USERNAME% returns David not SYSTEM.  %TEMP% returns c:\Users\David\app...  not c:\windows\Temp.   echo %windir% returns %windir%.  All other variables in System variables returns Value except windir.  I added windir variable in User variables and restarted the computer to see if it makes difference.  It still returns %windir%.   I am running as an administrator.

Posts 9146
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Wed, Dec 28 2011 4:48 PM | Locked

David Lee:

echo %windir% returns %windir%

It would appear that the environment inside the Command Prompt is incorrect (not sure how). However, you should still be able to run a program directly from the Start menu, without launching a Command Prompt first.

Press Windows+R, then enter

C:\Path\To\ProcDump.exe -e -x "%LOCALAPPDATA%\Logos4\System\Logos4.exe" C:\Temp\Logos4.dmp

Hopefully this should let Logos 4 run normally (until you reproduce the crash), and it will write the dump to C:\Temp. (Change the path as appropriate for your system.) 

Posts 164
David Lee | Forum Activity | Replied: Thu, Dec 29 2011 6:25 AM | Locked

Followed the instruction and got a message "Do you want to run this file .... procdump"  When I selected "Run" option, a command screen appears briefly (less than a second) and disappeared.  I cannot find a dump anywhere and Logos4 never started.

Page 2 of 3 (59 items) < Previous 1 2 3 Next > | RSS