Logos 5 won't open at all on my home computer

Page 1 of 1 (8 items)
This post has 7 Replies | 1 Follower

Posts 123
Tim Finlay | Forum Activity | Posted: Tue, Nov 20 2012 9:35 PM

I have successfully got Logos 5 working on my office computer and have downloaded it on my home computer (Windows 7). But when I click the sign in button, it starts going through the sign-in process and then Windows gives me a pop-up box saying that Logos Bible Software has stopped working. I have tried shutting the computer down and restarting but it does not help.

Posts 31849
Forum MVP
MJ. Smith | Forum Activity | Replied: Tue, Nov 20 2012 11:26 PM

I wish I had an idea of what was wrong .... words like prerequisites, ,NET 4.5 and others come to mind but not in a coherent manner. So I'll just bump you hoping others can help.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 325
Robert Wazlavek | Forum Activity | Replied: Wed, Nov 21 2012 2:03 AM

Try removing L5 from your computer and reinstalling it.

Posts 762
Patrick S. | Forum Activity | Replied: Wed, Nov 21 2012 2:56 AM

You could also save the Logos logs and post them to the forum, the Wiki has information on how to do that.


If your home machine hasn't done either downloading of resources (takes time) and/or indexing yet (which as we know takes quite some time) then trying a clean new install could be helpful — you won't lose any time already done for both these things. Also have a look what version of Microsoft .NET which may already be on your home Windows 7 machine. Some people have reported issues in that area.

"I want to know all God's thoughts; the rest are just details." - Albert Einstein

Posts 670
Sleiman | Forum Activity | Replied: Wed, Nov 21 2012 6:49 AM

I am currently having the same issue! I called and talked to customer support for about an hour yesterday. They had control of my laptop, re-installed the software, read the log files etc. It turned out that in my case it's something to do with day and time settings (no idea why) and the loading of the home page on Logos 5. The support guy said that the problem is more likely with the Logos server rather with my computer and that he will raise the issue with others and in the meantime I should work offline!

Suggestion for now: try to hold Ctrl while you start the application, then select either "work offline" or "start with a blank page" (or something like that) to avoid loading the home page and see if this works.

What I did:

After I hung up with Logos, I did my own uninstall and re-install. Because I was not able to find the link to download L5 from my orders page (the link disappeared), I had to download Logos 4 and install it only to find out that it too stopped working.

Ok uninstalled again, but this time I also went through the windows registry file finding and deleting Logos entries (since the uninstall does not clean up the registry entries) where I felt it is safe to do so (after saving a copy of the registry file of course)

Reinstalled Logos 4. Now working fine. Updated resources, indexed and automatically downloaded upgrade to L5 through the update process. Restarted Logos to L5. the home screen crashed again. So now back to working either offline or without the home page :(

Posts 302
John Graves | Forum Activity | Replied: Wed, Nov 21 2012 9:26 AM

I was having the same issue, I went into the registry and renamed my documents file documents.old seems to have worked so far.

Posts 123
Tim Finlay | Forum Activity | Replied: Wed, Nov 21 2012 5:48 PM

Logos has now fixed the problem. They told me to redownload from my  order for Logos 5. That should now work for you as well,


Posts 670
Sleiman | Forum Activity | Replied: Thu, Nov 22 2012 7:46 AM

My issue was fixed today. I received a follow up email from tech support suggesting I simply delete browser cache including cookies (since my issue was with homepage which apparently uses browser technology) and this solved it.

Page 1 of 1 (8 items) | RSS