Proclaim not updating/installing

Page 1 of 1 (2 items)
This post has 1 Reply | 0 Followers

Posts 10
Justin Long | Forum Activity | Posted: Fri, Jan 31 2014 2:45 PM

I tried opening proclaim today. It tried to load an update. I received an error message. Tried several times. Got the same message. Would always stop at the same point in the download. Then tried  restarting my computer. Same thing happened. Tried uninstalling and reinstalling and got the same message:

"Application download did not succeed. Check your network connection, or contact your system administrator or network service provider."

Network is fine. I also tried disabling my firewall and virus protection. Still got the same message.

Clicked on "details" this is what I got (on Windows 7 64 bit machine):


PLATFORM VERSION INFO  Windows    : 6.1.7601.65536 (Win32NT)  Common Language Runtime  : 4.0.30319.18052  System.Deployment.dll   : 4.0.30319.17929 built by: FX45RTMREL  clr.dll    : 4.0.30319.18052 built by: FX45RTMGDR  dfdll.dll    : 4.0.30319.17929 built by: FX45RTMREL  dfshim.dll    : 4.0.41209.0 (Main.041209-0000)

SOURCES  Deployment url   :       Server  : Microsoft-IIS/7.5       X-Powered-By : ASP.NET  Deployment Provider url  :       Server  : AmazonS3  Application url   :       Server  : AmazonS3

IDENTITIES  Deployment Identity  : Proclaim.application, Version=, Culture=neutral, PublicKeyToken=df2f702924a397ec, processorArchitecture=x86  Application Identity  : Proclaim.exe, Version=, Culture=neutral, PublicKeyToken=df2f702924a397ec, processorArchitecture=x86, type=win32

APPLICATION SUMMARY  * Installable application.

ERROR SUMMARY  Below is a summary of the errors, details of these errors are listed later in the log.  * Activation of resulted in exception. Following failure messages were detected:   + Downloading Files/Proclaim_1_20_0_0026_635265112460861631/Proclaim.Models.dll.deploy did not succeed.   + The operation has timed out


WARNINGS  There were no warnings during this operation.

OPERATION PROGRESS STATUS  * [1/31/2014 2:30:57 PM] : Activation of has started.  * [1/31/2014 2:30:57 PM] : Processing of deployment manifest has successfully completed.  * [1/31/2014 2:30:57 PM] : Installation of the application has started.  * [1/31/2014 2:30:57 PM] : Processing of application manifest has successfully completed.  * [1/31/2014 2:31:05 PM] : Found compatible runtime version 2.0.50727.  * [1/31/2014 2:31:05 PM] : Detecting dependent assembly Sentinel.v3.5Client, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a, processorArchitecture=msil using Sentinel.v3.5Client, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a, processorArchitecture=msil.  * [1/31/2014 2:31:05 PM] : Detecting dependent assembly System.Data.Entity, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=msil using System.Data.Entity, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=msil.  * [1/31/2014 2:31:05 PM] : Request of trust and detection of platform is complete.

ERROR DETAILS  Following errors were detected during this operation.  * [1/31/2014 2:33:48 PM] System.Deployment.Application.DeploymentDownloadException (Unknown subtype)   - Downloading Files/Proclaim_1_20_0_0026_635265112460861631/Proclaim.Models.dll.deploy did not succeed.   - Source: System.Deployment   - Stack trace:    at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)    at System.Deployment.Application.SystemNetDownloader.DownloadAllFiles()    at System.Deployment.Application.FileDownloader.Download(SubscriptionState subState)    at System.Deployment.Application.DownloadManager.DownloadDependencies(SubscriptionState subState, AssemblyManifest deployManifest, AssemblyManifest appManifest, Uri sourceUriBase, String targetDirectory, String group, IDownloadNotification notification, DownloadOptions options)    at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)    at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)    at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)    at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)   --- Inner Exception ---   System.Net.WebException   - The operation has timed out   - Source: System   - Stack trace:    at System.Net.HttpWebRequest.GetResponse()    at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)

COMPONENT STORE TRANSACTION DETAILS  No transaction information is available.

Posts 3502
Scott Alexander | Forum Activity | Replied: Sat, Feb 1 2014 11:18 AM

ClickOnce, the Windows installer technology we're currently using sometimes gets into a bad state. We're moving away from this installer in the next version for that reasion. You can get the beta here and just use that. It has been out for about a week and we don't know of any major blocking bugs.

Back to debugging the current installer issues. The error logs you posted make it look like a network issue... A couple things to try.

Uninstall, then reinstall

Disable any anti-virus application you may have running and reinstall (sounds like you tried this).

You can try clearing out your ClickOnce application cache and reinstalling

  1.  Hit Start, then type CMD and hit CTRL + SHIFT + ENTER and approve administrator priveledges for that process.
  2. In the command prompt window type “rundll32 dfshim CleanOnlineAppCache” (minus the quotes) and press ENTER.
  3. restart your computer.
  4. try running the Proclaim setup again and you should have more luck
Page 1 of 1 (2 items) | RSS