L4 not working at all, where to start looking for a solution?

Page 1 of 1 (17 items)
This post has 16 Replies | 1 Follower

Posts 121
Mark Watson | Forum Activity | Posted: Thu, Jan 7 2010 7:48 PM

Today L4 is not working.  Every time I open a Passage Guide, or even during indexing, I get a message that Windows is stating the program has stopped.  Where do I begin to get help on this problem?  I posted earlier with a word file of the screen shot that I was getting and received no reply yet.  I dearly need for this program (L4) to work.  I have never had this type of problem with L3.  So any help would be appreciated to diagnose the problem.

I know from reading the forums in the past month that there are many very talented Logos users and employees out there.

Posts 27919
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Jan 7 2010 7:56 PM

Mark,

Tell us everything about your machine, your version of L4, how it was installed. Try to post jpeg or gif or other compressed image formats (IrfanView is a free program) as Word files are huge and not very good!

We would also like to see log files as per http://wiki.logos.com/Diagnostic_Logging after the stop or crash!

Dave
===

Windows 11 & Android 8

Posts 121
Mark Watson | Forum Activity | Replied: Thu, Jan 7 2010 8:20 PM

Here it goes:

L4 Platinum was installed from DVD.  See below for other details and a question about how to attach the log file.  I was able to create one, and L4 crashed doing nothing on the screen but being on the home page.  The blue Logos logo is in the bar at the bottom saying that it has about 1 hour to go on indexing.

Manufacturer Hewlett-Packard

  Model HP Pavilion dv7 Notebook PC

  Total amount of system memory 4.00 GB RAM

  System type 64-bit operating system

  Number of processor cores 2

  Total size of hard disk(s) 298 GB

  Disk partition (C:) 120 GB Free (285 GB Total)

  Disk partition (D:) 1 GB Free (13 GB Total)

  Media drive (E:) CD/DVD

  Display adapter type ATI Radeon HD 3200 Graphics

  Total available graphics memory 1918 MB

        Dedicated graphics memory 256 MB

        Dedicated system memory 0 MB

        Shared system memory 1662 MB

  Display adapter driver version 8.563.0.0

  Primary monitor resolution 1440x900

  DirectX version DirectX 10

  Network Adapter Realtek PCIe FE Family Controller

  Network Adapter Atheros AR5007 802.11b/g WiFi Adapter

  Network Adapter Microsoft Tun Miniport Adapter

 

L4 version 4.0a SR-2(4.01.3.4767)

I have a text file of the log.  I will need help on how to attach that to a post.

Thanks Dave.

 

Posts 27919
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Jan 7 2010 8:29 PM

Attach according to http://wiki.logos.com/Uploading_Logs (link at the bottom of the Diagnostic Logging page!).

Dave
===

Windows 11 & Android 8

Posts 121
Mark Watson | Forum Activity | Replied: Thu, Jan 7 2010 8:38 PM

Attempting to attach log file.  (by the way, indexing just stopped)

5126.Logos4.log

Let me know if this does not work correctly.

Posts 9552
Forum MVP
Mark Smith | Forum Activity | Replied: Thu, Jan 7 2010 8:53 PM

I'm no expert at reading log files but it looks like Logos was unable to initialize a part of its installation. Perhaps there is a corrupt file the program was trying to access. Have you tried to do a fresh re-install of the program at any point?

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 27919
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Jan 7 2010 8:53 PM

Thanks Mark - that captures the error.

Now ensure everything works OK after indexing and see if the crash can be repeated.

Dave
===

Windows 11 & Android 8

Posts 121
Mark Watson | Forum Activity | Replied: Thu, Jan 7 2010 9:10 PM

Dave Hooton:

Thanks Mark - that captures the error.

Now ensure everything works OK after indexing and see if the crash can be repeated.

 

Dave - here is the next log file from the latest crash.  It has happened twice since my last post.  Once after it finished indexing while L4 was just open "sitting" on the home page.  And then just now in the middle of a passage guide lookup of Matthew 6:16-18.  I have attached the newest log file.

Also, just a day or so ago, I got the Nelson Counseling Essentials on CD from Thomas Nelson and installed and synched with L3 on this machine and then opened up L4 and it added these few resources on counseling.  But I have been using L4 up to this evening without a problem - before this latest indexing.

Trying to rack my brain about all of what I have done in L4 since the beginning of the week.6102.Logos4.log

Posts 121
Mark Watson | Forum Activity | Replied: Thu, Jan 7 2010 9:16 PM

Mark A. Smith:

I'm no expert at reading log files but it looks like Logos was unable to initialize a part of its installation. Perhaps there is a corrupt file the program was trying to access. Have you tried to do a fresh re-install of the program at any point?

 

Mark A. Smith - I have not done any type of re-install since receiving my DVD for L4 Platinum.  However, I have installed some new resources like the Wesleyan Commentary and Nelson's Counseling Essentials from L3 CDs.  (I have L3 still on this same computer.)  I have done a shut down and restart and opened L4 again and it crashes just sitting on the home page now.  So my frustration level is rising, but I still have L3 on another old laptop for backup.  Oh, and I don't have any other "programs like word or excel, etc. open when it crashes" just Internet Explorer, looking at the forums.

Posts 9552
Forum MVP
Mark Smith | Forum Activity | Replied: Thu, Jan 7 2010 9:33 PM

I understand your frustration.

It may take someone from Logos who knows how to read and interpret the log files to pinpoint the problem. At least tomorrow is Friday and some of them will check the forums.

I don't think it is a resource problem so wouldn't be linked to adding new resources. What makes this more difficult is the fact that you are sometimes not doing anything when Logos crashes. Of course that doesn't mean Logos isn't doing something. Hang in.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 121
Mark Watson | Forum Activity | Replied: Thu, Jan 7 2010 9:34 PM

Dave and Mark,

Here is the latest crash log.  I opened L4, left it sitting on the home page, not moving the mouse or anything, then "stopped working" again.  Attached is the log file.

5140.Logos4 - 1127 stop.log

 

Any further suggestions would be greatly appreciated. - Except "throw the laptop out into the snow tonight."  Well at least the cold and snow hasn't ruined my humor.  It was always a little corny.

Posts 9552
Forum MVP
Mark Smith | Forum Activity | Replied: Thu, Jan 7 2010 9:50 PM

The crashes all seem to end the same way. Here's a clip from the last one:

The crash always seems to appear after the data type 'biblio' has been created and during the creation of data type 'bdf'. Since you say you are not running any Logos function when Logos crashes I don't understand what could be causing the program to be trying to create data types.

I wonder if you could open Task Manager and monitor the processes when you open Logos 4 until it crashes. If you sort the processes by CPU you will better be able to see if a process (including a Logos process) is occurring right before the crash.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 27919
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Jan 7 2010 9:51 PM

Mark Watson:
Here is the latest crash log.  I opened L4, left it sitting on the home page, not moving the mouse or anything, then "stopped working" again.  Attached is the log file.

Mark,

They are all the same error but we need a Logos Tech to examine them and hopefully find the problem.

It looks to be a Handout issue, and these have been unstable. A workaround might be to delete them. Load to a blank layout by holding Ctrl as L4 is starting and then delete them.

Dave
===

Windows 11 & Android 8

Posts 121
Mark Watson | Forum Activity | Replied: Thu, Jan 7 2010 10:09 PM

Mark A. Smith:
I wonder if you could open Task Manager and monitor the processes when you open Logos 4 until it crashes. If you sort the processes by CPU you will better be able to see if a process (including a Logos process) is occurring right before the crash.

Mark - I watched the CPU processes as you suggested.  Saw nothing that would register to a novice like myself.  CPU usage levels were very low when L4 crashed again.  I am going to try the suggestion about deleting the handout now.

Posts 121
Mark Watson | Forum Activity | Replied: Thu, Jan 7 2010 10:18 PM

Dave Hooton:
It looks to be a Handout issue, and these have been unstable. A workaround might be to delete them. Load to a blank layout by holding Ctrl as L4 is starting and then delete them.

 

Dave - as soon as Logos came up to the Home Page, I deleted the "Matthew 6:16-18" handout that Logos had created and saved (I may have done it during the indexing earlier this evening by accident) and L4 has been working for 8 minutes now.  It was stopping after 2 minutes every time I opened it.  I have file logging on and have even done a Passage Guide on Matthew 6:16-18 again without it stopping.

I believe you were correct about the "handout" problem.

Praise God for people like you who know more about Logos and computers than I ever will. Big Smile

I just use it like a novice and try to buy all the resources I can afford to help me study the Bible.  I went to a Morris Proctor seminar for L3 and really learned alot, but feel like a beginner again when working with L4.

Posts 19643
Rosie Perera | Forum Activity | Replied: Thu, Jan 7 2010 10:35 PM

Mark Watson:

Dave - ...

I believe you were correct about the "handout" problem.

Praise God for people like you who know more about Logos and computers than I ever will.

I recommend Dave for an "MVP of the Day" award! Star

Posts 27919
Forum MVP
Dave Hooton | Forum Activity | Replied: Fri, Jan 8 2010 1:54 AM

Rosie Perera:
I recommend Dave for an "MVP of the Day" award! Star

Thanks for the accolade, Rosie. My day ends in 3 hours, so there'll soon be a new winner Smile

Dave
===

Windows 11 & Android 8

Page 1 of 1 (17 items) | RSS