L6 Ordering and Download Problems

Page 1 of 1 (5 items)
This post has 4 Replies | 0 Followers

Posts 830
JRS | Forum Activity | Posted: Mon, Oct 27 2014 8:35 AM

I just ordered L6 Reformed Platinum and found two minor problems w/r ordering and downloading:

1) After I selected the L6RP online and then went to my shopping cart, all looked good except that there was no button to allow me to pull the trigger and actually make the purchase. Tried purchasing it on Slimbrowser and on IE11 with the same results.  I had to call and place the order over the phone. 

2) After the purchase, I started L5 and waited for the download but it never came.  Switched from beta channel to default and it still never came.  Had to download LogosSetup.exe from Logos 6 for Windows .

All installed and the indexing is now complete ... let the fun begin!

Neither of these two problems are that major and are easily worked around as described above.  I mention them for the sake of anyone else who might be experiencing the same issues and for feedback to Faithlife.

JRS has left the building.

Posts 13420
Mark Barnes | Forum Activity | Replied: Mon, Oct 27 2014 8:54 AM

JRS:
After the purchase, I started L5 and waited for the download but it never came.  Switched from beta channel to default and it still never came.  Had to download LogosSetup.exe from Logos 6 for Windows .

This is normal. It's possible that you may want to stay on Logos 5 (for example, on older machines), and as a consequence Logos doesn't automatically update all your installations.

Posts 9153
LogosEmployee

JRS:
2) After the purchase, I started L5 and waited for the download but it never came.  Switched from beta channel to default and it still never came.  Had to download LogosSetup.exe from Logos 6 for Windows .

In a beta, the "default" channel is "beta". You have to explicitly "set update channel to stable" to update from 5.3 to 6.0.

Posts 3312
David Taylor Jr | Forum Activity | Replied: Mon, Oct 27 2014 9:19 AM

Bradley Grainger (Faithlife):

JRS:
2) After the purchase, I started L5 and waited for the download but it never came.  Switched from beta channel to default and it still never came.  Had to download LogosSetup.exe from Logos 6 for Windows .

In a beta, the "default" channel is "beta". You have to explicitly "set update channel to stable" to update from 5.3 to 6.0.

This explains so much!  As I am now smacking my forhead.  Thanks!

Teacher, Ministry Leader, Student, Author, Husband

How to upload logs

Visit My Site: Reformed Truths

Posts 830
JRS | Forum Activity | Replied: Mon, Oct 27 2014 10:37 AM

David Taylor Jr:

Bradley Grainger (Faithlife):

In a beta, the "default" channel is "beta". You have to explicitly "set update channel to stable" to update from 5.3 to 6.0.

This explains so much!  As I am now smacking my forhead.  Thanks!

May I join you? 

"Stable" ... of course!

JRS has left the building.

Page 1 of 1 (5 items) | RSS