CRASH Logos 6 SR 3 on Windows 8.1

Page 1 of 1 (13 items)
This post has 12 Replies | 1 Follower

Posts 47
Jason Van Vliet | Forum Activity | Posted: Mon, Nov 3 2014 11:20 AM

Here's what I did:

  1. Ran a new "Search everything" in a Basic Search on the word redeem; default Bible is ESV
  2. Once the search results populated I click on "Search Bible" at the bottom of the first section to get more results from the ESV on the word redeem.
  3. Logos 6 crashed.
  4. Tried it again with a different word, justify, and it crashed again.

Hopefully, you'll be able to sort out the problem and fix it.  Thanks.

PS Thanks for inline search.  Great tool!

Posts 26211
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Nov 4 2014 12:55 AM

We'll need to see some logs to diagnose this.

Enable logging, start Logos, reproduce the crash and upload logs (per the wiki) before you restart Logos.


Windows 10 & Android 8

Posts 47
Jason Van Vliet | Forum Activity | Replied: Tue, Nov 4 2014 5:34 AM


Thanks for the advice Dave.  I hope I did it correctly.  Here are the logs.  If you need more information let me know and I'll try something else.

Posts 26211
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Nov 4 2014 5:25 PM

Logos died without leaving a crash log so we now need to see contents of the Windows Event viewer.


Windows 10 & Android 8

Posts 47
Jason Van Vliet | Forum Activity | Replied: Tue, Nov 4 2014 6:00 PM

OK, thanks Dave.  There were three error logs that may help: 1. Net Runtime 2. Application 3. Windows Error Reporting.  The first two are simultaneous at 8:30:14 and the last slightly later at 8:30:33.  I hope you can make heads or tails out of them, because I can't :-).  Here we go:

1. Net Runtime

Application: Logos.exe

Framework Version: v4.0.30319

Description: The application requested process termination through System.Environment.FailFast(string message).

Message: Unrecoverable system error.


   at System.Environment.FailFast(System.String)

   at System.Windows.Documents.TextStore.GrantLock()

   at System.Windows.Documents.TextStore.GrantLockWorker(LockFlags)

   at System.Windows.Documents.TextStore.RequestLock(LockFlags, Int32 ByRef)

   at MS.Win32.UnsafeNativeMethods+ITfMessagePump.GetMessageW(System.Windows.Interop.MSG ByRef, IntPtr, Int32, Int32, Int32 ByRef)

   at MS.Win32.UnsafeNativeMethods+ITfMessagePump.GetMessageW(System.Windows.Interop.MSG ByRef, IntPtr, Int32, Int32, Int32 ByRef)

   at System.Windows.Threading.Dispatcher.GetMessage(System.Windows.Interop.MSG ByRef, IntPtr, Int32, Int32)

   at System.Windows.Threading.Dispatcher.PushFrameImpl(System.Windows.Threading.DispatcherFrame)

   at System.Windows.Application.RunInternal(System.Windows.Window)

   at System.Windows.Application.Run()

   at LDLS4.OurApp.InitializeAndRun(System.Collections.ObjectModel.ReadOnlyCollection`1<System.String>, Libronix.Utility.Threading.SingleInstanceManager)

   at LDLS4.OurApp.Main(System.String[])

2. Application Error

Faulting application name: Logos.exe, version:, time stamp: 0x5453d76f

Faulting module name:, version: 4.0.30319.34209, time stamp: 0x5348b261

Exception code: 0x80131623

Fault offset: 0x0000000000d3d4d4

Faulting process id: 0xb1c

Faulting application start time: 0x01cff83324604437

Faulting application path: C:\Users\jvanvliet\AppData\Local\Logos5\System\Logos.exe

Faulting module path: C:\WINDOWS\assembly\NativeImages_v4.0.30319_64\Presentatio5ae0f00f#\0c91c4eeee1db068779e4c11ffd5fa0c\

Report Id: b5176001-6426-11e4-bf09-c8f733d37c04

Faulting package full name:

Faulting package-relative application ID:

3. Windows Error Reporting

Fault bucket 94622710520, type 5

Event Name: CLR20r3

Response: Not available

Cab Id: 0

Problem signature:

P1: Logos.exe


P3: 5453d76f

P4: PresentationFramework

P5: 4.0.30319.34209

P6: 5348b261

P7: 6217

P8: 3f

P9: FatalError


Attached files:





These files may be available here:


Analysis symbol:

Rechecking for solution: 0

Report Id: b5176001-6426-11e4-bf09-c8f733d37c04

Report Status: 4104

Posts 8980

Unfortunately this is a bug in WPF that we can't control. (It crashes the app and gives us no chance to recover.)

I've typically only seen this when running Logos 6 under remote desktop; I'm assume you're not doing that?

Unfortunately, I don't know of any workarounds, and we still don't know what causes the problem. It's a wild guess, but it might help to clear your font cache? (Solution 2 here:

Posts 47
Jason Van Vliet | Forum Activity | Replied: Wed, Nov 5 2014 9:17 AM

Hi Bradley,

Thanks for the help.  In the first place, no I'm not using remote desktop. (At least I don't think so because I don't know what that is.)   Secondly, I did clear the font cache but it did not help.  Same problem occurs.  I'm assuming this is not a common problem and is somehow related to my particular setup.  Is that correct?

If so, I'm a fairly standard user.  I simply installed Logos 6 on top of Logos 5 on my laptop.  I'm not using multiple boot, or virtual machines, or anything like that.

The only clue I could possibly give you is this: my laptop is connected to the server here at our seminary.  Some time ago we had a new server installed and they changed not only the server computer itself but also the domain name (do I use the right term)?  Ever since then if Logos updates, it comes to a point in the process where it says that it cannot remove the older version of the program.  At that point I just push cancel and everything is OK and runs fine, except I assume I have some extra old Logos files floating around somewhere on my SSD that are not getting cleaned up.  Would this possibly have anything to do with the problem?

If not, what are my options, if I want to try and make this problem go away?  Reindex?  Reinstall software?  Something else?  I guess I'll live with it if I have to, but it would be nice to clear it up.  Logos has always run crash-lessly for me, I'm happy to report, and I'd like to keep it that way if I could.

Thanks again!

Posts 8980

Reindexing or reinstalling is unlikely to solve the problem, due to it coming from WPF.

Do you also crash when using Search History (the little triangle in the top right of a Search Panel) to go back to a previous Bible Search? If so, then the problem seems specific to Bible Search; we can investigate further but you may just have to avoid the "Bible Search" hyperlink and search history features for now.

Posts 47
Jason Van Vliet | Forum Activity | Replied: Wed, Nov 5 2014 1:07 PM

Hi Bradley,

Well, we're making a little headway.  I went to the Search History and clicked on various previous Bible Searches and everything went OK until I clicked on one that said "Redeem | Everything" and then it crashed before it even got around to displaying any search results. 

Now the interesting thing is that if I try that very same search, but initiate it by going to a new search window, and going to Basic, Everything, and then type in "redeem," the search results populate and it does not crash until a hit "Search Bible" under the first three results from ESV (see screen capture below) or scrolling down if I hit "Search Media for 'Redeem"" it also crashes.  Other show more type options work without a crash.  It only seems that launching a "Search...." from the Everything results panels causes the crash.

But the curious thing is that if I go to Search History and pick "Redeem | Everything" I would expect the Everything results panel to appear and then--like normal--crash when I click on a "Search..." but for some reason it crashes before the results appear. 

Maybe this anomaly helps you to narrow the source of the problem.

I look forward to any further diagnosis you can provide.

Posts 47
Jason Van Vliet | Forum Activity | Replied: Wed, Nov 5 2014 1:38 PM

Important Update!

Hello again,

I tried something else.  The search window that I have been launching the "crashy" Search Everything has been a standard part of the layout that I've been using for a long time.  I decided to close that Search window, and start with a fresh new Search window.  I did exactly the same Search Everything for "Redeem".  Not only did it populate the results just fine, I clicked on both "Search Bible" and "Search Media" and it popped up new search windows with results just as I would expect, and best of all, no crashes!

So, it's tied to something in my layout.  Now I can delete the layout and make a fresh new one, and hopefully all problems will go away.

I'm just wondering if you want me to hold on to the problematic Search Everything in that particular layout so that you can further diagnose what the problem might be.

Let me know what you like and I'll proceed accordingly.  In the meantime I've found a very straightforward work-around.

Posts 26211
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Nov 5 2014 1:58 PM

Jason Van Vliet:
In the meantime I've found a very straightforward work-around.

Well done! Just hang onto that layout until Bradley responds.


Windows 10 & Android 8

Posts 8980

Glad to hear you've found a fix.

We have a way to reproduce a similar crash internally (using Remote Desktop) so we won't need you to hold on to the layout.

Posts 47
Jason Van Vliet | Forum Activity | Replied: Wed, Nov 5 2014 4:02 PM


I hope you're still following this thread because I think I understand what's happening.  I setup an entirely new layout, but the crash still happened again.  Then the difference between my layout and a fresh new search window struck me.  In my layout I have that search window set as the target ("Send searches here" option is on). 

However, if you do an Everything search with that window set as the target, and you click on "Search Bible" or "Search Media..." then it tries to display the search in the same window that you click from.  Normally, you might be calling searches from all kinds of different windows (Exegetical Guide or Passage Guide), but now you're calling from within the same window so it has to display on top of itself and I guess WPF doesn't like doing that very much.

I suppose that either you can convince WPF to do what it doesn't want to do, or another option would be that Search... calls from within a Search Everything window always default to opening a new search results window, even if the "Send searches option" is set

I can confirm that this is the problem.  Whenever I click on "Send searches" the crash problem occurs, whenever I take that option off, everything works fine.

Page 1 of 1 (13 items) | RSS