[resolved] 6.0a: BUG: PBB error when rebuilding

Page 3 of 3 (51 items) < Previous 1 2 3
This post has 50 Replies | 2 Followers

Posts 18594
Rosie Perera | Forum Activity | Replied: Tue, Jan 20 2015 7:00 PM

Dylan Rondeau:
This should be fixed in 6.1 Beta 1. Big Smile

Yay! Confirmed it's fixed.

Posts 18594
Rosie Perera | Forum Activity | Replied: Fri, Mar 13 2015 3:44 AM

Rosie Perera:

Dylan Rondeau:
This should be fixed in 6.1 Beta 1. Big Smile

Yay! Confirmed it's fixed.

Bummer! This is broken again in 6.2 Beta 2:

PBB Log file:

7446.PBB_61d6de97b89a407e838a7dc386135f13_2015-03-13T10_41_29Z.log

Logos Log file (note that I uploaded this before quitting Logos so it's not a complete session; and there's a ton of other stuff in there above the key point where the error occurred; I rebuilt one more time after the error and it succeeded that time):

5140.Logos.log

Posts 9
LogosEmployee
Matthew Pearson | Forum Activity | Replied: Fri, Mar 13 2015 11:26 AM

Hi Rosie,

I'm sorry you had trouble rebuilding your personal book. I'm even more sorry that I haven't been able to reproduce the error on my machine. In my experience, this bug is usually caused when some other part of the application has the personal book open in some way and does not "play nice" and release it when asked. Between when you built the book the first time, and rebuilt it the time it failed, did you do any work with it within Logos? Did you have any other panels, menus or searches open or active at that time?

I'm struck that you were able to rebuild it successfully after the initial failure. That might mean that whatever was holding on to the book did release it, just a little too slowly for the personal book builder. I'd love to hunt this one down for you! If it's not too much trouble for you to talk me through the steps needed to trigger it again and send me a full screenshot of the app, not just the small portion above, that would be tremendously helpful.

Thank you very much!

Matthew

Posts 9819
Forum MVP
NB.Mick | Forum Activity | Replied: Fri, Mar 13 2015 11:57 AM

Rosie Perera:
I rebuilt one more time after the error and it succeeded that time

That's a great improvement. In "former times" the error always needed a restart of Logos.

Running Logos 8 latest beta version on Win 10

Posts 18594
Rosie Perera | Forum Activity | Replied: Sat, Mar 14 2015 12:57 AM

Hi Matthew,

Here's a full screenshot, though it might not be exactly what my layout looked like when this problem came up last night, however it's pretty close, since I haven't been using Logos at all today.

Alas, I don't have time to see if I can reproduce this now. But what I had done at the time was have Word open with the .docx file. I made a change in the .docx file and then switched back to Logos and rebuilt the book. Then I switched back to Word and made another change in the .docx file and then switched back to Logos and rebuilt the book again. The second rebuild caused the failure. I don't recall doing anything else in Logos other than looking at the PB to see if the change I'd done made any difference. I might have opened the PBB log file (in Notepad) to look at the warnings, and I might have left it open. But leaving it open other times has not seemed to cause this bug to appear so I doubt that was the culprit.

Posts 10426
Forum MVP
Jack Caviness | Forum Activity | Replied: Sat, Mar 14 2015 4:45 AM

NB.Mick:

Rosie Perera:
I rebuilt one more time after the error and it succeeded that time

That's a great improvement. In "former times" the error always needed a restart of Logos.

Still requires a restart in the Mac version Crying

Posts 2829
Don Awalt | Forum Activity | Replied: Sat, Mar 14 2015 7:14 AM

I can reproduce this every time, in the following way:

Download the files for the Biblical Illustrator series that has been posted in the Files forum, and build them as Personal Books.

Once they are all built, what I did this morning on Verbum 6.2 beta 2 was just start going down the list, click Edit then Build, you will get, depending on the speed of your computer, about 10-12 or so queued up to build, and all will be well. A soon as the first one completes, and displays, then the error wil result, and it will continue with every PB you attempt to build. You have to close the panels (on Windows) to get the error one(s) to build. 

Posts 1471
Angela Murashov | Forum Activity | Replied: Mon, Apr 27 2015 1:22 PM

Jack Caviness:

Rosie Perera:
But I see from the others that it doesn't fix it for Mac.

Crying

This should be fixed in 6.3 Beta 3.

Posts 24475
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, May 12 2015 11:48 PM

Rosie, Jack

Is this (perennial) finally fixed?

Dave
===

Windows & Android

Posts 10426
Forum MVP
Jack Caviness | Forum Activity | Replied: Wed, May 13 2015 3:28 AM

Dave Hooton:

Rosie, Jack

Is this (perennial) finally fixed?

Successfully rebuilt a PB twice—once while it was closed and even while it was open. Guess we can call it fixed.

BTW: Dave, thanks for calling these old bug reports to our attention.

Posts 18594
Rosie Perera | Forum Activity | Replied: Wed, May 13 2015 11:25 AM

Dave Hooton:

Rosie, Jack

Is this (perennial) finally fixed?

Yes, it appears to be fixed on my one simple trial just now. I haven't been building PBBs lately, though, so if there's an intermittent problem still there I wouldn't likely encounter it for a while.

Page 3 of 3 (51 items) < Previous 1 2 3 | RSS