Logos 6, Yosemite, and Customer Service

Page 1 of 1 (3 items)
This post has 2 Replies | 1 Follower

Posts 13
Joey K. Rountree | Forum Activity | Posted: Wed, Dec 31 2014 1:12 PM

Does anyone know if Logos or Apple is any closer to resolving the Yosemite downloading issue? I have been a Logos customer for years and have never experienced a problem like this. After upgrading (if that is what you want to call it) to L6, I have had nothing but problems. I can only take Logos' word that it is an Apple/Yosemite issue.

Right now I am looking at a message telling me "Downloading 887.1MB of updates" and that it is "22% Complete." Of course, it will do this for about 2 hours and then start all over again. I have performed the suggested work arounds and have called Logos several times. While the people are polite, no one seems to volunteer to go out of their way to follow up with me as a customer. 

What they are quick to do is offer to transfer me to a sales representative in hopes that I will purchase something else. I can't get get the $300 worth of upgrades to work, why would I purchase more?

I guess my main complaint is that I hear nothing from Logos concerning this problem. Even if it is 100% Apple's problem, it would just be nice to hear something. Even if they posted something periodically on the home page letting us as the consumer know that they haven't forgotten about us.

Posts 5573
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Wed, Dec 31 2014 1:23 PM

Joey K. Rountree:
Does anyone know if Logos or Apple is any closer to resolving the Yosemite downloading issue? I have been a Logos customer for years and have never experienced a problem like this. After upgrading (if that is what you want to call it) to L6, I have had nothing but problems. I can only take Logos' word that it is an Apple/Yosemite issue.

Have you seen this thread: https://community.logos.com/forums/t/96394.aspx 

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 3161
LogosEmployee
Thomas Ball | Forum Activity | Replied: Wed, Dec 31 2014 1:25 PM

Hello Joey,

Please follow Step one here --> https://www.logos.com/support/logos6/mac/error-yosemite They should resolve the problem for you. 

We've had a number of success stories from people following the instructions there 

Edit: I see I've come in too late. My links are still relevant so I'll leave them there. Thank you, Rich! 

 

Page 1 of 1 (3 items) | RSS