Search

Search in sorted by
  • Re: Old Logos 1.6

    I want to use Logos 3.6 again. I have an old notebook, that it still works, and I will install Windows 98 to use this version. I almost have all the diskettes, but not all. I used thia version a lot some years ago, and it liked a lot. And I like some resources of this version.
    Posted to Files by Carlos Luna on Sun, Mar 13 2011
  • Re: Old Logos 1.6

    I need any setup diskettes of Logos Bible Software version 1.6. I have almost all diskettes. But any are corromped. Can you help me?
    Posted to Files by Carlos Luna on Sun, Mar 13 2011
Page 1 of 1 (2 items) |