[resolved] Sync Error - ReadingPlanSyncItem

Page 1 of 1 (11 items)
This post has 10 Replies | 1 Follower

Posts 166
Anthony | Forum Activity | Posted: Wed, Apr 22 2015 6:31 AM

Can someone recommend what to do? I have a Sync Failure on my Desktop. Here is the log:

Program Version: 6.2 (6.2.0.0027)
Time: 2015-04-22 08:05:35 -05:00 (2015-04-22T13:05:35Z)
Exception while syncing client: ReadingPlanSyncItem
System.ArgumentNullException: Value cannot be null.
Parameter name: s
at System.IO.StringReader..ctor(String s)
at Libronix.Utility.Json.JsonUtility.FromJson(String json, Type type, JsonInputSettings settings)
at Libronix.Utility.Json.JsonUtility.FromJson[T](String json, JsonInputSettings settings)
at Libronix.DigitalLibrary.Documents.ReadingPlan.ReadingPlanManager.ReadDocumentSyncItem(IConnector connector, String itemId, Boolean excludeDeleted)
at Logos.Sync.Client.Database.DatabaseSyncClientRepository`1.GatherModifiedItemsCore(SyncOptions options, IWorkState state)
at Logos.Sync.Client.SyncClientRepository`1.GatherModifiedItems(SyncOptions options, IWorkState state)
at Logos.Sync.Client.SyncClient.Sync(SyncPurpose purpose, IWorkState state)
at Logos.Sync.Client.SyncV2Client.Sync(SyncPurpose purpose, IWorkState workState)
at Logos.Sync.Client.SyncManager.SyncManagerThread()

I tried deleting my Reading Plans, still won't sync. 

Posts 3176
LogosEmployee
Thomas Ball | Forum Activity | Replied: Wed, Apr 22 2015 11:17 AM

Have you modified your reading plan (I.E. changed it or read anything using it) since the sync error began?

 

Posts 166
Anthony | Forum Activity | Replied: Wed, Apr 22 2015 7:01 PM

I'm not sure; I noticed it a week or so ago actually. I don't think I've made any changes other than deleting everything in an attempt to fix it. 

Posts 3176
LogosEmployee
Thomas Ball | Forum Activity | Replied: Thu, Apr 23 2015 9:18 AM

Anthony:
I don't think I've made any changes other than deleting everything in an attempt to fix it.

I am going to email you about this.

 

Posts 25864
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Apr 30 2015 5:50 PM

Anthony or Tommy

Is this fixed?

Dave
===

Windows 10 & Android 8

Posts 3176
LogosEmployee
Thomas Ball | Forum Activity | Replied: Fri, May 1 2015 8:56 AM

Dave Hooton:
Is this fixed?

Yes. I had him rebuild his ReadingPlan folder in Logos' Documents>Unique folder>Documents folder.

 

Posts 10902
Forum MVP
NB.Mick | Forum Activity | Replied: Fri, May 1 2015 9:34 AM

Tommy Ball:

Dave Hooton:
Is this fixed?

Yes. I had him rebuild his ReadingPlan folder in Logos' Documents>Unique folder>Documents folder.

Tommy,

Since I have the same issue and see the same error in my logs - would deleting this folder have it rebuild by Logos and the error go away?

And if so: would it only affect my installation? Reason I'm asking: I deleted all other Reading Plans on my machine - the only Reading Plan I kept is one that I shared to some people from the German forum. I want to avoid that me deleting this plan (or having it affected somehow by Logos rebuilding the folder on my machine) disturbs the reading of all plan followers - I'd rather live with the red exclamation mark. 

Running Logos 8 latest beta version on Win 10

Posts 3176
LogosEmployee
Thomas Ball | Forum Activity | Replied: Fri, May 1 2015 12:16 PM

NB.Mick:
I want to avoid that me deleting this plan (or having it affected somehow by Logos rebuilding the folder on my machine) disturbs the reading of all plan followers - I'd rather live with the red exclamation mark. 

I don't think it will disrtupt the reading plan for others. I asked Anthony if he had made any modifications, or used the Reading Plans since the sync issue. He hadn't so I had no concerns that he would lose anything.

What deleting the local database does is destroy the local reading plan information. When you restart Logos we pull down the missing Reading Plan information that was last successfully synced. This means if you've progressed in the reading plan you'll need to use the "catch up to here" option to make it current. It shouldn't disrupt your community reading plan, but you can always move the database file out en lieu of deleting it in case something bad does happen, and then you can put it back if that's the case. 

 

Posts 10902
Forum MVP
NB.Mick | Forum Activity | Replied: Fri, May 1 2015 12:52 PM

Thanks Tommy!

Closed Logos, renamed the ReadingPlan.db file, started Logos: everything fine.

Mick

Running Logos 8 latest beta version on Win 10

Posts 3176
LogosEmployee
Thomas Ball | Forum Activity | Replied: Fri, May 1 2015 1:23 PM

NB.Mick:
Thanks Tommy!

You're welcome, Mick. I'm glad everything is working fine now. 

 

Posts 8
Paul Coleman | Forum Activity | Replied: Fri, Oct 2 2015 10:43 PM

Managed to figure out the "Unique Folder" reference and resolved this same sync error. I did have to reset my layout, close some old docs from a previous study, and reopen the correct docs and reference books, but the sync issue is no longer showing an error. 

Page 1 of 1 (11 items) | RSS