Logos 4.5a beta 4 Big Step Backwards in Notes Performance

Page 1 of 1 (17 items)
This post has 16 Replies | 1 Follower

Posts 2864
Kevin A. Purcell | Forum Activity | Posted: Thu, Feb 9 2012 6:35 AM | Locked

After a major improvement in the speed and performance of the notes feature in previous versions of 4.5, the latest beta slowed this down dramatically. I get a little stutter every few words after typing about a sentence worth of notes. The longer the note gets the worse the performance becomes. This is a very sad development as I previously posted my kudos for the way notes were finally performing after 4.5 and the new sync engine came out.

I have been careful to look at the sync icon in the upper right corner and it stalls but that icon doesn't spin every time. Most of the time it doesn't so I don't think it has to do with the sync feature.

I also tried running it with Use Internet turned off and it stil happens.

Posts 1680
Jerry M | Forum Activity | Replied: Thu, Feb 9 2012 6:48 AM | Locked

My experience with notes it that is erratic.  Some days it is fast and some days it is slow. Kevin your observation may be correct, but so far with me it has been off and on.  Perhaps someone can confirm what you are seeing.

"For the kingdom of God does not consist in words but in power"      Wiki Table of Contents

Posts 620
Jonathan | Forum Activity | Replied: Thu, Feb 9 2012 7:33 AM | Locked

Kevin A. Purcell:

After a major improvement in the speed and performance of the notes feature in previous versions of 4.5, the latest beta slowed this down dramatically. I get a little stutter every few words after typing about a sentence worth of notes. The longer the note gets the worse the performance becomes. This is a very sad development as I previously posted my kudos for the way notes were finally performing after 4.5 and the new sync engine came out.

I have been careful to look at the sync icon in the upper right corner and it stalls but that icon doesn't spin every time. Most of the time it doesn't so I don't think it has to do with the sync feature.

I also tried running it with Use Internet turned off and it stil happens.

I have not noticed a slow down in note entry per se, but I have noticed alot of bugs that affect performance across the entire program (see my reports here, here, here, here, here).Obviously with a beta we are to expect these kinds of problems, so lets hope they get them fixed up before the RC. My main concern is that I have not heard a response to any of my bug reports yet. Plus, the list of bug fixes in the latest beta builds has grown smaller and smaller.

I am wondering what's going on behind the scenes. I thought 4.5a was supposed to be a relatively minor update, but it seems that it is causing a lot of issues across the entire program.

Syntax Searching Group | Michigan Logos Users | L5 FAQ | OSX 10.10 | 2.4 GHz i5 | 8 GB Ram

Posts 2864
Kevin A. Purcell | Forum Activity | Replied: Wed, Feb 15 2012 5:41 AM | Locked

Could someone from Logos reply to this issue? Do you recognize a problem and will there be a fix? I was all in on notes with the previous update, but if it remains like this for long my excitement for the 4.5 update is gone. Notes performance is too big an issue for me. I need to know if this is a short term issue or one of those "it will be fixed soon" kinds of issue where we wait over a year.

Posts 10836
Forum MVP
Jack Caviness | Forum Activity | Replied: Wed, Feb 15 2012 5:47 AM | Locked

Kevin A. Purcell:
Could someone from Logos reply to this issue?

Sent an email to Phil Gons with a link to this thread.

Posts 450
Alexander | Forum Activity | Replied: Wed, Feb 15 2012 6:29 AM | Locked

So odd - I'm not seeing any decreased in performance in note :( You all have my sympathy!

Posts 9151
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Wed, Feb 15 2012 1:13 PM | Locked

Please don't email Phil Gons (who is in Marketing) with bug reports from a beta version of the software; please confine discussion of beta issues to this forum (and the PC Beta forum).

Posts 9151
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Wed, Feb 15 2012 1:17 PM | Locked

Can you post logs and a screencast of the problem?

Posts 10836
Forum MVP
Jack Caviness | Forum Activity | Replied: Wed, Feb 15 2012 1:23 PM | Locked

Bradley Grainger:
please confine discussion of beta issues to this forum (and the PC Beta forum).

That would be fine if Logos gave any indication that they take notice of those bug reports. I emailed Phil because he does get things done no matter what department he is in. When my bug reports are ignored, I contact someone who will care.

I have been so unhappy with the progress of L4 Mac lately that I have begun using L4 Windows (shudder) for Bible study

Posts 397
T Gerold Castle | Forum Activity | Replied: Wed, Feb 15 2012 1:29 PM | Locked

YIKES! Say it ain't so, Jack! Not you!!

In HIS Eternal Service,
Tom Castle
**If we will do God's work, in God's way, at God's time, with God's power, we shall have God's blessings!!**

Posts 10836
Forum MVP
Jack Caviness | Forum Activity | Replied: Wed, Feb 15 2012 2:51 PM | Locked

Tom C:

YIKES! Say it ain't so, Jack! Not you!!

Text boxes in Sentence Diagrams have always had alignment problems in L4 Mac that do not exist in L4 Windows. And Notes are much better in L4 Windows also. Those two areas caused the offending statement. These problems have existed for a long time.

Posts 2864
Kevin A. Purcell | Forum Activity | Replied: Wed, Feb 15 2012 3:36 PM | Locked

Bradley Grainger:

Can you post logs and a screencast of the problem?

 

Here is the screencast

http://www.youtube.com/watch#!v=JtQ_rg9FDBg

Here's my log file

3884.LogosLogs Kevin Purcell 20120215-183528.gz

 

Posts 29800
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Feb 15 2012 5:24 PM | Locked

Kevin A. Purcell:
Here is the screencast

Kevin - YouTube says the video is unavailable. Is that because of privacy settings?

macOS, iOS & iPadOS | Logs |  Install

Posts 2864
Kevin A. Purcell | Forum Activity | Replied: Fri, Feb 17 2012 7:30 AM | Locked

I'm not sure why it doesn't work. Here is a link that I know works.

http://youtu.be/JtQ_rg9FDBg

Posts 453
Mike S. | Forum Activity | Replied: Fri, Feb 17 2012 8:10 AM | Locked

I'm wondering if this is a memory shortage issue. That is to say, when memory has to page out or page in for logos. 

The current logging wouldn't capture any of that (nor would console). Need better instrumentation or higher level of diagnostics.

(I've experienced the same issue)

Posts 29800
Forum MVP
JT (alabama24) | Forum Activity | Replied: Fri, Feb 17 2012 8:23 AM | Locked

Kevin A. Purcell:
Here is a link that I know works.

Thanks. That worked.

macOS, iOS & iPadOS | Logs |  Install

Posts 620
Jonathan | Forum Activity | Replied: Wed, Feb 29 2012 8:23 AM | Locked

Kevin A. Purcell:

I have been careful to look at the sync icon in the upper right corner and it stalls but that icon doesn't spin every time. Most of the time it doesn't so I don't think it has to do with the sync feature.

I also tried running it with Use Internet turned off and it stil happens.

Kevin, I know you said that this still occurs when internet is turned off. So I am not sure if this is related, but I am noticing that this issue is increased exponentially if I am using anything that uses my internet connection (especially programs that upload). If my antivirus, dropbox, online backup software, or email are trying to send anything I get a tremendous slowdown in notes.

It would be nice if Logos could sync independently from notes entry.

 

Syntax Searching Group | Michigan Logos Users | L5 FAQ | OSX 10.10 | 2.4 GHz i5 | 8 GB Ram

Page 1 of 1 (17 items) | RSS