Bulk Star Ratings Not Working

Page 2 of 3 (46 items) < Previous 1 2 3 Next >
This post has 45 Replies | 0 Followers

Posts 1432
Tonya J Ross | Forum Activity | Replied: Mon, May 21 2012 4:38 PM

mitchellisdumb:
I've reproduced this on two computers so far. In 4.5b SR-1, while in the library panel, I select multiple books (whether by ctrl-A, or shift-click) and it gives the option to "set the same rating for all". Problem is, there's no place to click on a star rating and actually set it. I can clear ratings without a problem.

I can reproduce the issue and have reported it to Development.  

mitchellisdumb:

And there's more. When I bring up the information panel for a single resource in the library, the "prioritize" list works but the "browse" tab shows a completely empty gray panel.

This issue should be resolved in 4.5c Beta 2 for beta users and in general when 4.5c ships to the stable channel.

Posts 451
Mitchell | Forum Activity | Replied: Tue, May 22 2012 7:42 AM

fgh:

Good to know, but I shouldn't have to wait for a major release for these fixes. Regressions should be fixed in SR's. And a lot faster than this!

I have to say I was pretty shocked and pretty upset to find that, with all these regressions unaddressed, they had prioritized working on a new beta.

In their defense, Logos 4.5c is moving to a different UI implementation. To fix these problems both in a service release and in the beta means fixing it twice - once under the old (4.5b) paradigm, and again for 4.5c. That means double work, and it means that the SR fix can't be tested in the 4.5c code branch, so there's risk that the fix will add more problems. I'm as disappointed as you are in the regressions, but from a sprint planning perspective I can see the logic in delaying the fixes until 4.5c.

Tonya J Ross:

mitchellisdumb:
I've reproduced this on two computers so far. In 4.5b SR-1, while in the library panel, I select multiple books (whether by ctrl-A, or shift-click) and it gives the option to "set the same rating for all". Problem is, there's no place to click on a star rating and actually set it. I can clear ratings without a problem.

I can reproduce the issue and have reported it to Development.  

mitchellisdumb:

And there's more. When I bring up the information panel for a single resource in the library, the "prioritize" list works but the "browse" tab shows a completely empty gray panel.

This issue should be resolved in 4.5c Beta 2 for beta users and in general when 4.5c ships to the stable channel.

Thank you. I'm looking forward to 4.5c and future releases, based on feedback from beta testers it sounds like a big step in the right direction.

Posts 8893
fgh | Forum Activity | Replied: Tue, May 22 2012 11:13 AM

fgh:

Jack Caviness:
We did finally get information of the probable cause of the regressions

We did? Where? In the beta forum somewhere? Because I'm pretty sure I haven't seen it. All I've seen in the last few days when I haven't had time to post is your continued disappointment and continued requests for information.

I finally found it, at http://community.logos.com/forums/p/49852/368546.aspx#368546:

Todd White:
We have been analyzing what caused these regressions and it looks like some of the preparatory work that was being done for the UI changes (http://community.logos.com/forums/t/49846.aspx) caused some of the problems. I apologize that we didn't catch them sooner, the upcoming 4.5c releases will be focused on fixing as many of these issues as we can and getting it stable so all users can have a better Mac product.

But, like I suspected, that's a beta forum post. Information like this should be posted voluntarily, quickly, and where it's most easily seen by everyone affected. Not reluctantly, late, and hidden away out of sight.

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Posts 10737
Forum MVP
Jack Caviness | Forum Activity | Replied: Tue, May 22 2012 1:04 PM

fgh:
Information like this should be posted voluntarily, quickly, and where it's most easily seen by everyone affected. Not reluctantly, late, and hidden away out of sight.

Agree. Lack of communication with customers has always been a major failing with Logos. I have complained about this since at lease 2006, but to no avail.

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, May 23 2012 10:39 PM

mitchellisdumb:

And there's more. When I bring up the information panel for a single resource in the library, the "prioritize" list works but the "browse" tab shows a completely empty gray panel.

Logos 4.5c Beta 2 has a fix for completely gray panel: "No resource selected."

Keep Smiling Smile

Posts 8893
fgh | Forum Activity | Replied: Sun, Jun 3 2012 7:06 AM

mitchellisdumb:
In 4.5b SR-1, while in the library panel, I select multiple books (whether by ctrl-A, or shift-click) and it gives the option to "set the same rating for all". Problem is, there's no place to click on a star rating and actually set it.

alabama24:

mitchellisdumb:

And there's more. When I bring up the information panel for a single resource in the library, the "prioritize" list works but the "browse" tab shows a completely empty gray panel.

I finally had to give up and download 4.5b, and I can only say that I wish I only had your problems... I get the completely empty pane all the time. I have more than a hundred untagged resources, and no way to attach a single tag... This "update" is a complete scandal! (And the fact that I have to downgrade to it in order to be able to download my new resources is even more scandalous.)

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Posts 1432
Tonya J Ross | Forum Activity | Replied: Mon, Jun 4 2012 4:21 PM

Tonya J Ross:

mitchellisdumb:
I've reproduced this on two computers so far. In 4.5b SR-1, while in the library panel, I select multiple books (whether by ctrl-A, or shift-click) and it gives the option to "set the same rating for all". Problem is, there's no place to click on a star rating and actually set it. I can clear ratings without a problem.

I can reproduce the issue and have reported it to Development.  

This issue should be resolved in 4.5c Beta 4.

Posts 8893
fgh | Forum Activity | Replied: Sun, Jun 10 2012 2:16 PM

fgh:
I get the completely empty pane all the time. I have more than a hundred untagged resources, and no way to attach a single tag...

Oddly, the tagging panel for multiple resources suddenly started working again in the middle of this week, and the day after the info panel for single resources turned up as well. Now it's just the bulk rating that still doesn't work.

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Posts 8893
fgh | Forum Activity | Replied: Wed, Jul 4 2012 7:53 AM

Tonya J Ross:

Tonya J Ross:

mitchellisdumb:
I've reproduced this on two computers so far. In 4.5b SR-1, while in the library panel, I select multiple books (whether by ctrl-A, or shift-click) and it gives the option to "set the same rating for all". Problem is, there's no place to click on a star rating and actually set it. I can clear ratings without a problem.

I can reproduce the issue and have reported it to Development.  

This issue should be resolved in 4.5c Beta 4.

Should be, yes, but it's still there in 4.5c SR-2:

(KS4J, you can put this back on the feature parity list.)

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Jul 4 2012 8:20 AM

fgh:
(KS4J, you can put this back on the feature parity list.)

Apologies: using Logos 4.5c SR-2 (4.53.0.2270) on Mac OS X 10.6.8 am unable to replicate: the stars appear and work for me with many resources.

Wondering if another Logos 4 Mac user is encountering this star rating issue ?  (if confirmed by another user, planning to put back on feature parity list).

Note: personally pondering upgrade to Mountain Lion in a few weeks.

Keep Smiling Smile

Posts 10737
Forum MVP
Jack Caviness | Forum Activity | Replied: Wed, Jul 4 2012 11:21 AM

Keep Smiling 4 Jesus :):
Apologies: using Logos 4.5c SR-2 (4.53.0.2270) on Mac OS X 10.6.8 am unable to replicate: the stars appear and work for me with many resources.

Same OS & L4 as you and the stars do not appear

Keep Smiling 4 Jesus :):
 (if confirmed by another user, planning to put back on feature parity list).

Then, put it back Geeked

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Jul 4 2012 11:50 AM

Jack Caviness:

Keep Smiling 4 Jesus :):
 (if confirmed by another user, planning to put back on feature parity list).

Then, put it back Geeked

Feature Parity list now has reference to this thread:

Keep Smiling Smile

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Jul 18 2012 4:32 PM

Keep Smiling 4 Jesus :):

Feature Parity list now has reference to this thread:

Logos 4.5c SR-3 on Mac provided reason to remove this Feature Parity item.

Keep Smiling Smile

Posts 8893
fgh | Forum Activity | Replied: Wed, Jul 18 2012 4:48 PM

Keep Smiling 4 Jesus :):
Logos 4.5c SR-3 on Mac provided reason to remove this Feature Parity item.

And this time I can confirm that it's fixed for me as well. Smile

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Posts 8893
fgh | Forum Activity | Replied: Tue, Aug 14 2012 8:56 AM

Keep Smiling 4 Jesus :):

Keep Smiling 4 Jesus :):

Feature Parity list now has reference to this thread:

Logos 4.5c SR-3 on Mac provided reason to remove this Feature Parity item.

First attempt in SR-4 showed stars gone again.

Works after restart.

What's it like for the rest of you?

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Posts 10737
Forum MVP
Jack Caviness | Forum Activity | Replied: Tue, Aug 14 2012 12:52 PM

fgh:
What's it like for the rest of you?

Works fine in 4.6 Beta 3, also worked in B2—Don't remember prior to this.

Posts 2778
J.R. Miller | Forum Activity | Replied: Fri, Aug 24 2012 11:24 PM

mitchellisdumb:

I've reproduced this on two computers so far. In 4.5b SR-1, while in the library panel, I select multiple books (whether by ctrl-A, or shift-click) and it gives the option to "set the same rating for all". Problem is, there's no place to click on a star rating and actually set it. I can clear ratings without a problem.

Can anyone else reproduce this?

almost 4 months later and still does not work... this is the reason I don't bother reporting bugs anymore.  Why waste time reporting stuff that is a low priority for Logos?

 

My Books in Logos & FREE Training

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sat, Aug 25 2012 5:17 AM

Joe Miller:

mitchellisdumb:

I've reproduced this on two computers so far. In 4.5b SR-1, while in the library panel, I select multiple books (whether by ctrl-A, or shift-click) and it gives the option to "set the same rating for all". Problem is, there's no place to click on a star rating and actually set it. I can clear ratings without a problem.

Can anyone else reproduce this?

almost 4 months later and still does not work... this is the reason I don't bother reporting bugs anymore.  Why waste time reporting stuff that is a low priority for Logos?

Curious about versions of Logos 4 Mac and OS X ?

Logos 4.6 Beta 5 on OS X 10.6.8 can set and remove star ratings for a bunch of selected resources in the library.

Keep Smiling Smile

Posts 8893
fgh | Forum Activity | Replied: Fri, Aug 31 2012 11:55 AM

Stars gone again yesterday:

This has now happened twice in SR-4, both times directly after resource updates (i e precisely when I need it to work!).

Let's hope 4.6 works better...

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Posts 10737
Forum MVP
Jack Caviness | Forum Activity | Replied: Fri, Aug 31 2012 12:24 PM

fgh:
Let's hope 4.6 works better...

Works for me in 4.6 Stable release, but then it has worked for some time. Don't remember when it started working, perhaps it was with an early 4.6 beta. In case the OS matters, I am on 10.6.8

Page 2 of 3 (46 items) < Previous 1 2 3 Next > | RSS