Proclaim remote issues- how to get it to download all slides for a presentation?

Page 1 of 1 (6 items)
This post has 5 Replies | 2 Followers

Posts 28
Rev. Lawrence Becker | Forum Activity | Posted: Wed, May 20 2020 10:56 PM

Hi- I use Proclaim remote on an iPad Pro (2018 and now 2020 version) to control the flow of the service and provide illustration slides for my sermons. On both of the iPads the slides are slow to populate in the remote software. I thought it was my church’s 80mb up/down internet connection, but the iPads are even slow to populate the screens on my 1gb up/down connection at home. Is there an issue with Proclaim servers about this? I really depend on the slides being there, and often I lately will go to the next screen of slides and several aren’t there.

is there something I need to do to force the download of slides? I thought pulling the main screen with all the presentations listed would do that, but it doesn’t seem to make any difference.

Does my church have too many presentations on the server? 

How can I get better results on this? I am also using another iPad to control camera switching with SlingStudio (on its own dedicated WiFi network), so when I’m preaching or leading worship and switching cameras and moving slides along, and Proclaim isn’t showing the slides (or says unable to change slides), it throws me off. It happens when I am right next to the router, so it isn’t a distance issue. It isn’t a speed issue, because it is happening at home. It isn’t that I’m using an old or slow iPad, this is the latest iPad pro 256gb.

When I’m live on Sundays, it happens when I’m just on WiFi or have the local connection option on.

i think it’s on your end somehow. Help!

Pastor Larry Becker

Posts 130
Lawrence Becker | Forum Activity | Replied: Sun, May 24 2020 6:59 PM

Commenting on my own post here - I took a shot at something. I am using a Netgear Nighthawk AX12 router (looks like something out of Star Wars), and was having a few missed slide changes every Sunday, so I added a Nighthawk AX8 extender for it - it's the one matched for that router. It made a mesh network. I disconnected the extender today, and things worked MUCH better. Anyone know if mesh wifi can cause problems like this? It's still not perfect, and the slides are a little slow to populate the iPad's remote view - but it was usable today. 

I assumed that mesh networks would just allow the wifi to be extended to different areas - but I suspect that Proclaim needs a different setting in the extender, or something set up differently - or just doesn't care for mesh networks. Any advice? 

Posts 26051
Forum MVP
Graham Criddle | Forum Activity | Replied: Sun, May 24 2020 11:11 PM

Interesting - in a previous church we had a mesh network and there were occasional problems with Proclaim slide transitions - I never got to the bottom of what was going on. It may be totally unrelated and may suggest a link where there isn't one but I thought I would mention it!

We have since moved away and I can't check anything there now.

Posts 187
Brandon Adent (Faithlife) | Forum Activity | Replied: Tue, May 26 2020 8:52 AM

Thanks Lawrence, I'm sorry you're having trouble.

Is it possible that there's some built in security function in the extender? There's nothing in Proclaim or the remote that would depend on a specific network topology.

Posts 28
Rev. Lawrence Becker | Forum Activity | Replied: Thu, May 28 2020 3:40 AM

I haven’t turned on any special security features - can you give me an idea of what to look for?

Posts 28
Rev. Lawrence Becker | Forum Activity | Replied: Fri, May 29 2020 11:52 PM

Hi, Brandon,

Today I was able to try a couple of different security settings on the router. It defaulted to “WPA2.” I first tried just turning it off completely as a test - and the difference was incredible. Immediate response, no hesitation at all. Off is not good, so I tried “WPA/WPA2,” and that was better than the default setting, and was probably acceptable, but not as good as Off. I haven’t tried WPA3 yet.  does Faithlife tech have any suggestions or clarification on what’s going on?


Page 1 of 1 (6 items) | RSS