A Bug or a Feature? - Logos 9.5.SR-1

Page 1 of 3 (41 items) 1 2 3 Next >
This post has 40 Replies | 1 Follower

Posts 258
Gerald P. Swetsky | Forum Activity | Posted: Sat, May 29 2021 5:48 PM

Are you guys working on the Jewish Sabbath?  For shame!

Anyhow SR-1 downloaded here yesterday, I think.  Anyhow, it's here.  When I fired up Logos this morning, I went into the Library to look something.  When I went into sort by Author, the Library obeyed me with one glitch - It opened in the middle of the list.  I could move up or down as usual and as I recall, when I went back to sorting by Title, it opened at the top of the list.  Going back to sorting by anything else would open in the middle of the list again.

Okay, never mind that, because for some reason that glitch seems to have healed itself.  However, now we have another glitch.  When I open the Library, it resorts to opening in a window, not a window like opening another resource, but a window covering about seven eighths of my screen.  Yes, I know you're going to say grab the corner and enlarge the window to cover the entire display area.  That was the first thing I tried, but guess what?  It won't open any more than the seven eighths I spoke of.  This is annoying.  I much prefer the way it used to work!

I just discovered another glitch.  If I open the Library and with it open, I mouse over Docs, Guides or Tools, they open without my clicking on them.

Not complaining, just reporting, though I much prefer the way my program worked a couple days ago.

Gerry (If there's a bug in the system, I guarantee I'll be the first to find it) Swetsky

Posts 258
Gerald P. Swetsky | Forum Activity | Replied: Sat, May 29 2021 6:02 PM

Addendum - If I open the Docs, Guides or Tools tab, then mouse over any of the other tabs, whatever I have open closes and the new one opens.  This includes my Library tab!

Gerry

Posts 25143
Forum MVP
Graham Criddle | Forum Activity | Replied: Sat, May 29 2021 11:36 PM

Gerald P. Swetsky:
It won't open any more than the seven eighths I spoke of

I can adjust the size of the window so that it fills the entire screen

This is on Mac - which platform are you running on?

Gerald P. Swetsky:
I just discovered another glitch.  If I open the Library and with it open, I mouse over Docs, Guides or Tools, they open without my clicking on them.

I'm not seeing this - again it would be good to know which platform you are running on.

Posts 258
Gerald P. Swetsky | Forum Activity | Replied: Sun, May 30 2021 4:53 AM

I'm running an ASRock AB350 Pro 4 motherboard with an AMD Ryzen 7 18X processor and an NVIDIA GeForce GTX1070 video card to dual 27 inch monitors.  I have 16 GB of RAM and two SSD's.  My operating system is Windows 10 with all the mandatory updates.  The problem(s) just arose apparently with the SR-1 update.

I just checked this morning and the problems still exist.  I'm not experiencing any problems with any other programs.

Gerry

Posts 25143
Forum MVP
Graham Criddle | Forum Activity | Replied: Sun, May 30 2021 7:57 AM

Gerald P. Swetsky:
Addendum - If I open the Docs, Guides or Tools tab, then mouse over any of the other tabs, whatever I have open closes and the new one opens.  This includes my Library tab!

This has been the behaviour I have seen for some time - long before 9.5 SR-1.

It seems reasonable behaviour as - presumably - my focus has changed and I would want the app to keep up with me.

Am I missing your point?

Posts 25143
Forum MVP
Graham Criddle | Forum Activity | Replied: Sun, May 30 2021 8:05 AM

Gerald P. Swetsky:
I'm running an ASRock AB350 Pro 4 motherboard with an AMD Ryzen 7 18X processor and an NVIDIA GeForce GTX1070 video card to dual 27 inch monitors.  I have 16 GB of RAM and two SSD's.  My operating system is Windows 10 with all the mandatory updates.  The problem(s) just arose apparently with the SR-1 update.

Thanks Gerry

I've just checked on my Windows computer - also running 9.5 SR-1 - and I can't reproduce the behaviour you are describing.

So I'm afraid I don't know why this is happening for you.

Posts 258
Gerald P. Swetsky | Forum Activity | Replied: Sun, May 30 2021 8:12 AM

Graham - I open my Library and then I mouse over to another tab WITHOUT CLICKING THE MOUSE!

This is NOT the way Logos has been working, at least not on my computer.

Gerry

Posts 258
Gerald P. Swetsky | Forum Activity | Replied: Mon, May 31 2021 6:37 AM

I've updated the drivers for Logitech and NVIDIA.  No help.

I can't be the only one experiencing this phenom!

Gerry

Posts 743
Scott E. Mahle | Forum Activity | Replied: Mon, May 31 2021 7:12 AM

Gerald P. Swetsky:

I've updated the drivers for Logitech 

Gerry

Sounds as if it’s a mouse issue. Have you tried a different mouse?

Logos Series X Pastor’s Library | Logos 3 Leader’s Library | 4 Portfolio | 5 Platinum | 6 Feature Crossgrade | 7 Essential | 8 M & W Platinum and Academic Professional | 9 Academic Professional and Messianic Jewish Diamond

Posts 258
Gerald P. Swetsky | Forum Activity | Replied: Mon, May 31 2021 8:28 AM

Searched the house for a USB mouse.  Plugged it in and just for grins, rebooted the computer.

Same problem.  But thanks for the suggestion.

Gerry

Posts 258
Gerald P. Swetsky | Forum Activity | Replied: Mon, May 31 2021 9:01 AM

I have a screen capture I tried to upload, but this forum is cryptic.  It seems to me the Library used to come up in full screen mode covering everything below the tabs.  Now it comes up in a window. ??

Gerry

Posts 5552
SineNomine | Forum Activity | Replied: Mon, May 31 2021 10:57 AM

Gerald, I am confused. Exactly which reported problem are you trying to solve by updating device drivers for your mouse?

Posts 258
Gerald P. Swetsky | Forum Activity | Replied: Mon, May 31 2021 11:26 AM

It was a suggestion.  I find it wise to be able to say, "I tried that" to every possible suggestion people may come up with.

Do you have the same or a similar problem?  Do you have a suggestion I might try?

Gerry

Posts 258
Gerald P. Swetsky | Forum Activity | Replied: Mon, May 31 2021 9:18 PM

Fellow believers, out of frustration, I blew the dust off an old PC, brought it up and loaded Logos on it.  It displays the very same problem that my main desktop does!

I guess I must not be good at explaining this bug to you folks.  Tomorrow I'll call Logos tech support and explain it to them.

Thank you for all your responses and God bless.

Gerry

Posts 1562
Rick Ausdahl | Forum Activity | Replied: Tue, Jun 1 2021 5:05 AM

Gerald P. Swetsky:

Graham - I open my Library and then I mouse over to another tab WITHOUT CLICKING THE MOUSE!

This is NOT the way Logos has been working, at least not on my computer.

Gerry

Gerry, if the discussion is limited to the Library, Docs, Guides, and Tools tabs, then my install of Logos behaves exactly the same as what you have described.  (And yes... without clicking the mouse... simply hovering the mouse.)  I believe that's been the typical behavior.

Posts 258
Gerald P. Swetsky | Forum Activity | Replied: Tue, Jun 1 2021 6:05 AM

Rick Ausdahl:

Gerald P. Swetsky:

Graham - I open my Library and then I mouse over to another tab WITHOUT CLICKING THE MOUSE!

This is NOT the way Logos has been working, at least not on my computer.

Gerry

Gerry, if the discussion is limited to the Library, Docs, Guides, and Tools tabs, then my install of Logos behaves exactly the same as what you have described.  (And yes... without clicking the mouse... simply hovering the mouse.)  I believe that's been the typical behavior.

Yes, that is exactly what I was pointing out - and if you continue across to the right, the behavior continues.

This is in my opinion, a bug and not the way I would expect the program to behave.  I have accidentally moused across one of these tabs when I was using the Library.  This caused me to have to start my Library window again.

Thanks for your reply,
Gerry

Posts 2730
LogosEmployee
Andrew Batishko | Forum Activity | Replied: Tue, Jun 1 2021 6:38 AM

Gerald P. Swetsky:

Yes, that is exactly what I was pointing out - and if you continue across to the right, the behavior continues.

This is in my opinion, a bug and not the way I would expect the program to behave.  I have accidentally moused across one of these tabs when I was using the Library.  This caused me to have to start my Library window again.

This is not a bug. It's an intentional implementation choice, and has behaved in this way for as long as I can recall. It was implemented this way to mimic the behavior of the main menu in many Windows application.

I have no explanation for why you have not noticed this behavior in the past.

Andrew Batishko | Faithlife software developer

Posts 258
Gerald P. Swetsky | Forum Activity | Replied: Tue, Jun 1 2021 8:20 AM

Well I'm 82 and have been into computers personally and professionally from the day Intel first came out with the microprocessor chip and I've never seen a program that behaves in this fashion.  'Tis a bug IMNSHO!

Gerry

Posts 2730
LogosEmployee
Andrew Batishko | Forum Activity | Replied: Tue, Jun 1 2021 9:17 AM

I just tested Chrome, Firefox, Notepad, Acrobat Reader, as well as a half dozen other less well known programs and every one of their main menus all behave in this fashion.

Perhaps I haven't sufficiently described what I'm talking about. Click on the image below to see this in action. Click once on a menu item, then move your mouse to other top-level menu items.

Mainmenu

Andrew Batishko | Faithlife software developer

Posts 258
Gerald P. Swetsky | Forum Activity | Replied: Tue, Jun 1 2021 9:45 AM

We're not talking about drop-down menus here,  we're talking about sub-programs and I'm sticking to my guns.

There's not one convenience to what Logos has done here.  I've reported it to Logos Tech Support and I'm done arguing with you here, Andrew.

Gerry

Page 1 of 3 (41 items) 1 2 3 Next > | RSS