Bug: Program will not move newly downloaded resources from downloaded folders to resources folder

Page 1 of 2 (28 items) 1 2 Next >
This post has 27 Replies | 0 Followers

Posts 91
Seth Hewitt | Forum Activity | Posted: Tue, Dec 14 2010 9:04 AM | Locked

Newly downloaded resources are stuck in folders inside the downloaded folder. L2 Tech support had me delete the resourcemanager.db file to force the program to rebuild resources. It took a long time to rediscover all of my resources, but did not move any of the downloaded files to the resources folder. As an aside, the program has not deleted empty folders when previously downloaded files have been moved to the resources folder.

Logs attached.

Thanks!

Seth

4784.Archive.zip

Posts 91
Seth Hewitt | Forum Activity | Replied: Wed, Dec 15 2010 8:59 PM | Locked

No, really guys, it won't move the resources. Any ideas? Can I move them manually or does the move process involve logging what resources are where? Any thots? I really would like to use those books. This semester is over, so I'm good until January, but if it is something I can do manually now, I'd like to do that.

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Thu, Dec 16 2010 7:47 AM | Locked

Seth,

One of your resources might be corrupt. Take a look at the steps here for enabling debug logging: http://community.logos.com/forums/p/27255/201767.aspx#201767

Once you turn debug logging on, start Logos 4 and let the indexer run, then upload the Indexer.log and I'll take a look.

 

Mobile Development Team Lead

Posts 91
Seth Hewitt | Forum Activity | Replied: Thu, Dec 16 2010 10:58 AM | Locked

Tom, thanks so much for looking at this. Indexer log is attached.

Here's the background: I bought an old Nelson eBible version of the Word Commentary series. (This was the old 2.0 version with the 2 files for every resource wbc##x.lsf and .lix.)  I installed it from CD in windows, let Libronix find the resources and install them (they worked there!), synced my licenses, and exited my windows partition. When I started Logos 4.2a beta 2, the resources downloaded to the downloaded folder, but wouldn't install to the resource folder. I check with cust serv and the licenses are good. The Word Commentary files are all that remain in the downloaded folder.

Thanks for all your help with this. Back to the exegetical! (You remember those!)

Seth

7506.Indexer.log.zip

 

BTW, thanks for fixing the visual filters problem last week. Works like a champ now.

S

 

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Thu, Dec 16 2010 12:03 PM | Locked

So, you're saying that there are files in /Users/Seth/Library/Application Support/Logos4/Data/9167in6v.4lk/ResourceManager/Downloaded/LLS:29.6.5 ?

Mobile Development Team Lead

Posts 91
Seth Hewitt | Forum Activity | Replied: Thu, Dec 16 2010 12:14 PM | Locked

Exactly! Here's a screenshot.

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Thu, Dec 16 2010 4:42 PM | Locked

Ignore what I said in this post. The code I suspected wasn't working isn't the problem.

Mobile Development Team Lead

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Thu, Dec 16 2010 5:39 PM | Locked

Seth Hewitt:
Exactly! Here's a screenshot.

Can you give me the file size of /Users/Seth/Library/Application Support/Logos4/Data/9167in6v.4lk/LicenseManager/Licenses.dat?

Mobile Development Team Lead

Posts 91
Seth Hewitt | Forum Activity | Replied: Thu, Dec 16 2010 7:00 PM | Locked

78 KB

Seth

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Thu, Dec 16 2010 8:56 PM | Locked

Seth,

Can you zip up and send me this file? /Users/Seth/Library/Application Support/Logos4/Data/9167in6v.4lk/ResourceManager/ResourceManager.db

Mobile Development Team Lead

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Thu, Dec 16 2010 9:15 PM | Locked

Seth,

After you send me ResourceManager.db, try entering "Scan /Users/Seth/Library/Application Support/Logos4/Data/9167in6v.4lk/ResourceManager/Downloaded" into the command bar and see if the resources are discovered then.

 

Mobile Development Team Lead

Posts 91
Seth Hewitt | Forum Activity | Replied: Thu, Dec 16 2010 10:14 PM | Locked

Tom, here 'tis.

Seth

0243.ResourceManager.db.zip

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Fri, Dec 17 2010 11:56 AM | Locked

Seth,

Did you get a chance to try the scan command I referenced above?

Mobile Development Team Lead

Posts 91
Seth Hewitt | Forum Activity | Replied: Fri, Dec 17 2010 3:09 PM | Locked

Hi Tom,

Just got home and got your note. Had forgotten to run the scan prog, so thanks for the reminder. I just ran it. Can't tell that it did anything. I didn't see any disk activity. It did not find the files, or rather, they still don't show up in my library. There's your update.

Thanks for working on this!

Seth

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Fri, Dec 17 2010 3:13 PM | Locked

Can you try deleting the Downloaded folder and seeing if the files redownload?

Mobile Development Team Lead

Posts 91
Seth Hewitt | Forum Activity | Replied: Fri, Dec 17 2010 3:21 PM | Locked

Just deleted it and restarted Logos. No activity yet.

Seth

Posts 91
Seth Hewitt | Forum Activity | Replied: Fri, Dec 17 2010 3:23 PM | Locked

Tom, it did recreate the folder, but is not doing any downloading. The folder is empty.

Seth

Posts 91
Seth Hewitt | Forum Activity | Replied: Fri, Dec 17 2010 3:37 PM | Locked

Tom, I took a chance and ran the update resources command. It found missing resources and is now downloading 1.06G. So far just journals, no WBC. Not sure why it would do that unless you all recently updated those resources.

Seth

Posts 91
Seth Hewitt | Forum Activity | Replied: Fri, Dec 17 2010 3:55 PM | Locked

Tom,

OK, same situation. It installed all of the journals, but left the WBC in their folders in the downloaded folder. All of the other folders have been removed and Logos 4 is now reindexing.

Seth

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Tue, Dec 21 2010 4:06 PM | Locked

Once those files finish indexing, can you try deleting the downloaded folder and then running update resources and sending me the Indexer.log once the downloads have finished.

Mobile Development Team Lead

Page 1 of 2 (28 items) 1 2 Next > | RSS