Page 1 of 1 (4 items)
This post has 3 Replies | 1 Follower

Posts 1
Ken Jones | Forum Activity | Posted: Mon, Mar 26 2012 11:07 AM

Attempted to checkout at vyrso.com/checkout, but the Place Order button is grayed out. Is there another step I'm missing?

Linux is much more than an alternative; Light in a dark OS world...

Posts 379
Brian Williams | Forum Activity | Replied: Mon, Mar 26 2012 11:18 AM

Hi Ken!

First off, let me welcome you to the forums! Have you tried using a different browser at all?

Posts 30476
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Mar 26 2012 11:18 AM

Ken - Welcome to the forums! Sorry you are having troubles.

I have heard of others having difficulties on occasions with checkout, but not often. Sometimes it is because the system is down temporarily. 

Have you tried a different browser? Are you signed in to your account? If worst comes to worst, you might want to give Logos a call.

macOS, iOS & iPadOS | Logs |  Install

Posts 60
LogosEmployee
Aaron Dutton (Faithlife) | Forum Activity | Replied: Thu, Mar 29 2012 4:51 PM

For free unlocks on Vyrso and Logos, we require a credit card.  I think others from Logos have talked about this on Logos Speaks so I don't want to dive into the reasons why, but we do use the billing address for our royalty payments to publishers.

Page 1 of 1 (4 items) | RSS