BUG: 5.2 SR-3 (Reproducible case, finally!) PBB failed: "Could not remove existing resource"

Page 1 of 1 (7 items)
This post has 6 Replies | 0 Followers

Posts 18670
Rosie Perera | Forum Activity | Posted: Thu, Dec 5 2013 11:43 PM

I have found a reproducible case of the PBB failed: "Could not remove existing resource" error. Here are the steps I take which make it happen every time:

  • Create a .docx
  • Create a PB, add this .docx, and Build the PB
  • Select all the text in the PB
  • Right-click, and Add to an existing clipping doc
  • Delete the clipping you just added (just that one clipping, not the whole clipping doc it's in)
  • Go back to the PB tool, find the book you just built, and attempt to Build it again.

Result: You get the error: "Build failed with 2 errors, 0 warnings. Could not remove existing resource. Please close all other open panels and try again."

Log files attached, for a session where that's all I did.

In my case, if you close the Clipping document and try again, it does work, though I know when other people have had this problem, they've had to shut down Logos and/or delete the PB and start over.

This bug has been reported numerous times before, but as far as I know a reproducible case has never been posted, and it's never been resolved. 

My reproducible case might not be the same issue that has been causing other people to encounter this error, but maybe tracking this down will reveal something.

Here are some other threads that mention it, none of which end satisfactorily with something akin to "we got it!":

http://community.logos.com/forums/t/34846.aspx

http://community.logos.com/forums/t/36292.aspx

http://community.logos.com/forums/t/40688.aspx

http://community.logos.com/forums/t/42568.aspx

http://community.logos.com/forums/t/50843.aspx

http://community.logos.com/forums/t/72548.aspx

http://community.logos.com/forums/t/75085.aspx

Posts 8893
fgh | Forum Activity | Replied: Fri, Dec 6 2013 5:13 AM

Rosie Perera:
Here are some other threads that mention it, none of which end satisfactorily with something akin to "we got it!":

http://community.logos.com/forums/p/68297/479401.aspx#479401 (more details on the second page) (and, btw, there are still issues on that thread that don't have cases written for them, as far as I can tell)

Rosie Perera:
My reproducible case might not be the same issue that has been causing other people to encounter this error, but maybe tracking this down will reveal something.

Let's hope so, because I'm certainly never doing anything as complicated as that when it happens. I hardly ever use Clippings, and never while building PB's. I tend to save up .docx files from the forums, and when I have annoyingly many, I take some time to build them all, so all I really do is enter metadata, compile, and go back and forth to Finder to look for the next one. Well, if I find one that takes really long to compile, I guess I might check an e-mail or read a webpage or something while I wait.

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Posts 1258
LogosEmployee
Dylan Rondeau | Forum Activity | Replied: Thu, Dec 12 2013 3:17 PM

Rosie Perera:
I have found a reproducible case of the PBB failed: "Could not remove existing resource" error. Here are the steps I take which make it happen every time:

I was able to reproduce with your above steps. There is an active case for the issue, and I've updated it with this info. Hopefully having a reproducible case will help the developers figure out what's going on. Smile

Dylan Rondeau, Software Tester

Enable Logging: Mac | Windows (Right-click "Save As...")

Posts 18670
Rosie Perera | Forum Activity | Replied: Thu, Dec 12 2013 3:22 PM

Thank you, Dylan. And thanks for working your way through all my bugs reported last week, as I see you are.

Posts 18670
Rosie Perera | Forum Activity | Replied: Mon, Dec 15 2014 9:49 PM

Dylan, any update on this? It might be the same bug as this one, which is a simpler reproducible case which is still happening to me in 6.0b Beta 3, every time I rebuild a PB twice in the same Logos session. Extremely annoying.

Posts 1471
Angela Murashov | Forum Activity | Replied: Mon, Feb 23 2015 11:50 AM

Dylan Rondeau:

Rosie Perera:
I have found a reproducible case of the PBB failed: "Could not remove existing resource" error. Here are the steps I take which make it happen every time:

I was able to reproduce with your above steps. There is an active case for the issue, and I've updated it with this info. Hopefully having a reproducible case will help the developers figure out what's going on. Smile

This has been fixed in 6.1.

Posts 18670
Rosie Perera | Forum Activity | Replied: Mon, Feb 23 2015 12:27 PM

Yes, I've confirmed it's fixed. Thank you!

Page 1 of 1 (7 items) | RSS