Bug/Regression: 7.2 SR-1 Sync on OS X 10.10.5 => Spinning Cursors & would not Exit Now

Page 1 of 1 (10 items)
This post has 9 Replies | 0 Followers

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Posted: Mon, Dec 5 2016 9:50 PM

Woke MacBook Air up from sleep with Wi-Fi turned off.

Turned on Wi-Fi, then connected to a network server plus opened Safari so could create this thread.

Opened Logos 7.2 SR-1 on OS X 10.10.5 to a blank layout, which started Sync arrows spinning.

Tried to enter a scan command, which received another spinner:

Sync arrows continued to spin for many minutes. Logos.log file showed some sync time out errors.

Let arrows spin for 1.5 hours followed by quit of Logos 7.2 SR-1 followed by clicking "Exit Now"

After waiting 15 minutes for "Exit Now" (and Logos not responding), choose to Force Quit. Next zipped up diagnostic log files:

2502.Sync_spinning_errors.zip

Restarted OS X with Wi-Fi enabled for next sync attempt.

Keep Smiling Smile

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Tue, Dec 6 2016 1:05 AM

Keep Smiling 4 Jesus :):
Restarted OS X with Wi-Fi enabled for next sync attempt.

Opened Safari to this thread to verify Wi-Fi OK.

Opened Logos 7.2 SR-1 to a blank layout, which did not have spinning sync. Did have a notification to download 1.7 MB so could use scan command.

Keep Smiling Smile

Posts 2829
Don Awalt | Forum Activity | Replied: Tue, Dec 6 2016 5:10 AM

KS4J how big is your library, and how many Visual Filters do you have? In my own uninformed opinion, I think these performance/spinning/freezing issues on the Mac are account based - something that has gotten too big, Things seem the worst when resources are downloaded, or soon after. Other symptoms are that the Home Page takes forever to come up, and I see "preparing Library" for long periods of time. 

I still have the Mac version of Verbum on my work Mac as I can manage my time around the delays - sometimes hours for things like preparing library or home page problems - but on my Home Mac I now have Boot Camp running Windows 10 with Verbum on it - I have uninstalled the Mac version. My home Mac is one of the new Macbook Pros so I recently installed the Mac version on it, and the problems started within days - so I know it's not something specific to a given computer (besides the fact I see it on my work Mac too, which I have also tried uninstalling and reinstalling Verbum completely, one of the tech recommendations by FL).

I have submitted logs and even had private threads going with the tech support guys - they have not been able to find anything. So good luck with figuring out your problems, I will be watching this thread hopefully. I am curious how many books/filters/collections you have so see if my theory has merit.

Posts 2894
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Tue, Dec 6 2016 9:08 AM

Keep Smiling 4 Jesus :):

Restarted OS X with Wi-Fi enabled for next sync attempt.

Keep Smiling Smile

Keep Smiling 4 Jesus,

It looks like you were having some network issues on your end. Your restart likely fixed the problem. Please let us know if this happens again.

Blessings,

Philana

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Tue, Dec 6 2016 11:34 AM

Philana R. Crouch:
Please let us know if this happens again.

Easy to repeat MacBook Air (MBA) network (sync) issues in Logos while Safari access to forum web site works when Wi-Fi is enabled:

  • Close Logos
  • Turn off Wi-Fi
  • Close lid to put MBA to sleep
  • Open lid to wake up MBA
  • Open Logos for offline use
  • Close lid to put MBA to sleep
  • Open lid to wake up MBA
  • Close Logos
  • Turn on Wi-Fi
  • Open Logos for online use, which often has network (sync) issues

FYI: have had to restart MBA many times on different days for online Logos use; sometimes more than once on a single day. Thankful for some weekly Bible studies where MBA travels with me so have experienced Logos sync issues many times.

When Logos is experiencing network issues, quit Logos and clicking "Exit Now" should cause Logos to exit now instead of continuing to wait for sync.

Keep Smiling Smile

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Tue, Dec 6 2016 1:25 PM

Don Awalt:
KS4J how big is your library, and how many Visual Filters do you have?

Resources folder has 21,808 files that use 66.4 GB of space. Currently have 57 Visual Filter documents.

From several alpha/beta crash experiences of opening last used layout and Home Page, have chosen program setting: open to a blank layout. Hence, my 57 visual filters should not be applicable to this thread because no resource was open. Dreaming of visual filter notification when a resource is opened and visual filters are being searched/applied (perhaps something like Link Set indicator in upper left corner that appears while Visual Filter searching is in progress, which goes away when completed).

Due to many collections in my library, have learned to launch Logos and wait for collection cache refresh (dreaming of User Interface notification, possibly like Library message when Catalog index being updated), which can take several minutes. Hence tend to open Logos or Verbum on OS X followed by opening log file so can wait for App Idle message.

Annoying regression is sync arrows spinning that prevent command box usage.

Don Awalt:
I am curious how many books/filters/collections you have so see if my theory has merit.

Library shows 21,642 resources plus have 444 collections.

Keep Smiling Smile

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Tue, Dec 13 2016 7:39 AM

Keep Smiling 4 Jesus :):
Easy to repeat MacBook Air (MBA) network (sync) issues in Logos while Safari access to forum web site works

Repeated this issue on 27" iMac => https://community.logos.com/forums/p/133657/870571.aspx#870571 (27" iMac energy settings keep computer always on along with network using wired connection)

Suspect internet connection went down for awhile overnight since Mail had an account offline. However, quit Mail and relaunch allowed all accounts to be online.  Logos 7.3 RC 1 was launched on OS X 10.10.5 after Mail was online, but Logos 7.3 RC 1 has sync time out errors in Logos.log file plus console messages has:

13-12-16 7:35:50.907 AM com.apple.appkit.xpc.openAndSavePanelService[7382]: Layout still needs update after calling -[NSSavePanelAlertStyleContentView layout]. NSSavePanelAlertStyleContentView or one of its superclasses may have overridden -layout without calling super. Or, something may have dirtied layout in the middle of updating it. Both are programming errors in Cocoa Autolayout. The former is pretty likely to arise if some pre-Cocoa Autolayout class had a method called layout, but it should be fixed.

2577.Logos.log.zip

Since sync cannot complete, Text Comparison shows nothing.  Appears Logos 7.3 has a residual NS issue that needs Force Quit followed by restart of Mac to correct.

Keep Smiling Smile

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Tue, Dec 13 2016 10:45 PM

Keep Smiling 4 Jesus :):
Easy to repeat MacBook Air (MBA) network (sync) issues in Logos while Safari access to forum web site works when Wi-Fi is enabled:

Repeated on MBA so attached archive includes snippet from All Messages (after turning Wi-Fi on):

4024.Archive_Sync_Error_after_sleep.zip

Now to reboot MBA so sync can connect.

Keep Smiling Smile

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sat, Jan 14 2017 10:52 AM

Logos 7 thread => Searching for where God is called Shepherd has reply by Armin => https://community.logos.com/forums/p/134651/876601.aspx#876601

Armin:

Keep Smiling 4 Jesus :):

Doing same search in Logos 7 for Everything includes "Fuzzy Bible Search" for Now members and Cloud+ subscribers that has 102 verses: Fuzzy Bible Search needs online connection plus can return verse results from Bibles not in your Library:

Thanks for the suggestion. I am a Now member and tried your suggested search. However, Logos hangs and the search never completes. Here is a sample:

4743.God as Shepherd Search.zip

Logos.log file in zip shows Logos 7.3 SR-2 running on macOS 10.12.2 with history sync errors.

Keep Smiling Smile

Posts 800
Armin | Forum Activity | Replied: Sun, Jan 15 2017 2:21 AM

I experience exactly the same problem and reported it here:

https://community.logos.com/forums/p/131602/876702.aspx

Hopefully, Logos can find a solution to it as it gets annoying when not having a reliable internet connection.

Page 1 of 1 (10 items) | RSS