How long have I been under a rock?

Page 2 of 2 (36 items) < Previous 1 2
This post has 35 Replies | 0 Followers

Posts 285
David Gullick | Forum Activity | Replied: Tue, Apr 6 2010 5:31 PM | Locked

I just tried this to open to Hell in the NNTB, when I right clicked on the hyperlink though it opened Logos3 to the home page??   What am I doing wrong?

Logos Platinum

Windows 7 - 64 Bit
Lenovo laptop E520 i7-2640M, 2.8GHz 8G Ram, 2G Graphics

Australia

Posts 35547
Forum MVP
MJ. Smith | Forum Activity | Replied: Tue, Apr 6 2010 5:33 PM | Locked

The precedent between L3 and L4 depends upon the order of loading. Do a search on the forums on modifying your registry and follow the instructions.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 5337
Kevin Becker | Forum Activity | Replied: Tue, Apr 6 2010 5:37 PM | Locked

David Gullick:

I just tried this to open to Hell in the NNTB, when I right clicked on the hyperlink though it opened Logos3 to the home page??   What am I doing wrong?

wiki.logos.com/hyperlinks has instructions for modifying your registry to make the libronixdls protocol point towards Logos 4.

Posts 5337
Kevin Becker | Forum Activity | Replied: Tue, Apr 6 2010 5:38 PM | Locked

steve clark:

so is it working correctly in 4.0c ?

Does it actually open the specific resource? (even if it is a Bible which is not your preferred Bible)

The specific link I created and tested (to a non-bible resource) worked just fine.

Posts 285
David Gullick | Forum Activity | Replied: Tue, Apr 6 2010 5:50 PM | Locked

thanks

EDIT: From the wiki -

To fix this manually open Registry Editor, navigate to HKEY_CURRENT_USER\Software\Classes\libronixdls\shell\open\command, and change the (Default) value to:
"C:\Users\USERNAME\AppData\Local\Logos4\Logos4.exe" %1

 

I don't appear to have the folder 'libronixdls'     I do have L3 installed.   Forgive my ignorance

Logos Platinum

Windows 7 - 64 Bit
Lenovo laptop E520 i7-2640M, 2.8GHz 8G Ram, 2G Graphics

Australia

Posts 9552
Forum MVP
Mark Smith | Forum Activity | Replied: Tue, Apr 6 2010 8:49 PM | Locked

steve clark:
so is it working correctly in 4.0c ?

As far as the limited testing I've done, yes.

steve clark:
Does it actually open the specific resource?

Since you create a link from a specific resource, yes. Note that creating a hyperlink isn't the same thing as adding a note to a Bible or another resource. One noticeable difference is that no little yellow square appears next to the text you created the hyperlink to as happens when you add a note to a resource.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 59
Todd White | Forum Activity | Replied: Tue, Apr 6 2010 9:12 PM | Locked

Philip Spitzer:
No more paste to word---format---paste back to notes!!!! How in the world did I miss this?

Funny, I thought we made sure we mentioned this in the last release notes ... look at that we kind of did.

For Rich Text Editor:

  • Backspace at the end of a hyperlink will delete the hyperlink.
  • When pasting, the entire chunk of text is searched for auto-detect hyperlinks.
  • Cursor no longer jumps to random locations in the document after paste.
  • When the rich text editor loses focus (e.g. tab between title and content in note) auto detect will run on the last word the cursor was adjacent to.
  • Images and other unsupported content are removed on paste.
  • Hyperlink auto-detection will now work across multiple text element runs, that is the string “Gen 1” with a bold ‘e’ will be auto detected.
  • Ctrl-Z in a newly opened note will not remove the note content.
  • Fixed several app crashes induced by pasting specific content into the notes rich text editor
  • Hyperlinks will be preserved when copy/pasted within the rich text editor.

 

Really we do try to listen to you guys. You can thank Scott Alexander for doing the hard work of making the editor better. There should be a few more fixes in the next few releases too.

Posts 3578
steve clark | Forum Activity | Replied: Tue, Apr 6 2010 9:37 PM | Locked

Thanks Kevin & Mark !

QLinks, Bibl2, LLR, Macros
Dell Insp 17-5748, i5, 1.7 GHz, 8G RAM, win 8.1

Posts 3810
spitzerpl | Forum Activity | Replied: Wed, Apr 7 2010 3:32 AM | Locked

Todd White:
Funny, I thought we made sure we mentioned this in the last release notes ... look at that we kind of did.

Now, now. It's obvious that you buried it. I was waiting for a phone call with the news. Smile

Posts 2745
Bohuslav Wojnar | Forum Activity | Replied: Wed, Apr 7 2010 3:42 AM | Locked

Philip Spitzer:

Todd White:
Funny, I thought we made sure we mentioned this in the last release notes ... look at that we kind of did.

Now, now. It's obvious that you buried it. I was waiting for a phone call with the news. Smile

YesBig Smile

Bohuslav

Posts 5337
Kevin Becker | Forum Activity | Replied: Wed, Apr 7 2010 3:50 AM | Locked

David Gullick:
I don't appear to have the folder 'libronixdls'     I do have L3 installed.   Forgive my ignorance

Try this location: HKEY_CLASSES_ROOT\Software\Classes\libronixdls\shell\open\command, I don't understand why but sometimes the registry key is in different places in the registry. If it isn't there run a search on your registry for Libronixdls until you find the folder(s) with the appropriate key.

Posts 5337
Kevin Becker | Forum Activity | Replied: Wed, Apr 7 2010 3:52 AM | Locked

Todd White:
Funny, I thought we made sure we mentioned this in the last release notes ... look at that we kind of did.

When I read these I didn't interpret them as applying to the hyperlink box.... not that this matters, I'm glad it works now! Smile

Posts 9552
Forum MVP
Mark Smith | Forum Activity | Replied: Wed, Apr 7 2010 6:35 AM | Locked

Todd White:
For Rich Text Editor:

What's that?? I don't have it listed in my tools menu. How do I get one??

You programmers need to learn to talk user and them we'd understand. (Maybe.)

Thanks for fixing it.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 285
David Gullick | Forum Activity | Replied: Wed, Apr 7 2010 8:59 AM | Locked

Kevin Becker:

David Gullick:
I don't appear to have the folder 'libronixdls'     I do have L3 installed.   Forgive my ignorance

Try this location: HKEY_CLASSES_ROOT\Software\Classes\libronixdls\shell\open\command, I don't understand why but sometimes the registry key is in different places in the registry. If it isn't there run a search on your registry for Libronixdls until you find the folder(s) with the appropriate key.

Found the right folder and changed the data according to the wiki but still couldn't get it to work. Deleted L3, now have no libronixdls folder in my registry editor but hyperlinking still doesn't work?

This is definitely something that will need to be fixed for the official releases of 4.0c.

 

Logos Platinum

Windows 7 - 64 Bit
Lenovo laptop E520 i7-2640M, 2.8GHz 8G Ram, 2G Graphics

Australia

Posts 5337
Kevin Becker | Forum Activity | Replied: Wed, Apr 7 2010 9:32 AM | Locked

David Gullick:

Found the right folder and changed the data according to the wiki but still couldn't get it to work. Deleted L3, now have no libronixdls folder in my registry editor but hyperlinking still doesn't work?

This is definitely something that will need to be fixed for the official releases of 4.0c.

The hyperlink protocol is something that is interpreted by Windows which then sends the information to the program. Uninstalling Libronix probably removed the Libronixdls protocol from your computer thus making the hyperlinks unintelligible to Windows. Did you run the find tool to look for other occurrences of the \libronixdls\shell\open\command?

I can only recommend re-installing Libronix and then looking through each occurrence of libronixdls. Some people have gotten it to work without including the "" around the path to the Logos 4 exe.

This is an issue with two programs making changes to this registry key. It appears that Logos 4 doesn't modify the key after initial installation where as Libronix may check it when it updates.

Posts 285
David Gullick | Forum Activity | Replied: Wed, Apr 7 2010 4:19 PM | Locked

I did have a look for other occurrences of the folder and right path. Tried it with and without the "".  It puzzles me that L4 needs L3 though. So L4 hasn't the ability to hyperlink on its own yet. And changing the registry key isn't so much a case of re prioritizing hyper linking t oL4, but L4 actually borrows the ability from L3?

I'll wait around a bit and see if an upcoming release enables hyperlinking without the use of L3

Logos Platinum

Windows 7 - 64 Bit
Lenovo laptop E520 i7-2640M, 2.8GHz 8G Ram, 2G Graphics

Australia

Page 2 of 2 (36 items) < Previous 1 2 | RSS