L5.0 SR-4 Bug: Reading plan & visual markup don't match

Page 1 of 1 (14 items)
This post has 13 Replies | 2 Followers

Posts 1210
Ward Walker | Forum Activity | Posted: Tue, Nov 20 2012 11:48 AM

I saw this same bug in L4 from time to time, but was surprised it is in L5 too; I'm reading along in a reading plan, click the "Mark Read" banner, and my reading plan updates to show that item is complete...but the text where I am reading doesn't...it still shows "Mark Read" for the just-done part.  I usually have to close the layout and re-open it in order to clear the problem (this bug doesn't always happen though).  A screenshot follows:

Posts 25351
Forum MVP
Graham Criddle | Forum Activity | Replied: Tue, Nov 20 2012 12:01 PM

Hi Ward

Sorry, but what exactly is the problem?

The "Mark Read" indicator in the text seems to be aligned with what your plan document is showing.

What do you expect to happen?

Graham

Posts 3163
Dominick Sela | Forum Activity | Replied: Tue, Nov 20 2012 12:56 PM

Graham Criddle:
Sorry, but what exactly is the problem?

 

I think what he is saying is that on the left the reading thru chapter 25 has NOT been clicked yet, it says "Mark Read", yet on the right it shows  that reading is completed.

Posts 1210
Ward Walker | Forum Activity | Replied: Tue, Nov 20 2012 2:55 PM

Dominick Sela:

Graham Criddle:
Sorry, but what exactly is the problem?

 

I think what he is saying is that on the left the reading thru chapter 25 has NOT been clicked yet, it says "Mark Read", yet on the right it shows  that reading is completed.

Yes

Posts 777
Brisa Davis | Forum Activity | Replied: Mon, Dec 3 2012 2:00 PM

I'm having some trouble reproducing this issue. Have you been able to find specific steps that more consistently cause this to occur?

Logs of this occurring would be helpful. You can find instructions for getting logs here: http://wiki.logos.com/Diagnostic_Logging

Posts 1210
Ward Walker | Forum Activity | Replied: Wed, Dec 5 2012 8:14 PM

Brisa Calderon:

I'm having some trouble reproducing this issue. Have you been able to find specific steps that more consistently cause this to occur?

Logs of this occurring would be helpful. You can find instructions for getting logs here: http://wiki.logos.com/Diagnostic_Logging

No, and here recently it hasn't happened again.  I've now perm enabled logs: I'll keep an eye out and post logs if I see it again.

Posts 687
Jon | Forum Activity | Replied: Wed, Dec 5 2012 8:24 PM

Ward Walker:
I'm reading along in a reading plan, click the "Mark Read" banner, and my reading plan updates to show that item is complete...but the text where I am reading doesn't...it still shows "Mark Read" for the just-done part.

I see this occasionally, I reckon it happens maybe 1/20 readings? I'll post logs when I next see it too...

Posts 1210
Ward Walker | Forum Activity | Replied: Fri, Dec 28 2012 1:17 PM

Brisa Calderon:

I'm having some trouble reproducing this issue. Have you been able to find specific steps that more consistently cause this to occur?

Logs of this occurring would be helpful. You can find instructions for getting logs here: http://wiki.logos.com/Diagnostic_Logging

OK, it took a long time for me to notice it, but it just happened...unfortunately, my logs are rather massive...

 

Posts 1210
Ward Walker | Forum Activity | Replied: Fri, Dec 28 2012 1:30 PM

Well, it appears that the Log file is too big to post to the forum, so I e-mailed it to Customer Service...hopefully it isn't too big for e-mail!

...and it appears I just went over 1K posts....*that* took a few years! Wink

Posts 27255
Forum MVP
Dave Hooton | Forum Activity | Replied: Fri, Dec 28 2012 1:48 PM

Congratulations - does that mean you get about 333 problems a yearBig Smile

Dave
===

Windows 11 & Android 8

Posts 1729
LogosEmployee
Hunter Clagett | Forum Activity | Replied: Sat, Dec 29 2012 11:00 AM

Thank you for the logs! I have submitted them to our developers for review.

 

 

- Hunter Clagett

Logos 4 Bug Report - Mac | PC

Proclaim - Mac/PC

Posts 1210
Ward Walker | Forum Activity | Replied: Mon, Dec 31 2012 1:34 PM

Hunter Clagett:

Thank you for the logs! I have submitted them to our developers for review.

It just happened again:

The Log file is larger than the Forum will let me upload, so I'll e-mail it....

Posts 1210
Ward Walker | Forum Activity | Replied: Thu, Jan 10 2013 6:41 PM

I've discovered an interesting tidbit:  When the "reading bar" gets stuck, if I go to a different monitor and in a different window mark up some text and highlight it, then the "Reading bar" gets unstuck first, and shows "Start Reading" correctly.

 Perhaps this helps to debug what is going on.

Posts 777
Brisa Davis | Forum Activity | Replied: Fri, Jan 11 2013 10:15 AM

Thank you, I will add that information to the case.

Page 1 of 1 (14 items) | RSS