BUG: Selection Glitch (6.1 b2 Mac 10.10.2)

Page 1 of 1 (15 items)
This post has 14 Replies | 1 Follower

Posts 27681
Forum MVP
JT (alabama24) | Forum Activity | Posted: Thu, Jan 22 2015 9:31 PM

Another forum member was having difficulties with making selections, so I tried to replicate the issue. I don't know if I was fully successful in replicating his exact issue (see this thread), but if not I think I found a (related?) bug. 

In the screen shot below, notice the panel on the right has a passage highlighted. I had only double clicked on a single word. Sometimes the selection created is VERY lengthy (i.e. more than a chapter in length).

Here are the steps to replicate: In a bible with a RI turned ON, double click on a word. It may take a few tries, but it is fairly easy to replicate.

Here are some logs: 8664.LogosLogs.20150123-002155.zip

OSX & iOS | Logs |  Install

Posts 27681
Forum MVP
JT (alabama24) | Forum Activity | Replied: Sat, Jan 24 2015 6:11 AM

bump

OSX & iOS | Logs |  Install

Posts 27681
Forum MVP
JT (alabama24) | Forum Activity | Replied: Sun, Jan 25 2015 6:13 PM

B ump

OSX & iOS | Logs |  Install

Posts 162
LogosEmployee
Chris Culy (Faithlife) | Forum Activity | Replied: Mon, Jan 26 2015 11:22 AM

I have tried double-clicking every word in the selection you have above and also in another resource and have not been able to reproduce the issue. Could you post a screencast of the issue occurring? Thank you.

Posts 1573
Forum MVP
Levi Durfey | Forum Activity | Replied: Mon, Jan 26 2015 11:45 AM

I got it to occur twice. But I had to double-click a single word in the KJV 1900 something like 25-35 times.

Posts 27681
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Jan 26 2015 12:26 PM

Chris Culy (Faithlife):
Could you post a screencast of the issue occurring?

Sure.

Click here to play this video

OSX & iOS | Logs |  Install

Posts 27681
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Jan 26 2015 12:28 PM

I don't know how that screen cast turned out when I uploaded it. Let me know if you need something else. 

FWIW - I double clicked on the word "return". I single clicked on the other words. Also, you might want to let the other forum member know you are looking into the problem.

OSX & iOS | Logs |  Install

Posts 27681
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Jan 27 2015 4:34 AM

 bump

OSX & iOS | Logs |  Install

Posts 162
LogosEmployee
Chris Culy (Faithlife) | Forum Activity | Replied: Tue, Jan 27 2015 9:21 AM

I was able to reproduce the issue now, thanks! The fix I implemented for the issue reported here: https://community.logos.com/forums/t/99348.aspx resolves this issue. Please follow that thread for updates on when the fix will ship publicly. Thank you!

Posts 27681
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Feb 4 2015 12:06 PM

This issue is not fixed:

OSX & iOS | Logs |  Install

Posts 162
LogosEmployee
Chris Culy (Faithlife) | Forum Activity | Replied: Wed, Feb 4 2015 3:59 PM

I'm sorry you're still experiencing the issue. I will take another look when I get in tomorrow. Just double-checking: are you running 6.1 Beta 4 or higher?

Posts 27681
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Feb 4 2015 6:06 PM

I am running 6.1 b4. 

EDIT: I see that b5 is out. If I find that it fixes the issue, I will report back.

OSX & iOS | Logs |  Install

Posts 162
LogosEmployee
Chris Culy (Faithlife) | Forum Activity | Replied: Thu, Feb 5 2015 2:00 PM

I'm sorry. I have not been able to reproduce the issue again. If I remove my fix (which shipped in beta 4), I can reproduce the issue immediately, so I am at a loss as to what you are experiencing.

If you are still seeing this on beta 4/5, can you take another screencast? Again, sorry for this and I hope we can get it sorted out soon.

Posts 27681
Forum MVP
JT (alabama24) | Forum Activity | Replied: Thu, Feb 5 2015 2:29 PM

Chris Culy (Faithlife):
If you are still seeing this on beta 4/5, can you take another screencast?

Sorry I didn't get back with you earlier. It took me a while to get the download to finish and then I forgot what I was doing. Embarrassed

I am in a hurry now so I won't be able to get a screencast right away. I can tell you that 1) yes, the issue persists on b5 and 2) it is more difficult to reproduce. It was easier to reproduce before. After about 5 minutes of clicking, I got something similar to the screen shot below only twice. On 4-5 occasions, however, I received something <slightly> different. When double clicking on words on the first line of the panel, I would get a selection that was 2-3 lines ABOVE (and including) the selected word. I tried to reproduce after I grabbed the screen shot below, but it wouldn't cooperate.

OSX & iOS | Logs |  Install

Posts 54
Michael Sheaver | Forum Activity | Replied: Mon, Feb 9 2015 4:15 PM

I was having the same problems myself on my MacBook Pro running OS X 10.10.2, and just wanted to confirm that the newly released 6.0b SR-3 fixed the problems. The highlighting is working much better with an more natural feel/behavior. This was a great example of teamwork between the developers and the user community, and I offer a sincere shout-out to everyone! 

Page 1 of 1 (15 items) | RSS